PDA

View Full Version : Connecting to a DNS-323 NAS via smb


jeremya
October 28th, 2008, 02:43 AM
I just got an Apple TV this past weekend and I got Boxee installed. I was trying to connect to my DNS-323 via Smb, but it keeps failing to connect. My first guess is it has something to do with the fact smb asks for a username and password.

Anyone have any experience with the DNS-323?

Thanks,

Jeremy

marcel
October 28th, 2008, 06:09 AM
hi jeremya

how are you trying to connect ? did you try settings>media sources> networks ..can you see the share..if not try to add manually just the IP ..

iBog
October 28th, 2008, 09:37 AM
I have an Apple TV and the DNS-323.

Under the ADVANCED | NETWORK ACCESS tab, all I did was create a share with read and write access for all. In the SETUP | DEVICE I set the workgroup as "workgroup".

On the root of the DNS-323 I created a MEDIA folder where I put all of my movies, music and photos. I really should change the permissions on my root share and create a read only share directly to the MEDIA folder.

Regardless, once you do the above, you should see it from your apple tv. Let me know how it works for you.

jeremya
October 29th, 2008, 01:03 AM
Ok I tried how iBog suggested and it seems to crash my Apple TV... very strange.

marcel
October 29th, 2008, 05:42 AM
hi jeremya

what error are you receiving ? this could happen due to a media content or format?what content are you sharing?

jeremya
October 29th, 2008, 09:08 AM
hi jeremya

what error are you receiving ? this could happen due to a media content or format?what content are you sharing?

Status 4 I believe was the error. The share I created has one MP4 file in it.

I get an error 2 share not available when trying view my new source and then Boxee crashes with a status 4. It will also crash like this randomly until I remove the source.

-- Jeremy

marcel
October 29th, 2008, 09:12 AM
what is the MP4 file ..you can pm me if you like..:)

marcel
October 29th, 2008, 09:13 AM
sorry ..have you tried settings>videos>general ..uncheck "automatically generate thumbs..."

jeremya
October 29th, 2008, 10:28 AM
sorry ..have you tried settings>videos>general ..uncheck "automatically generate thumbs..."

Yeah I saw that in another thread as the cure all for crashing... and I unchecked it, but it still crashes.

-- Jeremy

marcel
October 29th, 2008, 10:57 AM
remove the share and try again..

jeremya
October 29th, 2008, 11:57 AM
remove the share and try again..

From the DNS or from Boxee?

-- Jeremy

agentlame
October 29th, 2008, 12:04 PM
from boxee.

jeremya
October 29th, 2008, 12:57 PM
Ok I will try again again tonight, but I did remove and add the share several times last night.

-- Jeremya

cwills
November 12th, 2008, 03:14 PM
Did you get this working? I have the same setup and receive the same error messages.

jeremya
November 21st, 2008, 01:41 AM
Never did get it working... I was hoping 4166 would fix the issue, but it still exists...

cl5ltd
November 21st, 2008, 06:25 PM
I have the DNS313 and did not have to make any changes at all for xbmc or boxee to see and use this netwrok drive.

Have you checked in the DLink setup for anything that may be preventing access to the drive?

Robusto
January 30th, 2009, 07:22 AM
I have DNS-323 with 1.06 firmware. User setup as "appletv" with password "appletv" with read access to a media folder (/Video) containing subfolders of videos etc. DNS-323 is on 192.168.1.100.

If I goto add Network media source then i see the DNS-323 in the list. I click it and it and select the "Video" share then it asks for the user and password. I enter user appletv and [ass appletv. I click ok and I get: "Error Invalid Argument".

If I try to add the source manually as a video source:

smb://appletv:appletv@192.168.1.100/Video

It says source added successfully. When I then goto Videos -> Browse -> (Select the name of the source I manually added) it says "Loading Error Failed to retrieve data".

I turned off auto generating thumbs as media source is read only - no joy.

To prove Im not an idiot and the appletv user and pass work correctly I booted XBMC and added the source without problems using the same source:

smb://appletv:appletv@192.168.1.100/Video

Any ideas? Im close to giving up on boxee (I dont want to as it looks awesome) as I can't get my media into it.

Thanks all.

Robusto
January 30th, 2009, 07:49 AM
Update: I tried adding all user read access to the whole DNS-323. Now when I scan for devices I get "Error 2: share not available"

Robusto
January 30th, 2009, 10:36 PM
Are there any logs I can look at to help the resolution? I'm happy to do any testing towards a stable product, rather then simply for my own setup.

PS: hey, great job... all this for free? wow, amazing.

stevenrushing
March 25th, 2009, 02:57 PM
Has anyone gotten the DNS323 to work with boxee yet? I am running latest boxee on a Mac, trying to get it to talk to my DNS 323. My wireless is through an Airport Extreme, the new one, and connected to it is my DNS323, xbox and VUDU (all wired) and my mac and touch and a couple of laptops wireless. The xbox using XBMC streams conted perfectly from the DNS323, but my Mac keeps saying various errors like "invalid source" and "no media found".