PDA

View Full Version : ssh appletv using putty


hiroller83
December 14th, 2009, 12:35 AM
Hello, I'm having trouble ssh into my Apple tv. I'm using windows xp sp2. Can anyone help me out with this? Does the patchstick need to be plugged in the ATV? I get "Network error: Connection Timed out" when try to use the ATV ip address. If anyone can list the settings needed to properly connect, that would be great?

Thanks in advance

gdezeeuw
December 14th, 2009, 03:05 AM
Seems like you didn't patch your apple tv at all. First you need to run the patchstick and yes this should be in the usb port of your ATV.

After the patching process you should be able to gain ssh acces.

Another option is that you using a wrong ip[adress, but doesn't seem the case. But try appletv.local instead of your ip.

hiroller83
December 14th, 2009, 08:44 AM
I tried appletv.local but got "Host name invalid". How do I know if the patchstick worked probably? I see a login prompt on my tv.

hiroller83
December 14th, 2009, 09:03 AM
i used atv usbcreator 2.0 and checked the ssh box in the window. I used the ATV 3.0.1 dmg file.

liquid64
December 14th, 2009, 12:17 PM
I tried appletv.local but got "Host name invalid". How do I know if the patchstick worked probably? I see a login prompt on my tv.

You should probably find out the real IP address of your appletv. You can go to the native AppleTV OS, and choose: Settings.. General.. Network, and you will find the IP address there.

hiroller83
December 14th, 2009, 07:12 PM
yea did that as well its 192.168.0.100 DHCP still get issues

gdezeeuw
December 15th, 2009, 08:24 AM
I would suggest running the patchstick again.

Check on the screen, while booting the patchstick, if the whole patching processs goes without errors. It should not take longer then a few minutes.

After that SSH should be enabled. But isn't a router or firewall setting is blocking the traffic? Try connecting your laptop straight to your ATV and check if that works.

Goodluck

hiroller83
December 16th, 2009, 01:10 PM
ok thanks i was able to ssh into atv. Now my issue is with wget. i get this error message.

Resolving atv-xbmc-launcher.googlecode.com... failed: No address associated with nodename.

any thoughts?

hiroller83
December 16th, 2009, 01:18 PM
i downloaded the run file to my desktop is there a command where i can point putty to?

gdezeeuw
December 17th, 2009, 03:10 PM
Is your ATV connected to a network? Is it wired or wireless connected?

Did you check if you have a connection at all? Settings- General Network within the orginal apple menu. Check if you have a dns ip.

What command did you use to download?

And yes offcourse you can download it and put it up manually but you need a connection anyway to run boxee or it's content.

Check your setting first.

timtucker
December 18th, 2009, 06:48 AM
Is your ATV connected to a network? Is it wired or wireless connected?

Did you check if you have a connection at all? Settings- General Network within the orginal apple menu. Check if you have a dns ip.

What command did you use to download?

And yes offcourse you can download it and put it up manually but you need a connection anyway to run boxee or it's content.

Check your setting first.

Sounds to me like gdezeeuw has it pegged. Your ATV doesn't seem to be getting all the necessary IP/DNS info from your router/Access point. Is it safe to assume you have other computers working on the same network? If so you may need to check your router/Access point configuration. If you download the file using another computer you can transfer it to the ATV using a program like filezilla. ( Or any other program that can do SFTP ) PM me if you want and I'll help ya' out. I have a lot of experience with networking and linux/unix.