PDA

View Full Version : Where do subtitle fonts live?


SanSan
November 1st, 2008, 10:43 AM
Hi,

I am running Boxee on my ATV but I want to watch my films with traditional chinese subtitles. As far as I am aware only certain fonts are able to display the chinese characters correctly (at the moment my chinese subtitles are a mixture of squares and other odd characters).

Does anyone know the directory location where I can copy the appropriate font files to, so that the chinese characters will display correctly?

Thanks.

agentlame
November 1st, 2008, 10:48 AM
while not entirely the same thing, this may be worth reading:
http://forum.boxee.tv/showthread.php?t=1312&highlight=chinese

SanSan
November 1st, 2008, 10:53 AM
Hi,

Thanks, but I have tried that. It works ok for menu items in Boxee but it does not fix the subtitle problem.

Thanks for the prompt reply though!

marcel
November 1st, 2008, 12:12 PM
hi SanSan

go to settings>videos>subtitles and change charset to chinese..:)

Apek
November 1st, 2008, 06:38 PM
This might help:

http://forum.boxee.tv/showthread.php?t=1005&highlight=subtitles

SanSan
November 2nd, 2008, 02:11 AM
Hi!

Still no luck - can't get Chinese subtitles to display!

Marcel: I went to settings>videos>subtitles and changed the charset to Chinese Traditional (Big 5) - but this didn't work. I also went to settings>appearance>region and changed the charset to Chinese Traditional (Big 5) there too in case - but that didn't work either.

Apek: I have tried putting some different font files in /Library/Fonts but they do not show up in settings>videos>subtitles>fonts - so I am unable to select them?

Actually, settings>videos>subtitles>fonts, by default, shows about 17 fonts but when i look in /Library/Fonts there are only about 4 font files in there. So I am not sure how 17 show up - are some font files stored somewhere else on the system?

So i think that I am still in a situation where I need to copy across a font that can handle chinese characters but i don't know where to store the font file and i dont know how to make it show up in the drop-down list under settings>videos>subtitles>font so that i can select it.

Thanks.

marcel
November 2nd, 2008, 03:22 AM
usually it takes the font from the OS try this path and add the font here

/Applications/Boxee.app/Contents/Resources/Boxee/media/Fonts

/Applications/Boxee.app/Contents/Resources/Boxee/skin/Boxee Skin NG/Fonts

SanSan
November 2nd, 2008, 03:58 AM
and still no luck! :-(

stuck a couple of font files (Apple_LiHeiPro.ttf and LiHeiProPC.ttf) in both of the directories that you suggested. rebooted the ATV. and neither of them show up under the drop-down list at settings>videos>subtitles>fonts???

Cheers.

marcel
November 2nd, 2008, 04:17 AM
can you send me the LiHeiProPC.ttf font ..

marcel
November 2nd, 2008, 04:25 AM
also do you have the font in your appletv at /Users/<username>/Library/Fonts

SanSan
November 2nd, 2008, 09:15 AM
Marcel,

I have sent you a PM concerning download of the LiHeiProPC.ttf.

I have tried putting the font files at /Users/<username>/Library/Fonts (well kind of, as every time i click on /Users my ftp client redirects to /mnt/Scratch/Users/ so i actually had to copy the fonts to /mnt/Scratch/Users/frontrow/Library/Fonts) - this hasn't worked either.

Some more details in case they are useful:
1. I am trying to watch a .avi on my ATV. The .avi is located on my iMac and is streaming via SMB. The .avi plays fine.
2. The subtitle file is a .srt which is located at the same place as the .avi on my iMac and is named the same as the .avi.
3. I am able to see the name of the .srt file displayed in Boxee under settings>audio&subtitle>audio>subtitle
4. At present, I am not able to see any subtitles displayed when watching the avi - not even English.

Cheers, B.

SanSan
November 3rd, 2008, 09:47 AM
After some experimentation I have come up with a work-around though this still leaves me with a question.

First the work-around:
This will allow traditional chinese subtitles to be displayed. Copy the contents of the LiHeiProPC.ttf into the TimesNewRomanBold.ttf (you might wanna keep a copy of the original TimesNewRomanBold.ttf). Copy the altered TimesNewRomanBold.ttf to /Library/Fonts. You can now go to settings>videos>subtitles>fonts in Boxee and select 'Times New Roman Bold' and your subtitles can now be displayed in Chinese (or English) depending on which .srt's you have stored with your film and have selected in Boxee (under settings>audio&subtitle>audio>subtitle).

Note: You also need to select the appropriate charset from the drop-down list in Boxee at settings>videos>subtitles>charset to match the encoding of your .srt. For example if your .srt is encoded in 'Big 5' then you need to select 'Chinese Traditional (Big 5)' from settings>videos>subtitles>charset.

Next my question:
Simply putting the LiHeiProPC.ttf into /Library/Fonts doesn't work as it does not show up under settings>videos>subtitles>fonts in Boxee (thus you can't select it). So how do you get new fonts that you add to /Library/Fonts to show up in the drop-down list at settings>videos>subtitles>fonts in Boxee? Or where should you put new fonts so that they show up in the drop-down list at settings>videos>subtitles>fonts in Boxee?

Cheers.

kelvin88
November 23rd, 2008, 08:15 AM
How about filename? I'm new to boxee and seems like I can't get filename in chinese display correctly.