PDA

View Full Version : four questions


wesmcbride
February 9th, 2010, 09:20 PM
I have four questions that are hard to search because I don't know how to simply word them:

1 - Sometimes when playing movies for the first time, there is a static/stuttering/buzzing/clicking type of noise. I will stop the movie play another one just fine, then go back to the original and it plays fine. Why is that?

2 - Is there a time limit on what boxee plays movies for? Some movies that I have, stop short of the ending. I have to go to my computer to finish them.

3 - Is there a way to make fast forwarding easier/faster?

4 - Some movies, ie District 9, have necessary subtitles. They don't show up, even though I have the .srt. What's with that?

**All movies are .avi's being played wirelessly from an iMac. atv is version 3.0.1, connected with HDMI to tv. All files are full length and have no sound issues when being played on iMac**

If you have any answers to one or all of the questions I would appreciate it.

Thanks in advance.

snbloch
February 10th, 2010, 09:58 AM
In order to address your question #2, if you're sharing your media via SMB protocol from the Mac to the ATV then the maximum supported filesize is going to be 2GB for any single media file.

Assuming you are running OS X 10.6.x on the Mac, this is a limitation of the Snow Leopard Operating System (and I believe the same limitation is found in 10.5.x Leopard as well). What you most likely are experiencing is that the AppleTV is addressing up to the 2GB mark in the file, and then the SMB read is being terminated which will make your playback via Boxee on the ATV stop abruptly in the middle of the file.

There won't be any issues with playback of the media on the local filesystem of the Mac that you are using as the "server" in this instance, which you have observed.

The ways to resolve this would be:
1) Downgrade the "server" to a version of the OS that has SMB compiled with Large Filesystem Support
2) Use NitoTV and Smart Installer in conjunction with an AppleTV 1.0 recovery disk image to enable AFP protocol file sharing, which does not experience this limitation
3) Use NitoTV to enable USB disk support and plug an external hard drive in to the AppleTV directly
4) Copy the files to the AppleTV internal hard drive via SCP before you watch them

Hope this helps!

wesmcbride
February 10th, 2010, 01:21 PM
Thanks. I was using SMB before.

Now I have it set up to play movies from the usb hard drive that is plugged into the atv (recommendation 3).

Is there a way to send new files to that hard drive from my iMac while it is still with the atv? Or do I have to plug it into the iMac to transfer files to the drive?

JimWiley
February 10th, 2010, 03:00 PM
Thanks. I was using SMB before.

Now I have it set up to play movies from the usb hard drive that is plugged into the atv (recommendation 3).

Is there a way to send new files to that hard drive from my iMac while it is still with the atv? Or do I have to plug it into the iMac to transfer files to the drive?

If you can get hold of a valid 1.0 recovery.dmg, place it in ~/Documents on your ATV along with a 10.4.9 Combo update (download from iClarified) and run Turbo's Kext Enabler and Nito's smart installer from the Nito menu, then you will enable the AFP server on your ATV. This will advertise your ATV drive and USB drive via Bonjour to all Macs on your network. You will then be able to drag and drop files from your iMac into the Folder in a Finder window and it will be copied via your network to your USB drive on your ATV. Simple!

Alternatively, you can use Cyberduck to easily copy files over your network to your ATV's USB drive.

Jim

wesmcbride
February 11th, 2010, 07:33 AM
Thanks,
So I put everything where you said, but when I try to enable AFP in the nitoTV settings I get AppleFileServer missing or something like that. Is there something else that I should have done or can do?

JimWiley
February 11th, 2010, 08:29 AM
Thanks,
So I put everything where you said, but when I try to enable AFP in the nitoTV settings I get AppleFileServer missing or something like that. Is there something else that I should have done or can do?

where did you get your 1.0 recovery from? you need to find a file called something like OS-dot-DMG 1.0.dmg on the internets.

1) locate OS-dot-DMG 1.0.dmg via Google. Download it


2) after downloading to your Mac, you should open a terminal, navigate to Downloads and run:

md5 'OS-dot-DMG 1.0.dmg'

It should return:

55b909196952ff72c93aaf3553cf661e

if the number is different to this, then it's the wrong file! Do not use it! You'll know you have the right file when you can md5 it and get that number.

3) Now we need to create a recovery.dmg, here's how:

SSH into your ATV and run:

sudo dd if=/dev/disk0s2 of=recovery.dmg bs=1m

this will create a recovery.dmg based on your current recovery firmware number. Don't worry about this, we'll be modifying it.

4) Use Cyberduck to copy this recovery.dmg to your mac. Delete the file left on the ATV - we no longer need that one. Mount the recovery.dmg on your mac and navigate to it via the Finder sidebar. Inside there is a file called OS.dmg - delete it. Then empty the trash on your Mac to truely remove it - this is important to successfully achieve the next step. Rename your downloaded OS-dot-DMG 1.0.dmg to OS.dmg and pop it inside the Mounted Recovery image in the place of the one you deleted. Unmount the image and you should be left with a recovery.dmg that contains a 1.0 firmware.

5) Using cyberduck copy this file back to the /Users/frontrow/Documents/ folder on your ATV and then from the NitoTV Menu run

nitoTV --> Settings --> Install Software --> Install Turbo's Kextloader

then run:

nitoTV --> Settings --> Install Software --> Smart Installer

Don't bother installing anything else. Then, when finished:

6) reboot your ATV by SSHing in and running:

sudo reboot

7) Your USB drive should mount automatically on your ATV as usual. On your iMac you should now see AppleTV in the shared section of the Finder Sidebar. You should also make sure that your Finder preferences are correctly set so that shares like these show up automatically:

Go to Finder --> Preferences --> Sidebar

and make sure all entries under SHARED are ticked

8) Select AppleTV in the Finder sidebar. Select Connect As from the top right hand side and use username frontrow, password frontrow and you should see a list of drives, something like:

frontrow
{your usb drive}
Media
OSBoot

9) Click on your usb drives name and you should be able to navigate through it as if it was a drive on your iMac. Just drag and drop files between finder windows to copy.


Finally don't be discouraged if the first OS-dot-DMG 1.0.dmg you download has the wrong MD5 - just discard it and find another download - keep googling for OS-dot-DMG 1.0.dmg. Remember - once you've done it once you can keep a copy on your mac and then you can repeat it everytime you have to restore your ATV to the factory settings (I also keep a copy of the 10.4.9 combo update handy for this reason, although this is readily available from Apple anyway)

Good luck!

Jim

maximusfacq
February 11th, 2010, 09:01 AM
Didju try the setting in nitoTV?

nitoTV > Settings > Utilities > Services > AFP Access > Off/On

wesmcbride
February 11th, 2010, 11:16 AM
I am working on the steps in post #6 by Jim.

Step 4 we have a problem; the new OS.dmg is 207.5 MB, the mounted recovery only has 198.9 MB available, it won't copy over. What went wrong/how to fix?

JimWiley
February 11th, 2010, 01:01 PM
I am working on the steps in post #6 by Jim.

Step 4 we have a problem; the new OS.dmg is 207.5 MB, the mounted recovery only has 198.9 MB available, it won't copy over. What went wrong/how to fix?

Does your downloaded OS have the right MD5 checksum? It should fit inside the recovery.dmg once you remove the existing OS.dmg. Your downloaded 1.0 file should be about 198 MB from memory, but it's the checksum that's important - don't skip that step! If it's not the same - you have the wrong file and none of this will work...

Jim

wesmcbride
February 11th, 2010, 02:12 PM
the md5 resulted in the right checksum. I am downloading another file that claims to be 197.9 MB...Hopefully it works, if not I'll be asking another question. You have been very helpful. I apologize for my retardedness.

JimWiley
February 11th, 2010, 04:13 PM
the md5 resulted in the right checksum. I am downloading another file that claims to be 197.9 MB...Hopefully it works, if not I'll be asking another question. You have been very helpful. I apologize for my retardedness.

Lol! Don't worry about it... This procedure is a lot more faffing about than most people are used to. I find it strange that the first file you downloaded was the wrong size, but had the right MD5 hash - that's something I've never heard of before. If you alter a file, then you alter the MD5. That's why MD5 hash checking stops you getting a potentially malicious file. Especially in a case like this where you have to get a file from RS or Pirate Bay and don't know what someone may have done to it....

I'll extract my OS.dmg and see what size it is and re-verify the checksum for you....

Jim

UPDATE: have check inside my recovery.dmg and the OS.dmg it contains is 197MB. If you do

ls -alh

in the directory that contains your downloaded OS.dmg, then it lists the filesize information as 'human readable' i.e. In KB, MB, GB, etc. Your OS.dmg should be listed as 197M in the output from this command (plus it should have the right MD5 hash)

hope that's helpful?

Jim

wesmcbride
February 13th, 2010, 08:57 PM
Just as an FYI, the reason why the new OS.dmg didn't fit, is that I didn't empty my trash so the space from the old OS.dmg wasn't free. Simple fix.

JimWiley
February 14th, 2010, 01:46 AM
Just as an FYI, the reason why the new OS.dmg didn't fit, is that I didn't empty my trash so the space from the old OS.dmg wasn't free. Simple fix.

Doh! I should have caught that.... it's been a while since I've done it myself and these are the little things that you forget over time....

Is it all working for you now? Don't forget to keep a copy of the 10.4.9 combo and the recovery.dmg spare on one of your PC/Mac's and then next time you're forced to do a factory restore (it happens!) you'll be up and running in two seconds flat!

Jim

wesmcbride
February 14th, 2010, 09:22 AM
I am now connected to the appletv. However, it when I try to copy files over, it says that the appletv cannot be modified???

maximusfacq
February 14th, 2010, 10:26 AM
Don't worry about it... This procedure is a lot more faffing about than most people are used to.


ROFLMAO!!! That's hilarious! Keep fighting the good fight peeps. :D

danGIMP
February 14th, 2010, 01:01 PM
I am now connected to the appletv. However, it when I try to copy files over, it says that the appletv cannot be modified???

"We're here to help."

Exactly what step/command/procedure are you attempting and specifically what is the error message? Are you trying to copy your new "recovery.dmg" from your MAC to your ATV? Are you trying to copy this to your /Users/frontrow/Documents folder?

wesmcbride
February 14th, 2010, 02:58 PM
Everything is set up and the AppleTV is a shared drive. Thank you Jim, your patience was much appreciated. When I went to drag a file over to place it in the USB mounted drive I got an error saying that the AppleTV cannot be modified or something like that. I rebooted the AppleTV and it still had a circle with a diagonal line through it as in no dragging files to the drive.

Turns out I have to actually copy and paste the files that I want to be in the drive.


Thanks again to everyone that helped me. Maybe this will help out another lost person with their AppleTV.

wesmcbride
February 14th, 2010, 05:48 PM
So questions 2 and 3 have been answered, thanks to everyone.

About question 4; I have .avi's that have the .srt in the same folder that the .avi. Subtitles do not show up for some reason. Does anyone know why or how to fix it?

danGIMP
February 14th, 2010, 06:24 PM
So questions 2 and 3 have been answered, thanks to everyone.

About question 4; I have .avi's that have the .srt in the same folder that the .avi. Subtitles do not show up for some reason. Does anyone know why or how to fix it?

I'm assuming that by your question, other movies are showing with correct subtitles but a few aren't?

Does the name match exactly (.srt match with the .mkv or whatever file?)?
If you're playing the video and then open the audio settings, did it identify the subtitle file? Is there a relevant error in ~/Library/Logs/boxee.log that points to an error with subtitles?

maximusfacq
February 14th, 2010, 06:28 PM
Ewww... not sure on this one. I write the subtitles into the movie file with my encodes. That works like a charm. I would have to defer to others that use the .srt files. :(

JimWiley
February 15th, 2010, 04:53 AM
So questions 2 and 3 have been answered, thanks to everyone.

About question 4; I have .avi's that have the .srt in the same folder that the .avi. Subtitles do not show up for some reason. Does anyone know why or how to fix it?

I have a few foreign language films in my collection and all use .srt files. A few things you have to do, first make sure they are in the same directory and have the same filename as your movie file. Second, make sure that subtitles are turned on in settings:

1) On a per film basis: Play your movie and press play a second time to bring up OSD. Press the up arrow and right arrow to select the 'cog'. Press the right arrow to select the audio and press play. Scroll downwards with the down arrow and highlight 'enable subtitles' and press play once to select the checkbox. This will enable subtitles for this film only. You can now back out by pressing the menu button back to the film, or if you want this setting by default then don't back out, go to (2):

2) For all films: As per (1) above, but scroll right down to the bottom of the list to highlight 'Set as default for all movies' and press play once to select.

If this does not work, then something has gone terribly wrong! Terribly, terribly wrong! But, try that first and then come back if it doesn't work (or even if it does - let us know!)

Jim

wesmcbride
February 28th, 2010, 08:54 AM
ANother quick question, how do you make it so that boxee uses the USB drive to be local media, that way the movie data is there?

JimWiley
February 28th, 2010, 09:16 AM
ANother quick question, how do you make it so that boxee uses the USB drive to be local media, that way the movie data is there?

Are you asking how to enable the USB port? You need to run turbo's enabler and the smart installer from the Nito Menu.

If you're asking how to get Boxee to scrape your content: Go to Settings --> Media --> Add Local Source and navigate to the folder on your USB drive where your media is. Then click add and select media type and scanning frequency. It'll take a while for Boxee to scrape your media, depending on how many movies you have... just leave it a while...


Jim

wesmcbride
February 28th, 2010, 09:48 AM
the usb drive has been selected for a few days as a local source, nothing loads. but the media is there when i browse for it.

JimWiley
February 28th, 2010, 10:26 AM
the usb drive has been selected for a few days as a local source, nothing loads. but the media is there when i browse for it.

Check the settings for the source:

1) Is it selected as a private source? If this is selected, deselect it.

2) What is the scanning frequency? Scan once, scan frequently? Select scan frequently

3) How are your movies and tv shows named - incorrectly named shows will not scrape, make sure they are named according to the following:

http://forum.boxee.tv/showthread.php?t=5214

Beyond that, if these three things are right, then it should be able to scrape your folder...

Jim

wesmcbride
February 28th, 2010, 12:07 PM
the source is not private.
where is the scan frequency option?
everything is named correctly.