PDA

View Full Version : mount usb hfs hdd


nnichde
February 25th, 2010, 06:44 AM
Hi Community !
I`ve patched my ATV with patchstick.ca and would love to mount my HFS formated USB HDD . So I installed the 10.4.9 Combo Update via Smart Installer in NitoTV. Now i can see my Harddisc with disktuil list :

/dev/disk1
#: type name size identifier
0: FDisk_partition_scheme *1.4 TB disk1
1: Apple_HFS loch 1.4 TB disk1s1

but there is no automount :

mount:

/dev/disk0s3 on / (local, journaled)
devfs on /dev (local)
fdesc on /dev (union)
<volfs> on /.vol
/dev/disk0s4 on /mnt (local, journaled)

So i tried to mount it myself:

sudo mount hfs /dev/disk1s1 /anywhere OR
sudo mount_hfs /dev/disk1s1 /anywhere OR
sudo diskutil mountdisk /dev/disk1s1 /anywhere

but nothing happens. Sometimes i get errors like:
mount_hfs: Device not configured
now I`m out of Ideas....any help ?

thanks a lot and greets from Germany

Markus

nnichde
February 25th, 2010, 06:56 AM
oh, i forgot to tell:
my ATV uses 3.0.1 firmware
the patchstick.ca is 3.0.1e
and i want to use the harddrive to store my Movies on it to see it in Boxee and XBMC

JimWiley
February 25th, 2010, 07:23 AM
oh, i forgot to tell:
my ATV uses 3.0.1 firmware
the patchstick.ca is 3.0.1e
and i want to use the harddrive to store my Movies on it to see it in Boxee and XBMC

Did you run Turbo's enabler from Nito's Installer menu? I think you will require this to enable kext loading. Then you probably should re-run the smart installer, then you MUST reboot (hard reboot is sometimes needed - i.e. turn off power and then back on) for the necessary kext's to be run to allow mounting. Any attached USB drives will then automount at boot.

Hope this helps!

Jim

nnichde
February 25th, 2010, 07:39 AM
Hi Jim !
thanks for fast posting :)
Unfortunately I`ve already installed the Turbo`s Kextloader . I think that all kext are loaded correctly...which kext are the important ones for USB mount ?
looking at kextstats i found a lot of loaded kext. For example:
...
com.apple.iokit.IOPCIFamily (2.1) <11>
com.apple.iokit.IOACPIFamily (1.2.0) <11>
com.apple.driver.AppleACPIPlatform (1.0.6) <17 16 11 6 3>
com.apple.iokit.IOGraphicsFamily (1.4.6) <16 6 5 4 3>
com.apple.iokit.IOUSBFamily (2.8.5) <6 5 4 3>
com.apple.driver.AppleUSBSupport (2.8.5) <20 4 3>
com.apple.driver.FPHwA (1.0.3) <6 5 4 3 2>
com.apple.BootCache (27.0.80) <6 5 4 3 2>
com.apple.iokit.IOHIDFamily (1.4.9) <6 5 4 3 2>
...
so, i dont believe that the problem is here .
any suggestions ?

by the way: hardrebooting seems to be my hobby ;)

JimWiley
February 25th, 2010, 08:24 AM
IOUSBMassStorageClass.kext, IOStorageFamily.kext, and IOSCSIArchitectureModelFamily.kext are the three that deal with usb, I think!

If you have those loaded, you should be able to mount it! In fact, mine has always automount on boot since the first time I ran Turbo's Enabler and then the Smart Installer and rebooted. If you have done a reboot and it still doesn't work, then I would remove /etc/rc.local (unless you've made custom additions to it), re-run the enabler, re-run the smart installer and reboot (i.e. basically start at the start).

Not sure what else to suggest?

Just for comparison, my rc.local looks like:

/sbin/turbo_atv_enabler.bin
/sbin/kextload -v /System/Library/Extensions/IOCDStorageFamily.kext
/sbin/kextload -v /System/Library/Extensions/IODVDStorageFamily.kext
/sbin/kextload -v /System/Library/Extensions/msdosfs.kext
/sbin/kextload -v /System/Library/Extensions/IOUSBMassStorageClass.kext
/sbin/kextload -v /System/Library/Extensions/AppleSMBIOS.kext
/sbin/kextload -v /System/Library/Extensions/IOSCSIArchitectureModelFamily.kext
/sbin/kextload -v /System/Library/Extensions/IOStorageFamily.kext
/sbin/kextload -v /System/Library/Extensions/cddafs.kext
/sbin/kextload -v /System/Library/Extensions/smbfs.kext
/sbin/kextload -v /System/Library/Extensions/udf.kext
/sbin/kextload -v /System/Library/Extensions/IOBluetoothFamily.kext
/sbin/kextload -v /System/Library/Extensions/IOBluetoothHIDDriver.kext
/sbin/kextload -v /System/Library/Extensions/IOHDIXController.kext
/sbin/kextload -v /System/Library/Extensions/ntfs.kext
/sbin/kextload -v /System/Library/Filesystems/fusefs.fs/Support/fusefs.kext
/sbin/kextload -v /System/Library/Extensions/BroadcomCrystalHD.kext

Perhaps you can compare it with yours (you will not need fusefs.kext or BroadcomCrystalHD.kext in your rc.local for this. Bluetooth obviously has no bearing on this issue either, nor does smbfs or CD/DVDStoragefamily...)

Jim

JimWiley
February 25th, 2010, 08:30 AM
Just got this regarding post-install from AwkwardTV:

Now when you plug in a USB disk, your drive's partitions will be mounted at /Volumes/. If your disk was plugged in from the beginning the process or has been rebooted you will need to unplug it and plug it back in and the drive will mount at /Volumes/.

seems like you must reboot, then unplug and re-plug your disk and it will automatically mount. Next time you reboot, this process should happen automatically?!

Give it a go and let me know...


Jim

danGIMP
February 25th, 2010, 02:18 PM
Just got this regarding post-install from AwkwardTV:

Now when you plug in a USB disk, your drive's partitions will be mounted at /Volumes/. If your disk was plugged in from the beginning the process or has been rebooted you will need to unplug it and plug it back in and the drive will mount at /Volumes/.

seems like you must reboot, then unplug and re-plug your disk and it will automatically mount. Next time you reboot, this process should happen automatically?!


you shouldn't have to unplug/replug if you have the following


sudo defaults write \
/Library/Preferences/SystemConfiguration/autodiskmount \
AutomountDisksWithoutUserLogin -bool true