PDA

View Full Version : Does the UPNP *client* work?


akshunj
March 23rd, 2010, 06:55 PM
I've read a bunch of conflicting posts on this, so I'd like to hear some actual experiences. Has anyone successfully used UPNP? The linux subforum says it doesn't work. But a couple of Mac users seem to be blissfully using it.

I just set up MediaTomb on my home server, and I have verified that it works by using VLC. In fact it is the smoothest media experience I have ever had. I just enable UPNP in VLC, and in a few moments it finds all of the files I added to MediaTomb. Streaming is perfect. No skips, pauses or stutters.

When I tried to use UPNP for Boxee, I went into setup and searched UPNP shares, but there was nothing. Then I tried to manually add the IP, but I kept getting a "connection timed out" error. I even tried to edit the guisettings file, to "True" for the UPNP client, but this was already done, so no dice.

And, before anyone suggests it, I don't use SAMBA. In general, I have had horrible streaming experiences with it. And the setup is more than a pain. MediaTomb took 5 minutes to set up and works like a champ with VLC.

Anyway, what kind of experience is everyone else having with this feature?

--Akshun J

darcilicious
March 23rd, 2010, 07:02 PM
My UPnP sources come and go (so far I have Orb's server, SimplifyMedia which uses Bonjour, and Windows Home Server) as does my ability to actually make use of them when they do show up.

Possibly the biggest issues you're running into are various network related bugs. I know that SMB in a primarily Windows environment is probably impacting my ability to use UPnP consistently. I'm Very Eagerly awaiting the next release because I believe the networking bits will be working much better.

What OS are you on -- you kind of implied Linux but I didn't want to assume and since you posted in the general boxee help forum... it's hard to know for sure :)

agentlame
March 23rd, 2010, 07:23 PM
Should be working fine.

Here is an example of a Linux user using it:
http://forum.boxee.tv/showpost.php?p=59612&postcount=54

From the Netflix thread:
http://forum.boxee.tv/showthread.php?t=3385&page=2

What are your examples of it NOT working on Linux?

BTW, I am also assuming you're using Linux, based on your post. If the question is 'Is the UPnP client working [on Linux]', this should have been posted in the Linux forum.

darcilicious
March 23rd, 2010, 07:55 PM
We-elllll... those are some pretty old posts, Mr. Agent Man :) Samba broke with the very first public beta release but worked fine up until then. So there may be some UPnP issues that have cropped up as well with beta...

akshunj
March 26th, 2010, 09:54 PM
Should be working fine.

Here is an example of a Linux user using it:
http://forum.boxee.tv/showpost.php?p=59612&postcount=54

From the Netflix thread:
http://forum.boxee.tv/showthread.php?t=3385&page=2

What are your examples of it NOT working on Linux?

BTW, I am also assuming you're using Linux, based on your post. If the question is 'Is the UPnP client working [on Linux]', this should have been posted in the Linux forum.

My example of it NOT working on Linux is ME, myself and I. Again, it works fine in VLC, so I know it's not a network issue. I could be wrong, but I thought that UPnP was OS agnostic. If it's working on Mac, it should be working on Linux, right? But I suppose since there is different *Boxee* functionality between platform versions, perhaps UPnP just isn't implemented in Linux.

And, thanks for the reply Agent Lame, but the examples you linked to are from the Alpha. I have not read of any successes with the Beta. That's why I'm asking...

darcilicious
March 26th, 2010, 10:08 PM
Can you browse to any of the media via the Files function in Boxee? Something like Files / Network / UPnP / "source" / media files ?

I just tried to browser to a folder of mp3 files via Orb's UPnP service and got "no results found" after selecting a particular folder.

Edit: I had better luck with some other UPnP service on my Windows Home Server (twonky maybe, definitely not the Windows Media Connector one though).

akshunj
March 28th, 2010, 12:34 PM
Can you browse to any of the media via the Files function in Boxee? Something like Files / Network / UPnP / "source" / media files ?

I just tried to browser to a folder of mp3 files via Orb's UPnP service and got "no results found" after selecting a particular folder.

Edit: I had better luck with some other UPnP service on my Windows Home Server (twonky maybe, definitely not the Windows Media Connector one though).

Nope, I tried that too. It's a MediaTomb UPnP server, BTW. I go to files/network/upnp/ and then immediately get "no results found". And again, VLC sees the server fine and streaming works perfectly. Not sure what the deal is with Boxee.

darcilicious
March 28th, 2010, 12:43 PM
Yeah, wonky UPnP via Boxee -- probably worth reporting via jira if UPnP is important to you. Note that a lot of Boxee functions are supported via UPnP and that may go for resolving / index content items (tv shows, movies, etc), though I'm not sure. I know that the "share" option is not available on items via UPnP playback (when browsed via Files / Network).

Yono
March 29th, 2010, 12:33 AM
I'm having a similar problem. My situation is that I am running mediatomb off my linux box, and boxee on my WinXP box.

Unlike the OP, I can access my mediatomb share through the file browser, but after I added the network share to my music and video libraries, it says Not Connected and won't scan them to add to my libararies.

Accessing through the file browser is a decent temporary solution, but causes me to miss out on much of the boxee functionality. Any suggestions?

darcilicious
March 29th, 2010, 12:38 AM
The next release *may* address the no connection error... from what I've been following samba has been the issue they've been most trying to address; not sure what the status of UPnP is. I'd wait for the next beta version and if there are still problems with UPnP, then post a bug report...

Linezilla
April 9th, 2010, 09:49 PM
Just ran Boxee 09.20.10708 on Windos 7, trying to access MediaTomb UPNP share and the intermittent UPNP connection bug is occuring for me as well.

akshunj
April 12th, 2010, 11:25 PM
UPNP is definitely still broken on the latest version. I will post a bug report on jira.

On the other hand, SAMBA seems to be working well for streaming via the file browser...

dconti
April 16th, 2010, 06:52 PM
Thanks for all of the problem reports. If you can confirm that your UPnP server is accessible some other way (opening Windows Media Player if you are on vista/w7 or have wmp11 on xp) that will also help out.

Also is there a bug in jira for this?

Thanks

Linezilla
April 17th, 2010, 08:22 AM
UPNP disconnects happening over here, with the Early Release 0.9.21.1141 as well. :(

chief_p
April 25th, 2010, 07:45 AM
Not working for me as well. I'm using the TwonkyMedia upnp server and Boxee seems to discover it okay, however after connecting it just says disconnected.

I'm using a mac mini as my HTPC and running Plex for my media center software. Plex has no issues connecting to my TwonkeyMedia upnp server.

Upnp support is critical for me, as I don't want to maintain multiple music libraries for different rooms around the house. I was looking forward to getting the boxee box for another room in my house, however if it won't connect to my upnp server that will be a deal breaker for me.

Paul

dconti
April 25th, 2010, 08:51 PM
Thanks Paul - looks like twonky media has a free trial, i'll check this out either later today or sometime tomorrow.

dconti
April 26th, 2010, 10:45 PM
Everything works consistently through the file browser for everyone, correct ? Or do people experience disconnects and interruptions when loading content through the file browser?

darcilicious
April 26th, 2010, 10:50 PM
I have not had problems accessing / playing files via the file browser on either Vista or Windows 7.

Also, Twonky media server came installed on my HP MediaSmart Server and Boxee has no problems connecting to it, letting me browse and even play media (primarily audio) files (I've disable video content via Twonky as it is also used for externally streaming content as well).

dconti
April 27th, 2010, 11:59 AM
I went through things with twonky yesterday a bit. I had no issues with pictures, music, or video through the file browser. Everything enumerated and played just fine.

If i go to, say, music and try to add something off the twonky server as a source, that works but after a while it shows the twonky server as disconnected. This is because scanning UPnP libraries as a media source does not work.

If anyone is hitting issues with UPnP through the file browser i definitely want to know, as there is likely a specific bug happening that can be fixed. If it's all through add a UPnP source, then all bets are off in the near term, but it's on the short list of things to improve.

Thanks

chief_p
April 28th, 2010, 07:51 AM
I was adding a upnp source under media. I will try using the file browser tonight. Thank you for the quick reply on this issue.

Paul

chief_p
April 29th, 2010, 06:51 AM
The file browser works fine for me connecting to my upnp server. Can't wait for the boxee box.

Paul