PDA

View Full Version : HDMI - Audio low



vikasa
May 24th, 2010, 01:23 PM
Latest Boxee on Toshiba A505 laptop running Windows 7 64-bit connected to Toshiba Regza HDTV using HDMI cable to view a DVD backed up as a ISO file on local machine. F5 display mode is set to "HDMI only".

The video looks great but couple of issues with the audio. a) The TV's remote control doesn't control the audio and more importantly b) the audio output is quite low. Even when all audio slider controls (laptop's Output Device, Boxee volume control, etc) are set to max, the sound is still quite low.

Clicking on taskbar Volume Control/Mixer shows Boxee under Applications with volume slider at max. Changing default device from analog/speakers to Realtek Digital Audio doesn't make any differerence (except that the Boxee section on Volume Control dissapears)

Any ideas? Thanks

ikjadoon
May 24th, 2010, 02:20 PM
Realtek, eh? Same as me. :)

Mine is called ATI HDMI Output (as I have an ATI GPU). Try this:

Right-click the volume button and go to "Playback Devices". Enable and set the default to your HDMI audio (Digital Output, HDMI Output, whatever it's called) by right-clicking that device. Then double-click and wander through the tabs and max out all the volume tabs you find.

Try to disable Enhancements, too?

vikasa
May 24th, 2010, 02:40 PM
OK will try that and let you know.

Any idea why the TV remote doesn't control the volume? When I connect, say, a DVD player via the TV's HDMI-in, I am able to use the TV remote to control the volume, how is this any different? Thanks

ikjadoon
May 24th, 2010, 04:08 PM
I think your TV remote controls the volume of the speakers, not the volume of the output device. The DVD player is always outputting at 100% volume. Thus, any change of the volume of the speakers controls the volume overall.

However, the computer is different. You need to control its output as well as the volume of the speakers. Your TV remote only controls the volume of the speakers. It can't control the 5% volume of the computer. Make sense?

~Ibrahim~

vikasa
May 24th, 2010, 05:11 PM
Understood. Which is why I was not expecting to increase the volume using the TV remote. But whatever volume the computer is pumping into the TV speakers, I would have expected to be able to *reduce* using the TV remote. The fact that the TV remote had absolutely no effect on the overall volume was a little surprising to me.

christoff
May 24th, 2010, 07:47 PM
I have a similar issue, running Boxee latest beta on my dedicated HTPC, HDMI output from Nvidia GF210 to my Panasonic AVR. I also have XBMC on the same machine, same exact hardware, etc, and the difference in volume levels is huge, like 10-15 db between what XBMC outputs as very loud versus Boxee. I found a few threads here about setting boxee's gain levels higher, but see nowhere in setting to do this. Also it was suggested to disable mixer in ffdshow audio settings, but made no difference.

Any other ideas?

ikjadoon
May 25th, 2010, 12:02 AM
@vikasa

Ah...right, right. How about moving between 0% and 1% volume via the TV remote? Does that make a difference?

@christoff

Huh...maybe this is a larger issue? I couldn't find a setting in Boxee, either.

And this is a Boxee-only issue for you guys? Like this low HDMI volume doesn't carry over to other Windows programs?

christoff
May 25th, 2010, 12:45 AM
Yes, it only seems to be evident when playing Boxee.

My AVR's gain level shows the difference between when I play media in XBMC (audio is loud enough at -29 setting)
For Boxee, I have to turn up gain to around -10 to equal it.
That is a BIG difference !

ikjadoon
May 25th, 2010, 12:54 AM
Weird...I did notice that Boxee was quieter than my other programs, but just turned up the speakers.

Move to bugs forum?

christoff
May 25th, 2010, 08:08 AM
Probably a good idea. It's definitely a bug from where I stand . Switching between sources without remembering to dial down your gain could result in some ear/equipment damage.:(

christoff
May 25th, 2010, 04:40 PM
posted

please add your input, specs, etc

http://forums.boxee.tv/showthread.php?t=18420

vikasa
May 30th, 2010, 08:26 PM
OK here's an update.

Windows 7 x64, latest Boxee, Toshiba Satellite A505 laptop connected using HDMI output to Toshiba HDTV's HDMI in.

When the HDMI connection is made, right-clicking on the taskbar Volume icon shows up a new device called TSB-TV (Intel Display Device).

I tried all combinations a) choosing this TSB-TV under Boxee Setting/Audio Hardware and b) setting this TSB-TV as the default device in Windows and choosing Primary Sound Device under Boxee Settings/Audio Hardware and c) choosing Realtek Digital Audio in Boxee settings.

All volume sliders are set to max. Now when I launch Boxee, I get the startup sound/jingle nice and clear from the TV speakers which is great. But when I play any media (music, video files) the sound output is extremely low, I have to put my ear right next to the TV speakers to hear it. When the default device is set to TSB-TV and I play MP3 files from the hard drive, they place loud and clear from the TV speakers so this seems to be a Boxee problem.

Restarting both Boxee and even rebooting the laptop at various points along the way doesn't change the behaviour.

Help? Thanks

christoff
May 30th, 2010, 11:12 PM
Another thing I noticed is that the Boxee navigation sounds
are way louder than the music & video tracks played within Boxee.

christoff
June 2nd, 2010, 07:19 PM
update
I decided to wipe my HTPC clean & install Win 7 Pro 32 bit.
Put Boxee back on, & audio levels are OK now <shrug>