PDA

View Full Version : web server on windows 7


jago.taylor
September 20th, 2010, 06:19 AM
Hi,

I have just started using Boxee and just wanted to say that I am very impressed. It's a really good media server app!

However, I can't seem to get the Boxee iphone remote working and I think the issue is with the web server. In summary:

1. Installed latest boxee build on windows 7 ultimate PC. All good. up and running fine

2. Confirmed web server enabled and on port 8800 in boxee settings

3. installed iphone remote app but can't find host (either automatic or manual) NOTE: connected over wifi and both iphone and Boxee PC are on same subnet

3b. I have switched off windows firewall on the boxee PC

4. tried safari browser on iphone but can't connect to http://IP_boxee:8800 or http://IP_boxee:8800/iphone

5. tried IE browser on Boxee PC but can't connect to http://IP_boxee:8800 or http://IP_boxee:8800/iphone

So I think there is a problem with the web server on my boxee PC.

My questions:

Do I need to enable the win7 web server (IIS) or does boxee use a built-in web server?

Is there a log file I can look at? If so where can I find this and do I need to switch logging on?

Any other tips would be appreciated..

Many thanks,
Jago

dadein
September 20th, 2010, 09:35 AM
Hi and welcome to Boxee! :)

I believe Boxee uses its own web server.
To get a debug log see this (http://boxee.zendesk.com/entries/136404-i-ve-been-asked-by-boxee-support-to-send-debug-logs-how-do-i-do-that).

jago.taylor
September 20th, 2010, 01:02 PM
OK so I have made some progress.

I checked if the deault directory for the web server existed in my installation folder:

C:\program files\boxee\web (on windows 7 install)

and i noticed that the folder 'Web' was missing. After creating this folder, I can access the folder using http://localhost:8800

So I have tried to reconnect using the boxee iphone remote app but still no luck.

Browser on iphone can't view http://Boxee_IP:8800 either...

Anyone have any ideas?

darcilicious
September 20th, 2010, 01:14 PM
I have the iPhone remote app working fine. I do NOT have a "web" folder in my Boxee install directory and I cannot connect to http://localhost:8080/

I don't think the web server is related to the iPhone app at all.

Have you enabled debug (http://boxee.zendesk.com/entries/136404-i-ve-been-asked-by-boxee-support-to-send-debug-logs-how-do-i-do-that) logs yet, per the first followup to your post?

dadein
September 20th, 2010, 01:25 PM
Not sure what you are doing, but the normal Boxee install does not include a 'Web' folder, AFAIK.
And I am not sure what you have tried but maybe this will help ...

(original post by marcel)
1. Make sure Boxee is running on your PC.

2. Make sure that the Web server is enabled and the port is set to 8800(default) on Boxee (Settings>Network>Servers)

3. Make sure your iTouch / iPhone is connecting to wifi that is on the SAME subnet as your boxee machine. Note: If it's using edge / 3g internet connection, then it will NOT be able to connect to Boxee

Troubleshooting:

1. Use Safari on your iTouch / iPhone to call up the Boxee app's web-based interface by typing the IP address of the Boxee host & port number(e.g http://192.168.2.1:8800/). If that doesn't work, then your handheld device isn't on the same subnet.
2. Make sure the Web Server Password is empty.

darcilicious
September 20th, 2010, 01:46 PM
I don't think the web server is related to the iPhone app at all.

And I'm a big fat liar ;)

If I disable the webserver (settings / network) the remote app won't find/connect to Boxee.

So, you do have some sort of connection error between your iPhone and the PC running Boxee...

If a web browser (not the Boxee web browser) on the PC can't reach http://localhost:8800 try also http://IPADDRESS:8800/ from the same PC that's running Boxee.

If that doesn't work we definitely need to see the debug logs...

jago.taylor
September 20th, 2010, 04:44 PM
Thanks all for the suggestions - i have tried most of this already - but really appreciate the help.

In summary:

latest boxee build on win 7 32bit - working fine - first ever install so s/be clean
iphone on same subnet as boxee over wifi

iphone brower to http://boxee_ip:8800 = fail - cant connect
iphone brower to http://boxee_ip:8800/iphone/ = fail - cant connect

note the below are from the boxee pc - and boxee is running
boxee browser IE to http://boxee_ip:8800 = fail - can't display web page
boxee browser IE to http://localhost:8800 = fail - can't display web page

If I add the folder named 'web' to the boxee main install directory a directory listing web page is displayed (nothing to list though!) i.e.

boxee browser IE to http://boxee_ip:8080 = OK - displays empty directory list page

Note: when i searched through the forums (not sure if windows board) i read a thread that mentioned the 'add the web folder'. anyway...

Still can't connect from iphone using boxee remote app.
Also no luck using safari on iphone on http://boxee_ip:8800

So log file attached. log level = debug - new log file from boxee start-up

any futher help appreciated.

thanks
jago

adricha
October 11th, 2010, 03:38 PM
I am having the same problem. Cannot access boxee using iphone remote or web browser on iphone or pc. Both devices are most definitely on the same subnet and firewall is open.

My debug log also attached??

subvertbeats
November 4th, 2010, 12:50 PM
exact same issue here guys - im trying to experiment with getting sick beard to update boxee via its xbmc webserver interface.

phikai
November 4th, 2010, 01:04 PM
Have you guys checked firewalls in your router...might need to forward the ports for it to work properly...

subvertbeats
November 5th, 2010, 04:13 AM
Have you guys checked firewalls in your router...might need to forward the ports for it to work properly...

remote access isnt even in the equation, all this is on localhost

phikai
November 5th, 2010, 07:50 AM
remote access isnt even in the equation, all this is on localhost

Just a thought, your router could be fairly restrictive to internal traffic and ports, more unlikely, but a place to check.

Also...is something else on your system's using the port? As opposed to scanning have you just tried manually entering the ip address and port of the machine running boxee?

subvertbeats
November 16th, 2010, 04:06 AM
As I said, this is all on localhost :/

enigma
November 16th, 2010, 05:06 AM
Im running Boxee on Windows 7 Professional & am able to connect to the Boxee web interface using Android remote app 'Boxee'
The web server interface was already checked in the Boxee settings by default.
The issue might well not be Win 7 related for you guys.

Dems
December 16th, 2010, 06:48 PM
Any news on this?

I can get the XBMC Commands to work, such as...
> http://192.168.0.102:8800/xbmcCmds/xbmcHttp?command=GetVolume


But I can't get the iphone page to respond...
> http://192.168.0.102:8800/iPhone


I just get...
> Access Error: Site or Page Not Found
>
> Cannot open URL



Please note: if xbmcCmds is working, it is not port issues, firewall issues, router issues, or anything along those lines.



Cheers,
Dems

Prospero424
December 16th, 2010, 07:45 PM
Well, the Android app works fine on all three of my machines. Haven't tested the iPhone app, but I imagine that it would work as well unless there's been some change to it or the iPhone software itself.

Perhaps it's an iPhone/app-related issue and not a Boxee-related issue?

For those above who have seemingly tried everything else: have you done a clean reinstall of Boxee?

darcilicious
December 16th, 2010, 09:31 PM
But I can't get the iphone page to respond...
> http://192.168.0.102:8800/iPhone


I'm not even sure that's a valid URL. My iPhone Boxee remote is connected just fine to my Windows 7 install of Boxee. But if I go to http://localhost:8800/iPhone I get the same message...

Access Error: Site or Page Not Found

Cannot open URL

That mean there is no page / folder with that name that the web server knows about.

triffle
December 16th, 2010, 09:41 PM
As I said, this is all on localhost :/
LOL

No issues with the android boxee remote app, who maintains the iphone app? Have you tried their forums/support site?