PDA

View Full Version : Connected hard drive has no available space


Nall
November 12th, 2010, 06:31 PM
I just picked up a brand new 2tb drive (default formatted to fat32) for the boxeebox since my old one wasn't being detected at all, when I plug it in and add it it seems to work fine, but when I connect to it from my macbook via boxee's SMB server, it only shows 312 megs free on it.

I can upload as many files as I want under this size and the total size available will never change. Is there any way to fix this so it understands there are 2TB on this thing?

Nall
November 12th, 2010, 07:09 PM
I've since tried connecting multiple devices (SD card still says 300 megs of space even though it has 8 gigs) and connecting to the drive directly via SMB instead of to the boxee first. It's clearly using the onboard storage space as the available space for everything, is there any way to fix this or a workaround?

gschep
November 13th, 2010, 08:41 AM
Having the same issue. A 'work around' that I found is if you copy a directory you get the error regarding the available space. Boxee creates the directory, then copy the directory again and it prompts you to replace existing directory - hit replace and bob's your uncle....

Works for me this way - was just coming on here to find out if it's a bug? or design feature? lol Hopefully it's something that is going to be 'fixed'

mariusp
November 13th, 2010, 08:55 AM
Yep, same thing going on here. I'll try the replace directory trick but still... pretty annoying. I hope this gets fixed.

gschep
November 13th, 2010, 04:08 PM
has anybody reported it as a bug? or are we setting it up 'wrong'?

StevenR
November 20th, 2010, 07:33 AM
Until this bug is fixed, here is another workaround for anybody with a Mac who prefers to use Finder to copy the files (The cp command in Terminal does not have the problem):

1) Create a folder on your local disk called "Automatically Add To Boxee"
2) Open up Automator and create a new Folder Action workflow.
3) Choose the "Automatically Add To Boxee" folder as the folder the workflow will be applied to.
4) Add a "Move Finder Items" action to the workflow with the destination folder set to a folder on the shared drive - I created an "Incoming" folder on the drive specifically for this.
5) Save the workflow with whatever name you want.

Now whenever you copy files to "Automatically Add To Boxee" they will be moved to the shared drive, and you can use Finder to move them to whatever folder you want (using the list view in Finder makes this easier).

shayz
November 20th, 2010, 08:28 AM
Hi,

This is a known issue and the fix will be released in one the upcoming releases.

--shay