PDA

View Full Version : Subtitles nowhere to be found


Sadres
November 12th, 2010, 06:52 PM
Despite detecting subtitles, they seem to not be appearing. At all. A little difficult to watch foreign films, at the moment.

floodland
November 12th, 2010, 07:10 PM
I added subtitles using the little search thing for opensubtitles.org and then couldn't turn them off without leaving the movie and going back in. I think the subtitles are just broken.

dijama
November 12th, 2010, 07:13 PM
to be more specific - .srt subs work and render, but .ass subtitles are recognized but not rendered. I'd assume that this is an issue with rendering embedded fonts, or alternatively, boxee box just isnt capable of rendering these subs despite claiming to. :mad:

Sadres
November 12th, 2010, 08:21 PM
Yeah, it's detecting but not rendering my embedded subtitles - talk about growing pains, this needs a patch and fast.

EDCVO
November 12th, 2010, 09:36 PM
(sigh) Seriously. One of the reasons I got this was so I wouldn't have to re-encode every piece of anime I watch and burn the subtitles in.

My MKVs are playing fine, but even with subtitles enabled ... nada.

Guess I'll see what happens if I extract the subtitles as a separate file (and convert to .srt, no?) and hope that works as at least a temporary, if annoying, workaround.

UPDATE - Yeah, that works - extract the subs and rename them as exact file name, and go with .srt. If you're on a MAC, use iMkvExtract to extract and Jubler to save as .srt. Just make sure you get the framerate correct.

Sadres
November 12th, 2010, 10:50 PM
I'm sure a fix will come along - hopefully sooner rather than later.

AzureSky
November 13th, 2010, 02:38 PM
This was driving me crazy as well and I figured out the problem (at least for me).

1.) Go into the Settings/customize Boxee menu under General go to Display -> screen format & overscan, go over to advanced.

2.) This will take you to an advanced version of the display setting from when you first set up the box. Click through arrow 1 (upper left corner) and arrow 2 (lower right corner). This will take you to the bottom of the screen where there is a line with two arrows pointing down at it. This indicates where your subtitles will show up on the screen.

3.) Move the line wherever you want it from the bottom to the middle of the screen (sorry no top of the screen for you unconventional folks). I aligned the *blue line* with the bottom edge so it was just barely visible on the screen and then clicked/moved it up 5 spaces & have not had a problem since

4.) Another option is to Got into the Settings/customize Boxee menu then under Media go to Subtitles and you can adjust the size and color of your subtitles.


Now if only Boxee would make it easier and faster to toggle when watching a show that is dual audio. It seems to take 3 to 5 clicks to change audio/subtitle and then at least 5 min of waiting for it to switch/toggle from 1 language to another with subtitles.


*FYI if you have no idea what I mean when I say Settings/customize Boxee menu. If you hit the back button enough times you will get a see through layered navigation menu that will give you the time/temp in the upper right corner (home, search, media options, local file all in a row to choose from in the middle) in the upper left hand corner is the log out/shutdown button and the Settings cog icon/button.

kenjisugahara
November 14th, 2010, 04:53 AM
UPDATE - Yeah, that works - extract the subs and rename them as exact file name, and go with .srt. If you're on a MAC, use iMkvExtract to extract and Jubler to save as .srt. Just make sure you get the framerate correct.

Yo EDCVO- extracted, saved as .srt. selected the correct file while playing the .mkv. No show on the subtitles. Do you think it might have to do with having an incorrect framerate?

chronicrebellion
November 14th, 2010, 12:10 PM
i noticed that with mkvs with embedded subs that IF the overscan setting is anything but 0% i will not see any subtitles...

one put into default settings i can see them just fine...

not sure if this is addressed anywhere in the current bugs...

SleazyC
November 14th, 2010, 07:39 PM
i noticed that with mkvs with embedded subs that IF the overscan setting is anything but 0% i will not see any subtitles...

one put into default settings i can see them just fine...

not sure if this is addressed anywhere in the current bugs...
Can confirm that this works for me. Thanks a ton for the tip was getting a bit frustrated not being able to watch a lot of my local content.

kenjisugahara
November 15th, 2010, 09:21 PM
I can confirm this too.

I'm e-mailing with support to let them know.