PDA

View Full Version : Can't connect to Windows 7 - asks for username/password


Tufflaw
November 16th, 2010, 05:49 PM
I was very excited to get my Boxee Box, now I'm very sad that I can't access my Windows 7 shared folders.

I can access my folders on my XP machine fine, but I tried it with 7 and it asks for username/password, and nothing works. I don't have any password on my windows 7 machine at all. I tried some of the suggestions I've seen in other posts - namely, adding a new account with a password and sharing to that account; sharing with Everyone; unsharing with Homegroup; turned off password protected sharing; nothing works. Any suggestions?

dconti
November 16th, 2010, 05:52 PM
Hi tufflaw, let's try this:

go to the sharing center, make sure your network type is set to home. Make sure network discovery is on, file sharing is on, password protected sharing is off.

go to the directory you want to share. make sure it is marked as shared. go to the properties, security tab. make sure 'everyone' has at least access to read, list directory contents, etc.

then reboot your boxee box and see if you can access the share.

Tufflaw
November 16th, 2010, 05:56 PM
All of that was already done :(

taffer
November 16th, 2010, 05:56 PM
Have you tried using "computer name/username" as the username where "computer name" is the name of your Windows box? I have to do this for the shares from my Windows Home Server.

dconti
November 16th, 2010, 05:57 PM
do you have windows live essentials installed on the machine?

Volatile
November 16th, 2010, 06:04 PM
do you have windows live essentials installed on the machine?

+1 Uninstalling Windows Live Essentials fixed it for me.

Tufflaw
November 16th, 2010, 06:14 PM
Have you tried using "computer name/username" as the username where "computer name" is the name of your Windows box? I have to do this for the shares from my Windows Home Server.

Tried it, no luck.

Tufflaw
November 16th, 2010, 06:16 PM
do you have windows live essentials installed on the machine?

I do - I was hoping not to have to install it if possible. I was able tp connect to the shared directory with my XP machine with no password prompt.

I guess I'll try to uninstall and see what happens, I can always re-install later.

Tufflaw
November 16th, 2010, 06:17 PM
All I had was photo gallery and moviemaker - will update after uninstall

dconti
November 16th, 2010, 06:22 PM
All I had was photo gallery and moviemaker - will update after uninstall

if you want to keep it on, try going to settings, file sources, add source, manually by ip

then go to your windows machine, get the IP address (cmd, ipconfig), and add it into boxee with the share name.

that should allow you to map with a user/pass and work around the WLE issue for now. let me know if that works?

Tufflaw
November 16th, 2010, 06:50 PM
OK it seems to be working now! After I uninstalled it wouldn't show the Windows 7 computer at all, then it started working. New problem - it appears that I have to manually share all my shared files in addition to the folders, otherwise they won't show up. They all have a little lock symbol on them until I share them. Do you know a way to get them to be shared automatically? Thanks!

dconti
November 16th, 2010, 07:03 PM
OK it seems to be working now! After I uninstalled it wouldn't show the Windows 7 computer at all, then it started working. New problem - it appears that I have to manually share all my shared files in addition to the folders, otherwise they won't show up. They all have a little lock symbol on them until I share them. Do you know a way to get them to be shared automatically? Thanks!

where do you have your shared folder located? is it in your user account or at the root of a drive?
confused about sharing individual files/lock icon - where do you see the lock, in windows ?

gmd024
November 16th, 2010, 07:06 PM
Get rid of all traces W's Live Ess'ls and reboot all devices on the network after doing so - good luck

jebise
November 16th, 2010, 07:51 PM
i didn't really read all the replies and this was an issue with many users using the Asus O!Play. When adding your sources click UPnP go into Movies > Folders etc and add that way, the other way you are logging into a account with UPnP you are accessing the shares.

Make sure on Win 7 that the folder is shared to the network and/or homegroup. After that you should not have issues viewing your files with BBox.

If you happen to have an issue like me that out of my 300 files only 289 showed on the boxee (or whatever box you got same applies) go into the folder and right click the files that are not showing and click share with > homegroup read and or read/write. This is not BBox fault blame M$.

With UPnP it will not ask for password or anything and has its own folder structure just like homegroup libraries.

Tufflaw
November 16th, 2010, 08:28 PM
where do you have your shared folder located? is it in your user account or at the root of a drive?
confused about sharing individual files/lock icon - where do you see the lock, in windows ?

I have my main C drive (unshared) and under that I have Torrents (shared) with individual folders (shared). I attached a screenshot - as you can see, one file has a lock symbol on it (which is how it showed up) and can't be seen by Boxee. The other one also had the symbol but I had to manual share it and now it can be seen by Boxee. Trying to figure out how to have it automatically sharable.

dconti
November 17th, 2010, 12:01 PM
I have my main C drive (unshared) and under that I have Torrents (shared) with individual folders (shared). I attached a screenshot - as you can see, one file has a lock symbol on it (which is how it showed up) and can't be seen by Boxee. The other one also had the symbol but I had to manual share it and now it can be seen by Boxee. Trying to figure out how to have it automatically sharable.

go to the folder you are sharing. right click, properties, security. make sure 'everyone' is in the top list with at least read, folder list, etc. here's where i get fuzzy. there is an option to ensure the security settings for the folder are applied to all of its contents. i can't recall at the moment where that is, but that may be what is required here to recursively allow access to all of your files

Tufflaw
November 18th, 2010, 11:38 AM
go to the folder you are sharing. right click, properties, security. make sure 'everyone' is in the top list with at least read, folder list, etc. here's where i get fuzzy. there is an option to ensure the security settings for the folder are applied to all of its contents. i can't recall at the moment where that is, but that may be what is required here to recursively allow access to all of your files

Tried it, no luck. Tried a bunch of stuff I found online, nothing works. At this point though I guess it's anot a Boxee issue but a Windows 7 issue. Thanks for all the help!

daver77
November 18th, 2010, 02:40 PM
+1 Uninstalling Windows Live Essentials fixed it for me.

Thanks guys, uninstalling that fixed it for me too. You really need to either fix this or get this fact across to everyone, i'm sure loads of people are going to be stuck on this

Tufflaw
November 18th, 2010, 08:51 PM
Tried it, no luck. Tried a bunch of stuff I found online, nothing works. At this point though I guess it's anot a Boxee issue but a Windows 7 issue. Thanks for all the help!

I FIGURED IT OUT!

I have uTorrent set up to automatically download files and transfer them to a different folder. I did not set the folder for the active downloads to be in, so it was automatically put in one of my Documents folders. At the completion of the download it would transfer to one of my shared folders. BUT the original folder was not shared, so the file wasn't shared. I created a new folder under my Torrents directory which is shared, set that to be the default active download folder, and voila! It works. Thanks to all for the suggestions!

cyrdax
November 23rd, 2010, 02:34 AM
Hi tufflaw, let's try this:

go to the sharing center, make sure your network type is set to home. Make sure network discovery is on, file sharing is on, password protected sharing is off.

go to the directory you want to share. make sure it is marked as shared. go to the properties, security tab. make sure 'everyone' has at least access to read, list directory contents, etc.

then reboot your boxee box and see if you can access the share.

I have done all of this and unistalled all windows live essentails.

I use my computer name/username and it gives me:

"Loading Error
Could not access file, directory or device."

please help... dont understand why it is so difficult :(

haveringcottage
November 23rd, 2010, 02:52 AM
this is going to be fixed in the upcoming software update... look at the sticky on the "announcements" section.

ingoldsby
November 23rd, 2010, 02:53 AM
I was very excited to get my Boxee Box, now I'm very sad that I can't access my Windows 7 shared folders.

I can access my folders on my XP machine fine, but I tried it with 7 and it asks for username/password, and nothing works. I don't have any password on my windows 7 machine at all. I tried some of the suggestions I've seen in other posts - namely, adding a new account with a password and sharing to that account; sharing with Everyone; unsharing with Homegroup; turned off password protected sharing; nothing works. Any suggestions?

You most likely have a component of windows live installed.

cyrdax
November 24th, 2010, 12:25 PM
guess its time to return this terrible device.

the fact that its so hard to get setup on the worlds dominant OS is kinda sad. what were you testing on during development?