PDA

View Full Version : Buffering problems on 720p MKV (3 Samples inside)


stacked
December 14th, 2010, 05:50 PM
I recently posted that I was having buffering problems playing some 720p mkv videos via LAN and USB. Here are three samples that I created. Please test them on your Boxee Box and let me know if you notice any buffering after the video starts playing.

Buffers at ~7seconds
http://www.mediafire.com/?577y6p6z8a08qrl
media info for original file: http://pastebin.com/8xzfBnJY

Buffers at ~8seconds
http://www.mediafire.com/?tg6nbi12xca1g4k
media info for original file: http://pastebin.com/z8wftHCq

Buffers at ~ 34seconds
http://www.mediafire.com/?26d4p8a4llxwnsw
media info for original file: http://pastebin.com/A9P7TUrg

zdesignstudio
December 14th, 2010, 07:41 PM
I tried all three of them and experience the same issue. It could possible be a bad compile of the mkv file.

stacked
December 14th, 2010, 08:13 PM
I tried all three of them and experience the same issue. It could possible be a bad compile of the mkv file.

I thought that at first, but the files work fine on the PC Boxee, XBMC, VLC, and MPC. The problem also occurs on every episode for each of the samples that I made.

Prospero424
December 14th, 2010, 10:32 PM
What software was used to author these .mkv files? Was it MakeMKV?

war59312
December 14th, 2010, 10:49 PM
Looks he is using mkvmerge v4.4.0 ?

And indeed same issue when playing on Boxee and play fine on computer so files are fine.

Prospero424
December 14th, 2010, 10:55 PM
Normally, mkvmerge is used transparently by the transcoding/authoring suite (like HDConvertToX or MakeMKV, etc.). What I'm asking is what authoring/transcoding program was used to originally create the files.

Unfortunately, there's no way to scan the files and determine this.

Rustycar
December 15th, 2010, 04:26 AM
Mediainfo (http://mediainfo.sourceforge.net/en) will tell you the application used for muxing the media if you switch to view->text mode.

According to it mkvmerge was the application used. MakeMKV will also show as a separate entry if it was used they may have their own matroska muxer too, Handbrake will also show up if used.

Those files also buffer on my Boxee Box too, I hope someone from Boxee can figure out why and nail this buffering gremlin.

On a side note I tried a video which causes slow downs on an XBMC nettop, Tvix Slim S1 through Samba and PS3 through DLNA on my network all the media players can play it fine from local storage.

But the Boxee Box is able to play the video flawlessly from the samba share though it does buffer at 5 points still pretty interesting why Boxee can handle this and the others cant so it's doing something right.

It's a 47Mbps video taken using a Canon EOS 5D Mark II, grab it here (http://en.akihabaranews.com/20634/legacy-unused/image/download-our-canon-5d-mark-ii-full-hd-video-now-the-world-s-first-forbidden-hd-video) if someone from Boxee wants to check it out.

Prospero424
December 15th, 2010, 04:32 AM
Handbrake will indeed show up, but I believe that MakeMKV uses mkvmerge, internally. I'm guessing that MKVMerge will sometimes append its name to the metadata in certain modes/settings, but not in others.

I've noticed that a lot of these problem MKV files have been muxed with 4.X versions of mkvmerge. We've already eliminated header compression (a new feature) as the cause, but I'm starting to wonder if some other new change/feature to the software might be the culprit.

But I'm just speculating out loud, here...

diprip
December 15th, 2010, 07:07 AM
This is exactly what is happening to me. Any 720p mkv movie or 1080p mkv movie works fine. But for some reason every HBO and Showtime 720p mkv rip buffers anywhere from 2-5 times per episode. This is the single most annoying issue with the boxee box. If they could fix this and give us netflix soon, I will be a really happy camper.

dyrhus
December 15th, 2010, 07:53 AM
Same issue here too. 720p MKV takes a lot longer to load on the new firmware.

dconti
December 15th, 2010, 01:57 PM
heads up that checking these out is on my todo list for tomorrow

stacked
December 15th, 2010, 08:40 PM
Looks he is using mkvmerge v4.4.0 ?

And indeed same issue when playing on Boxee and play fine on computer so files are fine.

I only used mkvmerge v4.4.0 to create the samples. I posted the media info for all the original files on the first post (http://forums.boxee.tv/showpost.php?p=135773&postcount=1).

diprip
December 15th, 2010, 09:53 PM
heads up that checking these out is on my todo list for tomorrow

That is fantastic news. This is my #1 problem I am having with the box. Thanks for your hard work and hopefully there is a quick fix for it.

dconti
December 16th, 2010, 10:45 AM
clips 1 and 2 have an issue that we have an open bug already; i need to dig into the content a bit to see what is up.

clip 3 is something we've known about for a little bit but don't have a fix for yet. i filed a bug to make sure it doesn't get lost. The short of it is in some clips where there used to be a commercial, we get tripped up on the remnants of the audio switch for the commercial break.

http://jira.boxee.tv/browse/BOXEE-7597

dconti
December 16th, 2010, 03:39 PM
thanks for the samples, this really helped out since the buffering always happened in the same spots.

i was able to get a fix built for this today, barring any issues we'll have this fixed up in sp3.

cheers

diprip
December 16th, 2010, 04:56 PM
thanks for the samples, this really helped out since the buffering always happened in the same spots.

i was able to get a fix built for this today, barring any issues we'll have this fixed up in sp3.

cheers


Thats great news dconti. Hopefully sp3 comes out soon along with netflix.

bradtacs
December 16th, 2010, 05:07 PM
I am in the same boat as these guys, this will really make me a happy camper if this is fixed.

It is one of the last outstanding playback issues for me.

stacked
December 16th, 2010, 05:30 PM
thanks for the samples, this really helped out since the buffering always happened in the same spots.

i was able to get a fix built for this today, barring any issues we'll have this fixed up in sp3.

cheers

Thanks a lot for taking time to fix this bug. :)

chaseme
December 16th, 2010, 07:05 PM
Nice! This is my #1 issue with Boxee too.

muhri
January 19th, 2011, 04:52 AM
I can confirm this issue happens to me with one MKV only in my collection, the rest are fine. Albeit that the RC2 release I'm using takes a lot longer to start streaming files than the previous releases.

ScottAllyn
January 19th, 2011, 07:58 AM
For what it's worth, this problem seems to be gone with SP1 RC2 (http://forums.boxee.tv/showthread.php?t=26275) - I was able to play all 3 clips this morning with no sign of buffering.