PDA

View Full Version : how do i use boxee fullscreen and still use my mouse/keyboard? (linux)


agentlame
August 23rd, 2008, 08:44 PM
*THIS IS A COMPLETE HACK*

in fullscreen mode, boxee locks the mouse/keyboard to it's window.
as a result, you can not launch boxee fullscreen on one monitor, and still use your mouse/keyboard on another. :(

this is an issue with the sdl frameword that boxee/xbmc are based on, and not something that is easily fixed the those teams.

so here's what you can do:

1. install wmctrl.
click here (apt://wmctrl) on ubuntu.

2. configure boxee to launch in windowed mode.
in boxee: Settings > Appearance > Screen > Resolution.
set it to anything that ends in: "(Window)"

3. use wmctrl to make boxee fullscreen.
wmctrl -x -r Boxee.Boxee -b toggle,fullscreen

BAM! fullscreen boxee, completely usable mouse/keyboard.

now, this is all fine and good, but I want to launch boxee like this.

here is a simple shell script:

#! /bin/bash

STATUS=0
WINCLASS=Boxee.Boxee
DISPLAY=:0.1
SLEEPDELAY=1


/usr/boxee/run-boxee-desktop "$@" &

while [ $STATUS -eq 0 ]
do
sleep $SLEEPDELAY
STATUS=`wmctrl -x -l | grep $WINCLASS | wc -l | awk '{print $1}'`
done

wmctrl -x -r $WINCLASS -b toggle,fullscreen

save this as ~/bin/launch-boxee

then run this command:
chmod +x ~/bin/launch-boxee
-------------------------------------------------------------------------------------------------------------------

note: set "DISPLAY" to whichever display you want boxee to run on.

note: you may need to adjust "SLEEPDELAY" to be longer or shorter, depending on your system.

confession: i suck at scripting, so if i did something dumb, lemme know.

belovedmonster
August 24th, 2008, 04:17 AM
Am I missing something here, isnt there an option in the settings to turn off the "Disable Mouse" setting. :confused:

tsella
August 24th, 2008, 04:28 AM
@agentlame - very cool! will try it.

@belovedmonster - @agentlame is not enabling mouse within boxee, but rather another thing altogether. he has a dual screen setup, and when you run boxee, it's locking the keyboard & mouse to its viewport. with @agentlame's hack, you can use boxee in one screen, while retaining keyboard & mouse in the other.

billgoldberg
August 31st, 2008, 09:50 AM
@agentlame - very cool! will try it.

@belovedmonster - @agentlame is not enabling mouse within boxee, but rather another thing altogether. he has a dual screen setup, and when you run boxee, it's locking the keyboard & mouse to its viewport. with @agentlame's hack, you can use boxee in one screen, while retaining keyboard & mouse in the other.

I presume an option for this will be added in the future too Boxee?

agentlame
August 31st, 2008, 01:49 PM
Extremely unlikely. This is an awful gross nasty hack. The Boxee devs have much more class then that. :)


My understanding of the actual issue is: SDL is a cross-platform gaming framework, and that's why fullscreen locks the mouse. Which is the right way to do it--for games.

And example of the opposite is: ioquake does NOT handle FS on multi-mon correctly, so when I play WoP, if my mouse ventures to the other screen, WoP resizes and becomes windowed. Pisses me off.

But, I might be misunderstanding the exact implementation details. All that said, It's not a simple fix/patch for the Boxee/XBMC devs to fix.

sertys
May 11th, 2009, 07:46 AM
that wmctrl tip saved my life virtually. i have 2x20.1 lcds and it puts them in 3200x1200 , while centering content at the middle. i use wmctrl to scale and toggle to fullscreen like that :

wmctrl -x -r Boxee.Boxee -e 0,1600,0,1600,1200 -b toggle,fullscreen

xobes
June 28th, 2009, 06:12 PM
Building on the above, which was extremely helpful, I have created my own solution:

http://forum.boxee.tv/showthread.php?t=10103

Also, a note for the above posters, I would suggest using "add, fullscreen" instead of "toggle, fullscreen". Granted my use case is different than what's listed above -- I am switching between two apps which are both always full screen.

Thanks for the awesome post! wmctrl was just the trick!

- AZ

Sheik
August 29th, 2009, 10:14 AM
There's an even easier way for this:

1. Configure boxee to launch in windowed mode.
in boxee: Settings > Appearance > Screen > Resolution.

2. Go to System -> Preferences -> Keyboard Shortcuts

3. Find the item that says “Toggle Fullscreen Mode” and set the keyboard shortcut you want to use.

4. Launch Boxee and press your fullscreen hotkey! ;)

Tested with Ubuntu 9.04

Nensi
June 5th, 2010, 01:27 AM
That seems pretty good to me and I hope you will keep up the good work in future as well.

yekibud
December 27th, 2010, 11:26 PM
Woo-hoo! This is still gold on Boxee 0.9.22/ 64bit Ubuntu 10.04.

Thank you agentlame! Now my entertainment system is almost set. Just need Netflix to get out of bed with MS/Silverlight and get the streaming goodness flowing (I will pay for movies - but I wont pay for DRM).