PDA

View Full Version : Boxee stuters


tgggd86
January 21st, 2009, 01:59 PM
Ok so I have been playing Hulu for awhile on boxee and I've noticed it is really stutery. It's like it's going at 12FPS even when I have it set to 480p. I checked my CPU utilization and it's about 90-95% on my HTPC. It works fine on my Desktop thought. I was wondering if there was just some wierd thing going on causing that or is it that my CPU is so close to max?

nalthien
January 21st, 2009, 02:08 PM
Is it only Hulu videos?

Have you tried playing those same Hulu videos outside of Boxee to see the results?

sgt cyborg
January 21st, 2009, 07:03 PM
I have noticed stuttering playing Hulu in boxee with 480p content. It seems like its just missing some frames here and there not sure of the actual FPS though. My CPU utilization spikes to 90-95% when the video starts to stutter but when the video is playing nice and smooth CPU utilization is around 70-80%. Why is the CPU utilization so high for 480p in Hulu? I can steam 1080P from Apple's HD movie trailers and its nice and smooth.



Systems Specs:
Intel Core 2 Duo E6600 2.4 Ghz
2GB DDR2-800 Memory
Ati Radeon X1900 XT 512 MB
Creative X-Fi
Windows 7 Beta 1 Build 7000 32 Bit
ISP: 15 mbps download, 1 mbps upload

tgggd86
January 22nd, 2009, 01:07 AM
ya it kind of stutters when using the site but boxee makes it a little worse. I am sure it's because boxee is so processor intensive. Should I just upgrade my CPU?

dobyken
January 22nd, 2009, 11:14 AM
ya it kind of stutters when using the site but boxee makes it a little worse. I am sure it's because boxee is so processor intensive. Should I just upgrade my CPU?

I don't think your CPU is the problem. I've got a Athlon 64 single core and
when watching 480p Hulu streams in Firefox I run 45% without stutter. In Boxee the CPU runs 97-100% while video stutters and drops frames. XBMC has issues with Hula as well that have been attributed to the core RSS feed code which means that it might need to be fixed in XBMC before it works right in Boxee.
Another issue I have is that everything is too bright and there don't appear to be any default setting for gamma, brightness and contrast. I know that XBMC had an XML file containing 20/50/50 but changing those did not seem to do anything. I took a quick look through the Boxee XML and didn't find those values.

One thing I did notice is that if I get to my task bar so that the Hulu video looses focus then the brightness came down to proper values and other than the stuttering the video looked good. Playing 480p Hulu video directly in Firefox works and looks perfect.