PDA

View Full Version : Install Failed: Installer could not install some files in /Applications


morphos
July 2nd, 2008, 11:06 AM
I cannot even install boxee. This particular problem occurs on two tested macbooks. I usually use a standard account, but have also tested using an administrator account. Same error message every time. Any assistance?

vulkan
July 2nd, 2008, 06:53 PM
when you get this error message - hit cmd+L to see the log.
choose "show All logs" from the drop down list and please paste it or email it to me
vulkan@boxee.tv

thanks.
-vulkan.

morphos
July 2nd, 2008, 10:31 PM
Jul 2 22:30:26 Blackbook payloadExtractor[6674]: BomFileError 13: Permission denied - /Applications//Boxee.app
Jul 2 22:30:26 Blackbook payloadExtractor[6674]: Error extracting archive.
Jul 2 22:30:26 Blackbook payloadExtractor[6674]: pkgExtractor exited with error 1 while processing package '/Users/chad/Desktop/boxee-0.9.2335.pkg'
Jul 2 22:30:27 Blackbook Installer[6664]: Install failed: The Installer could not install some files in “/Applications”. Contact the software manufacturer for assistance.
Jul 2 22:30:27 Blackbook Installer[6664]: Displaying 'Install Failed' UI.
Jul 2 22:30:27 Blackbook Installer[6664]: 'Install Failed' UI displayed message:'The Installer could not install some files in “/Applications”. Contact the software manufacturer for assistance.'.

avneron
July 2nd, 2008, 10:35 PM
pls try to download the file again. it may be corrupted. if that still does not help let us know.

what is the exact file size you have?

morphos
July 2nd, 2008, 10:45 PM
boxee 0.9.2335.pkg - 30.8 MB (32,261,145 bytes).

I have actually semi-fixed this issue. It seems that *either* the download was corrupted, or your installer is broken, honestly. Extracting the .pkg to get access to the boxee.app file worked (indicating the installer again).

Perhaps I can strongly suggest you provide a zipped, rar'ed or other compressed version of just the .app and necessary documentation?

avneron
July 2nd, 2008, 10:47 PM
hmmm.. we should indeed look into it.
tom will get back to you on this one.

sorry for the trouble.

morphos
July 2nd, 2008, 10:59 PM
Maybe I should also add that, once the program is actually able to be ran, it is simply awesome. Crashy? Sure, I'll try to file some light bug reports soon, after the last few minutes of using it, but I absolutely love the direction it's headed, as well as the work so far. Thanks, both for the program and quick replies.

vulkan
July 3rd, 2008, 01:50 AM
happy to hear you got it to work and having fun with it.
we'll probably also add auth request (password) to the next pkg so that permission will not be an issue.

thanks for the report.
-vulkan.

tsella
July 3rd, 2008, 03:31 AM
hi morphos,

we had another user having this issue, who was able to resolve it by moving the .pkg file to a thumb drive, and i suspect if moved to another place (like your desktop), would also resolve it. maybe your browser keeps the file locked in some way.

its very rare though (3 total reports on the issue thusfar), and now we have two solutions.

thatdood
July 15th, 2008, 11:25 AM
I was having the same issue and I just ran the installer from a terminal window as sudo. First just change directories till you get where boxee package is located, then type:
sudo installer -pkg boxee-0.9.2335.pkg -target /Users/username/Documents/

Then you will have to type your sudo password. That seemed to have worked for me.

tsella
July 15th, 2008, 02:28 PM
thanks for the tip!

our upcoming version fixes this issue regardless.

vinko
August 6th, 2008, 08:19 AM
I too had the exact same problem.

Fortunately, thatdood's solution worked for me too.

I too think that the Installer that Boxee shipped has a problem and should be requesting Administrative credentials during install.

marcel
August 6th, 2008, 08:48 AM
Hi Vino

welcome to boxee :) as mentioned the next version will solve this problem

livlab
August 14th, 2008, 12:21 AM
I had the same issue so I moved the file to another location and it persisted. Then I tried the sudo installer way and it installed successfully. However, when I try to run Boxee, I get the following error: "You can't open the application 'Boxee' because it is not supported in this architecture" -- Any suggestions?

tsella
August 14th, 2008, 01:19 AM
I had the same issue so I moved the file to another location and it persisted. Then I tried the sudo installer way and it installed successfully. However, when I try to run Boxee, I get the following error: "You can't open the application 'Boxee' because it is not supported in this architecture" -- Any suggestions?

what are you trying to run on? boxee is currently for intel based os x leopard.