PDA

View Full Version : Installing os.dmg?


silsurf
March 2nd, 2009, 08:25 AM
I am in the final stages of trying to get my afp to work to an ext HDD connected to a USB port of my ATV.

I have read extensively the post here as well as other sites regarding this process. I cannot find anywhere the answer to some seemingly stupid questions.

(I have NitoTV installed and ran the smart installer previously, all works great)

I have a folder entitled "AppleTV v1.0 Recovery Partition" inside of it is a dmg entitled OS.

It appears that I just rename this file "recovery" and place it in the documents folder of my ATV and I should be set? But I think there is more to it. Do I realy just rename the file? If so, upper or lower case, I see both listed in posts. I am skeptical about the renaming process because it is not mentioned anywhere except one small post I found on another webiste.

If indeed I just rename the file and then copy it over via SHTP using Cyberduck (which connects perfectly). I see that there may be permissions issues, but I cannot find any mention of the exact permission I need to change on my ATV?

So, what I hope will finalize my quest is:

OS.dmg, do I just rename the file to recovery.dmg. Upper of lower case?
Can I just copy via Cyberduck?
What permission should I set on the ATV files, which files exactly?

I love using Boxee and if I can get htis ext HDD up and running with file sharing I will be all set.

Thanks,

Henry

docbrown
March 2nd, 2009, 06:23 PM
1. You will need to find an image of an AppleTV 1.0 drive somewhere on the internet. I will not tell you where as it is copyrighted material.

2. Create a recovery.dmg from your current AppleTV (regardless of what firmware its on) by ssh'ing to your AppleTV and type: sudo dd if=/dev/disk0s2 of=recovery.dmg bs=1m

3. This will create "recovery.dmg" at /Users/frontrow/

4. Copy this to your Mac and mount it. Inside you will see OS.dmg. Delete the recovery.dmg from your AppleTV.

5. Mount the image of AppleTV 1.0 on your Mac. You should see inside another OS.dmg

6. Replace the OS.dmg inside the recovery.dmg you just created with the one from the AppleTV 1.0 image.

7. Copy recovery.dmg back to your AppleTV in /Users/frontrow/Documents

8. Copy 10.4.9 Combo update to /Users/frontrow/Documents

9. Run NitoTV smart installer.


you need to do step 2. this will create recovery.dmg out of your appletv. it doesnt matter what factory version your appletv is.
following from step 4, you need to copy this recovery.dmg to your mac, replace the os.dmg inside it with the one from your downloaded "apple tv v1.0 recovery partition" then copy recovery.dmg to ~/Documents back on your apple tv.

silsurf
March 2nd, 2009, 06:53 PM
Thanks so much, that is very clear.

In order to ssh into my atv, is it just:

in terminal: ssh frontrow@AppleTV.local?

Henry

antwerx
March 2nd, 2009, 10:29 PM
I logged into my router to be sure of the IP address my Apple TV was assigned.

Once I have the IP of my Apple TV I just ssh to it like below:

ssh frontrow@ip addy of your apple tv here
Password frontrow

Also if you need to reboot your Apple TV while logged into it via ssh you can use this command instead of going through the boxee/apple tv menu.
sudo reboot
Password frontrow

silsurf
March 3rd, 2009, 11:58 AM
Everything went as you liad out, thanks for the great instructions.

After the NitoTV smart install I was left me with this:

Install Partial or Failed and at the bottom the statement that I needed to run the two following commands to complete the install, which I did.

sudo /System/Library/Coreservices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -configure -clientopts -setvnclegacy -vnclegacy yes

The second was

sudo /System/Library/Coreservices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -activate -configure -access -on -users frontrow -privs -all -restart -agent -menu

I power cycled the ATV and turned on afp sharing on my desktop. The ATV is listed in my sharing sidebar and I even see my EXT HDD I added to it,

But I do not have any access privilages for copying files? I tried to add the ATV and or the EXT HDD in the Sharing panel, but nothing happened. Do the privileges need to be set via ssh on the ATV in order for me to have access. Sorry again for the extreme lack of knowledge here, I would appreciate a little more guidance when you have the time.

Henry

silsurf
March 3rd, 2009, 12:18 PM
OK, I see that there is a network setup in the NitoTV program.

I tried to add a registered user (my admin acct on my home desktop), but that got kicked back with this -1069 error I have read a little about.

I also see I can add a manual share point.

What is the best way, or only way, to have my access privileges engaged?

Thanks, thanks, thanks, again.

Henry