PDA

View Full Version : how-to watch videos from ninjavideo.net in boxee


agentlame
October 12th, 2008, 08:48 PM
ninja video is dead: http://xbmc.org/forum/showpost.php?p=239293&postcount=294

agentlame
October 12th, 2008, 09:07 PM
[reserved for known issues/notes/errata]

phillipsmn
October 13th, 2008, 06:29 PM
I need a little help...I'm running boxee on my mac and I have followed your directions. I can access the Ninja Video from the internet feeds and can see all the categories and the actual shows/movies/etc. Whenever I try to play one, I get nothing. It goes right back to the select episode/movie/etc. screen. I added the autoexec.py and the most recent veohproxy-1.5.1 (renamed of course).

One thing I couldn't find was the ~/.boxee/UserData/profiles/[USERNAME]/sources.xml
*EDIT: This should actually be: ~/Library/Application Support/BOXEE/UserData/profiles/[USERNAME]/sources.xml


Any recommendations? I would love to get this working both on my mac and my ATV.

agentlame
October 13th, 2008, 06:39 PM
when you launch boxee, it will load the proxy in the background, as a result ninjavideo.net videos should be resolvable on port: 64653.

one way to test if the proxy in running correctly is to load boxee in windowed mode, and try this link:
http://127.0.0.1:64653/10647

if the proxy is running correctly, that link should resolve to slacker uprising (2008).avi.


disclamer: only click the link in you live in the u.s.... blah, blah

phillipsmn
October 13th, 2008, 06:59 PM
do I try that link in my standard browser or in boxee itself? (if it's in my browser, it doesn't work) ;)

disclaimer: I live in the US and was testing

agentlame
October 13th, 2008, 07:03 PM
do I try that link in my standard browser or in boxee itself? (if it's in my browser, it doesn't work) ;)

disclaimer: I live in the US and was testing

yeah, i screwed all the paths royally... pleas check them all again.

in my defense, i didn't have a mac on me, and did it by memory.

and yeah, the link should work in a browser, so long as boxee is running.

phillipsmn
October 13th, 2008, 07:42 PM
Thanks! It works successfully once I put everything in the right place.

I am beginning to seriously love boxee.

jeelhaus
October 14th, 2008, 05:23 PM
Hai,
I'm testing this Ninja stuff :)
Everythings goes fine, in the menu I can choose the Ninja section, I can select the items I want. But after the final choice, when the movie should start Boxee exits.
I have this on my iMac (10.5) and my AppleTV (2.1).

The proxy works, I've checked that.

AppleTV exits with errorcode 10?

Any idea?

Gr. Jeelhaus.

agentlame
October 14th, 2008, 05:49 PM
Hai,
I'm testing this Ninja stuff :)
Everythings goes fine, in the menu I can choose the Ninja section, I can select the items I want. But after the final choice, when the movie should start Boxee exits.
I have this on my iMac (10.5) and my AppleTV (2.1).

The proxy works, I've checked that.

AppleTV exits with errorcode 10?

Any idea?

Gr. Jeelhaus.

sometimes boxee just crashes like this, for no good reason.

logging out/in--or just restarting--should resolve it.


EDIT:
wow, i just ran into the same problem on my gf's mbp, running 10.5.5. :(
i have no clue what the issues is... i never actually tested it on hers, and just assumed it would work fine, because it works on linux (again, multi-platform support is a pain.)

i can only hope that the new version of boxee that comes out on the 20th will resolve this issue. i looked at the logs, nadda. :(
i did, however, report the crash to boxee.

jeelhaus
October 15th, 2008, 04:23 PM
Thanks Neil for taking the time for answering my question.
We'll just have to wait a few days for the new version.
Thanks again.

I'll test it on my AppleTv also, I will let you know if the new version works beter.

phillipsmn
October 16th, 2008, 02:42 PM
I've noticed the same error on my AppleTV. But the funny thing was that I would get an outright crash on my MBP running boxee. This made me look a little more into it. I went to the ninjavideo site and found the movie I was trying to look at. At their site, although the link was there, there was no media. I think something is broken when there is no media file (like it's been removed since they posted). It would be nice if the plugin could detect a failed/broken stream and exit back to the screen. Boxee itself seems to do this with a bad rss feed source.

agentlame
October 16th, 2008, 04:24 PM
boxee crashed when it couldn't find the video? boxee should never crash... it's should always fail gracefully. (but, that's more of a software in general kind of thing.)

now is it only crashing on a single video, or all of them? also, how about the link i posted on the other page?

remember, any ninjavideo.net net video will not play without the proxy OR ninjahelper (their download) are not running.

i am not the author of anything here, so i can not help you with feature requests. the way the plugins work, is:
if the video is un-resolvable, it will not load.

phillipsmn
October 16th, 2008, 08:11 PM
I didn't really mean to make it sound like it was necessarily a feature request for boxee. I do think that it has to do with the plug-in. That being said, I've had boxee hang and crash on YouTube videos also (on my MBP. I haven't checked with ATV). No exit status just fail. On my ATV, this issue usually returned exit status 10, and sometimes then let me go back to the menu. Other times I had to powercycle.

agentlame
October 16th, 2008, 08:46 PM
i'm sorry, what i meant is i didn't write these plug-ins. all this stuff is from the guys over at xbmc.org. so changing the behavior of un-resolvable videos is not something i can fix.

what would be required is to attempt to establish a connection to each video in the list. the problem is that because of how the proxy works, sometimes just establishing the connection take upwards of a minute. so you would be stuck in the video screen of every video you looked at.

ssserpent
October 18th, 2008, 02:31 AM
Hi All,

I have followed the instructions and have access to the ninja internet videos screen in Boxee. However, when I try to play anything Boxee exits to the previous menu screen with no effect. With Boxee open in the window I cannot access 127.0.0.1:64653. Are there any settings in Boxee, that I'm missing? Any help would be appreciated.

agentlame
October 18th, 2008, 04:16 AM
Hi All,

I have followed the instructions and have access to the ninja internet videos screen in Boxee. However, when I try to play anything Boxee exits to the previous menu screen with no effect. With Boxee open in the window I cannot access 127.0.0.1:64653. Are there any settings in Boxee, that I'm missing? Any help would be appreciated.

ninjavideo was down for a bit... please try again.
the link i provided on the first page is working, again.

gaurav
October 19th, 2008, 09:32 PM
was anybody able to use this on an apple tv? boxee crashes with status 10 every time i try to watch a video from ninjavideo.net.

i have a feeling that i might be doing something wrong here.

i have done the following so far:

1) installed python
2) after boxee was launched, made sure that the veohproxy was listening and available on port 64653.

$ netstat -nal | grep 64653
tcp4 0 0 127.0.0.1.64653 *.* LISTEN

however, connections from the web browser or telnet from my laptop don't work. is this by design? any help will be appreciated.

thanks
gaurav

agentlame
October 20th, 2008, 12:05 AM
while i don't have an atv, here is what i do know:

you should need python installed. xbmc/boxee have an embedded python runtime. (gotta love oss!)

netstat is correct... the proxy is up and listening. while connections to http://[IP/LOCALHOST]:64653 should resolve with no error, nothing is there; you should just get a blank page. (i test this in firefox, i have no idea how other browsers will handle a correctly resolved, but empty page.)

ninjavideo.net have been doing a lot of upgrade/maintenance in the last 48hrs. everything seems to be working, again... but i wouldn't say they are 100%, just yet.

lastly, for just no good reason, boxee sometimes crashes on video playback, on os x. (see the posts from the last page.)

i'm hoping the last issues will be sorted-out in the next release. (t-minus eight hours.)

gaurav
October 20th, 2008, 12:20 PM
Thanks. I am not nearby to my ATv but I plan on checking if there is some sort of firewall installed on it. I can't telnet or FF to the port 64653 on the ATv, which makes be believe there is something that might be blocking it. Also plan to install a bit more tools on ATv to dig deeper.

Waiting for the next release too.

ssserpent
October 20th, 2008, 12:56 PM
No luck for me either. I was waiting for the next release of Boxee hoping it will fix it, but so far nothing. Don't really know what else can I try :(
@guarav - would be very interested in Your findings, please post if You manage to fix it.

vcosta
October 21st, 2008, 10:25 AM
Same error status: 10 on my Apple tv.

I waited for the invitation to BOXEE i tested the XBMC and this very same plugin (and script) had the same result. I came to the conclusion that it's a problem with compatibility. *disappointed sigh*

My humble opinion is that users will also seek long run videos instead of those pushed by mainstream media such as CNN and CBS (and the others too). So to say that these plugins were the salvation to viral browsing.

Boxee is an amazing piece of software and with many amazing features, it's the open source that commercial providers don't pass on because there is no direct sales / profit in it (shall I say "yet"), but if I am allowed I would love to ask some real online movie watching integrated by default.

Thanks Boxee team you guys are truly amazing. I mean it :)

phillipsmn
October 21st, 2008, 06:55 PM
I just wanted to pitch in again...I get:
Error status: 10

on the most recent version of Boxee on my ATV (including the one that made hulu *much* better).

Hopefully there will be a fix and ninja video will work.

I wonder if it doesn't have anything to do with the veoh proxy. Sometimes boxee crashes on veoh and I've gotten Error status: 10 on that as well.

I guess I may have to add python to the languages I know. Maybe I can be helpful then.

agentlame
October 21st, 2008, 07:34 PM
between the new version of boxee, the new version of the ninjavideo plug-in, AND the ninjavideo.net site changes... it's broken, somewhere.

i'm gonna look into all they different updates, and do some debugging soon... next day, or so.

gatsby
October 22nd, 2008, 06:43 PM
Agentlame, Thanks for the tips on this. Looking forward to whatever you may find. I have no joy under XBMC/Plex or Boxee on atv, linux or Leopoard so indeed she's busted.

dee trollop
October 22nd, 2008, 06:53 PM
so i need to install SSH on my ATV for this?

agentlame
October 22nd, 2008, 08:28 PM
after extensive testing, all i can say is it's broken.

it segfaults boxee, and i don't know why.

sorry, guys.

gatsby
October 22nd, 2008, 08:44 PM
Ok, a little more testing shows that it whacks out in xbmc on Windows too when running the proxy script. However, manually running the 'standalone' proxy (installed through the windows installer) lets the plugin itself work with xbmc. I tried running the proxy python script from a command line in Linux but it wouldn't run at all.
-Gatsby

agentlame
October 22nd, 2008, 08:59 PM
i'll be damned... that worked.

i renamed autoexec.py ... then ran:
python /opt/boxee/scripts/veohproxy/default.py
from the terminal... BAM ninja video!

i set it to run on session load in gnome, and it works.

i have no idea how to load python scripts at the start of a session on Mac... any one got a hint?

AaronX
October 22nd, 2008, 09:28 PM
i have no idea how to load python scripts at the start of a session on Mac... any one got a hint?

i bet you could use applescript to shoot the terminal a command at startup.

agentlame
October 22nd, 2008, 09:31 PM
i know nothing of applescript.

i don't use os x, at all... i would just like to fix this for my gf.

aircool00
October 22nd, 2008, 10:17 PM
OSX Workaround with standalone Proxy loading at startup

Required:
Veoh Proxy * Version used is 1.51
http://code.google.com/p/veohproxy/downloads/list
Install to:
mac: /Applications/veohproxy

Ninjavideo Plugin *10-20-08
http://code.google.com/p/voinage-xbmc-plugins/downloads/detail?name=Ninja%20Video20-10-08.rar&can=2&q=
Install to:
mac: /Applications/Boxee.app/contents/resources/boxee/plugins/video/Ninja Video

load boxee and go to the videos>sources>add source>application>add new source
this should show you the ninja plugin


You can make an applescript using applications>applescript>script editor
tell application "Terminal"
activate
do script "python /Applications/veohproxy/default.py"
end tell

Save save script don't check anything and name it something smart


Open up system preferences>Accounts>
Go to Login Items and add your script to the login

Now your system on restart will load the proxy and when you load boxee you can just run the ninja video plugin via video>internet.



Enjoy Arrr.


Note the apple script (http://forums.plexapp.com/index.php?s=&showtopic=1520&view=findpost&p=11231) was taken from godmonkee at the plex forums Cheers
Thanks for this post i just dove into this option of having ninja video in an application. Hope it works for everyone else.
This also works for the newest XBMC

Tested on a hackintosh

gatsby
October 23rd, 2008, 09:50 AM
Sweet! Thanks very much!

On that note - any idea how to get the proxy to run from a shell in Linux? Looks like dependency errors were stopping me.

agentlame
October 23rd, 2008, 10:22 AM
@aircool00, thanks for the detailed post... i'll update the initial instructions as soon as i get the time t test it.

...any idea how to get the proxy to run from a shell in Linux? Looks like dependency errors were stopping me.

should just be:
python /opt/boxee/scripts/veohproxy/default.py

if that's not working, can you post up the error(s) you're getting?

gaurav
October 23rd, 2008, 11:50 PM
super cool, air cool :)

for the apple tv folks, below should work.

1) install veohproxy in /Applications folder

2) configure apple tv to start veohproxy on bootup

cd /Library/StartupItems/
sudo mkdir /Library/StartupItems/veohproxy
cd /Library/StartupItems/veohproxy/


3) create veohproxy startup script using the command below:


sudo nano veohproxy


contents of veohproxy

#!/bin/bash
python /Applications/veohproxy/default.py &


4) create StartupParameters.plist file

sudo nano StartupParameters.plist


contents of StartupParameters.plist

{
Description = "Veohproxy";
Provides = ("Access to ninjavideo");
Uses = ("Network");
Requires = ("Network");
OrderPreference = "Late";
}


5) set permissions

cd ..
sudo chown -R root:wheel veohproxy/
sudo chmod -R 755 veohproxy/
sudo chmod 744 veohproxy/StartupParameters.plist
sudo reboot


veohproxy will start up automatically after you have rebooted the apple tv. enjoy watching ninjavideo.

jazzboy
October 24th, 2008, 06:36 AM
The Apple TV instructions still produce an Error 10 although I can now select the actual movie to play..it got a bit further..

Are the script contents correct??

Thanks for your efforts....I can smell victory!

ssserpent
October 24th, 2008, 07:24 AM
@aircool00 thanks!! got it working on my MacBook.

Guys, is the playback smooth for You? I get a lot of buffering...

gaurav
October 24th, 2008, 07:54 AM
The Apple TV instructions still produce an Error 10 although I can now select the actual movie to play..it got a bit further..

Are the script contents correct??

Thanks for your efforts....I can smell victory!
i assume this was for me and not the original post from Neil.

did you remove the earlier installation of veohproxy?

ssserpent
October 24th, 2008, 10:52 AM
@guarav I have followed Your instructions religiously. I can see Ninja Video and can navigate through the folders, but when I actually try to play the movie nothing happens. Boxee just comes back to the previous screen. Any help where to go from here will be highly appreciated.

gatsby
October 24th, 2008, 11:22 AM
Ok, I'm obviously insane. I swear the proxy wouldn't start yesterday in Linux but now as I go back and try today, it starts fine. Neeeeevermind ;) I have not checked the plugin though.

I did find last night that I was ending up with video corrupting and then stopping. The proxy said something about unable to contact the url, retrying. Well it never actually continued to play (several different times and streams). Anyone else see this?

-Gatsby

gaurav
October 24th, 2008, 11:35 AM
@guarav I have followed Your instructions religiously. I can see Ninja Video and can navigate through the folders, but when I actually try to play the movie nothing happens. Boxee just comes back to the previous screen. Any help where to go from here will be highly appreciated.

i have seen this as well. i am not 100% sure how ninjavideo.net stores it's files. however, my understanding is that they use multiple servers and if the file is missing, boxee comes back to the previous screen.

you can do couple of things to see if the file exists or not.

test 1: browse to ninjavideo.net for the file that you want to watch and try to view it in web browser.

test 2:
1) login to apple tv
2) kill the veohproxy process using the commands below:


ps auxwww | grep default.py
kill -9 <pid>


where, pid would be from the second column of the output. i don't have access to my atv right now to provide you with an example

3) run veohproxy from the command line


python /Applications/veohproxy/default.py


4. try to watch the video and monitor the output from veohproxy file. it will point you towards the problem.

you can also verify that veohproxy is running or not using the following commands:


ps auxwww | grep default.py
netstat -nla | grep 64653


note: the use of proxy from your laptop/pc won't work as veohproxy listens on 127.0.0.1 (localhost) only.

hth

ssserpent
October 24th, 2008, 01:01 PM
@guarav Actually I have found that there's no python installed on my Apple TV. I don't know if there's only my machine not having it? Nonetheless I have managed to install it using this (http://wiki.awkwardtv.org/wiki/Python) guide. Now everything is working but buffering a lot. Thanks a lot for help.

jazzboy
October 24th, 2008, 07:06 PM
Gaurav....

I didn't remove the earlier install of Veohproxy....I'll try that and let me know...

Thanks again..

agentlame
October 24th, 2008, 07:24 PM
some video on ninja don't always play well.

the best way to test if it's the video or you box is to go to ninjavideo.net (with the proxy running) and test the video on their site.

pegasosii
October 25th, 2008, 04:42 AM
Hi


I follow the indication to put Ninja video on my AppleTV but i think ...after this command i don't have python on AppleTV system,
on my MacBook everything for fine

I try this
-bash-2.05b$ python /Applications/veohproxy/default.py
-bash: python: command not found

What suggest? to install phyton from Tiger?

pegasosii
October 25th, 2008, 09:59 AM
Hi


I follow the indication to put Ninja video on my AppleTV but i think ...after this command i don't have python on AppleTV system,
on my MacBook everything for fine

I try this
-bash-2.05b$ python /Applications/veohproxy/default.py
-bash: python: command not found

What suggest? to install phyton from Tiger?

Right...i install python on my my AppleTV and Ninja Video work ok for me.

vcosta
October 26th, 2008, 12:00 PM
Yes same here. Installed Python with the instructions here http://wiki.awkwardtv.org/wiki/Python and it is running great. Thank you all.

riegersn
October 26th, 2008, 05:26 PM
Is this working on linux yet? I checked out the site and it looks awesome!

aircool00
October 27th, 2008, 01:35 AM
The reason for videos not loading or some not streaming correctly is this. The ninja site is getting really popular and getting hammered they have a 4 digit hosting overhead...... If you can head to the main site and donate if not please don't complain. The problem is mostly with new items since everyone jumps on them right away. They also have some problamtic posts and take them down and re-upload them. So hang in there and hope for the best.

agentlame
October 27th, 2008, 01:41 AM
Is this working on linux yet? I checked out the site and it looks awesome!

only ever used it on linux... works great!

The reason for videos not loading or some not streaming correctly is this. The ninja site is getting really popular and getting hammered they have a 4 digit hosting overhead...... If you can head to the main site and donate if not please don't complain. The problem is mostly with new items since everyone jumps on them right away. They also have some problamtic posts and take them down and re-upload them. So hang in there and hope for the best.

amen, brother... couldn't have said it better myself...

nv has grown exponentially, in the last few weeks... if i had known what was gonna happen, i would have never posted this.... honestly, i fear an end is coming to nv, soon. :(

gatsby
October 27th, 2008, 04:34 PM
The reason I brought it up was not to complain :) What I've found is that under Vista (xbmc), the divx player gets upset if there's a drop in data flow and seems to get stuck. I don't see this under Linux or in my limited testing on OSX. I'll get artifacts etc. but it will eventually catch up and continue on. It's odd that of all the platforms, Windows is the one that works worst for me.
-Gatsby

riegersn
October 27th, 2008, 08:17 PM
ok I was able to add the plugin and start browsing! there is soooo much content! However when I browse down to the second level it crashes. In other words... I select TV Episodes, then click on a show, say 24, boxee crashes. I copied the scripts to /opt instead of /usr (since the update) and I copied them as root. Except for the sources which I edited as normal user.

I have the Error Log...

Error log posted on http://paste.uni.cc/19396

Please someone help! I need to get my hands all this awesome content!

agentlame
October 27th, 2008, 08:44 PM
sorry, i haven gotten to update the original post, as it's been kinda crazy around here...

if you read from page three on... you should see the solution.

mackdd4
October 29th, 2008, 01:24 AM
is veohproxy/ninja video broken right now or is it just me

ABNGTI
November 1st, 2008, 09:38 AM
is veohproxy/ninja video broken right now or is it just me

doesn't seem to be working for me either. it was, but it stopped yesterday I think. :(

agentlame
November 1st, 2008, 09:51 AM
yep... see here: http://xbmc.org/forum/showthread.php?t=33701&page=30

Voinage is working on it, though.

ABNGTI
November 2nd, 2008, 02:08 PM
from the looks of that thread veohproxy needs to be updated, and the ninjavideo plugin is no longer under development :(

jeckle
November 2nd, 2008, 06:18 PM
Can i get confirmation whether this does or does not work with the newest build of boxee 53936 (or something like that)?

agentlame
November 3rd, 2008, 03:50 AM
from the looks of that thread veohproxy needs to be updated, and the ninjavideo plugin is no longer under development :(

the last post is yesterday. :confused:

agentlame
November 3rd, 2008, 03:51 AM
Can i get confirmation whether this does or does not work with the newest build of boxee 53936 (or something like that)?

nothing to do with the boxee build... has to do with the ninjavideo.net site.

Tom Dibble
November 5th, 2008, 07:46 PM
the last post is yesterday. :confused:

In the veohproxy issues, he closed a bunch of NinjaVideo bugs s WontFix, like bug 17 (http://code.google.com/p/veohproxy/issues/detail?id=17#c6)

"Comment 6 by gerkensm, Today (11 hours ago)
NinjaVideo encrypted the responses from their server ( DSA & SHA-1, I believe).
Nothing I can do about it.
Status: WontFix"

Doesn't sound promising. I suspect Ninja Video on XMBC/Boxee is a dead end unless the Ninja folks decide to cooperate.

Note the main project page still says it supports NinjaVideo along with Veoh and Messagefromme (but the other bit to pull XML from those sites is beyond my capabilities to produce, so it doesn't seem useful there).

agentlame
November 5th, 2008, 08:11 PM
In the veohproxy issues, he closed a bunch of NinjaVideo bugs s WontFix, like bug 17 (http://code.google.com/p/veohproxy/issues/detail?id=17#c6)

"Comment 6 by gerkensm, Today (11 hours ago)
NinjaVideo encrypted the responses from their server ( DSA & SHA-1, I believe).
Nothing I can do about it.
Status: WontFix"

Doesn't sound promising. I suspect Ninja Video on XMBC/Boxee is a dead end unless the Ninja folks decide to cooperate.

Note the main project page still says it supports NinjaVideo along with Veoh and Messagefromme (but the other bit to pull XML from those sites is beyond my capabilities to produce, so it doesn't seem useful there).

yep: http://xbmc.org/forum/showpost.php?p=239293&postcount=294

fun while it lasted. :(

stencilone
November 9th, 2008, 10:00 AM
Please help me, im quite new in UNIX and ssh

Im desperately trying to make ninja videos work on my apple tv, i have installed python and veohproxy as well, however when i run "netstat -nla" i dont find "tcp4 0 0 127.0.0.1.64653 *.* LISTEN" so its probably not running. On the other hand i have already managed to add the ninja video as a source in boxee, and i get the same issues as the others : when i open a media it goes back one page. Ninja video site crash is the reason?

Any suggestions?
thanks in advance

agentlame
November 9th, 2008, 10:03 AM
Please help me, im quite new in UNIX and ssh

Im desperately trying to make ninja videos work on my apple tv, i have installed python and veohproxy as well, however when i run "netstat -nla" i dont find "tcp4 0 0 127.0.0.1.64653 *.* LISTEN" so its probably not running. On the other hand i have already managed to add the ninja video as a source in boxee, and i get the same issues as the others : when i open a media it goes back one page. Ninja video site crash is the reason?

Any suggestions?
thanks in advance

ninjavideo in boxee/xbmc is dead: http://xbmc.org/forum/showpost.php?p=239293&postcount=294

vcosta
November 10th, 2008, 03:52 AM
damn!

Back to square one on real full length videos :(

voinage
December 3rd, 2008, 12:38 PM
Firstly,

Thanks for your kind words Agent.

Secondly,

Ninja Video has been decoded and a fully working (Boxee included) version will appear over the next week.

Hagen the creator of Veohproxy has dealt with the issues and i am tidying up a version with full download capability, IMDB, buffer threading etc

Should be fun..


Cheers V

agentlame
December 4th, 2008, 07:20 AM
the man himself... welcome!

genuinely: thank you for your awesome wealth of plugins... to my girlfriend's dismay, i watched three hours of mythbusters, yesterday. :D

i've been following the "...thanks phara" thread on xbmc.org with bated breath.

i think we're all excited to see the new nv plugin.... the feature list sounds amazing!

aircool00
December 4th, 2008, 11:25 PM
Thanks voinage, for the update. Looking forward to the update my tvserver will be happy.

grey
December 5th, 2008, 06:34 AM
any updates ?

thanks!

voinage
December 10th, 2008, 08:28 PM
Try the freemedia.tv though

JimWiley
January 11th, 2009, 05:55 AM
Hi,

I'm trying to play stuff from FreeMediaTV on the AppleTV as recommended above. I've started Veohproxy in a terminal window, so that I can monitor error output (since playing veoh vids seems to fail everytime on the AppleTV): this is what it gives me:

-bash-2.05b$ python /Applications/veohproxy/default.py
Sun Jan 11 11:47:52 2009 VeohProxy Starts - 127.0.0.1:64653
Sun Jan 11 11:50:34 2009 Serving HEAD request...
Sun Jan 11 11:50:34 2009 Getting infos from NinjaVideo.net for Video ID 1771 ...
Sun Jan 11 11:50:39 2009 Serving GET request...
Sun Jan 11 11:50:39 2009 Getting infos from NinjaVideo.net for Video ID 1771 ...
Traceback (most recent call last):
File "/Applications/veohproxy/default.py", line 70, in answer_request
s.serveNinjaVideo(request_path, requestedRange, sendData)
File "/Applications/veohproxy/default.py", line 128, in serveNinjaVideo
(myFileHash,myFileSize,myFileName,myParthHashFile, myUrlRoot,hashes)=s.getNinja(request_path)
File "/Applications/veohproxy/default.py", line 244, in getNinja
if params["Method"]!="ninjaveoh":
KeyError: 'Method'
Traceback (most recent call last):
File "/Applications/veohproxy/default.py", line 70, in answer_request
s.serveNinjaVideo(request_path, requestedRange, sendData)
File "/Applications/veohproxy/default.py", line 128, in serveNinjaVideo
(myFileHash,myFileSize,myFileName,myParthHashFile, myUrlRoot,hashes)=s.getNinja(request_path)
File "/Applications/veohproxy/default.py", line 244, in getNinja
if params["Method"]!="ninjaveoh":
KeyError: 'Method'


Are there any experts who can give pointers about where I might be going wrong? Any help is greatly appreciated!

Thanks,


Jim.

JimWiley
January 11th, 2009, 06:01 AM
PS. Anyone having anyluck with "Divx Veoh Movies - Brilliant." menu item? Just gives me a blank screen (plus I get no output in terminal window showing veohproxy output) - just remembered and thought I'd better add this problem too. No other menu items seem to give this issue with this plugin on AppleTV

PPS Running Apple TV 2.3 and latest Boxee Bulid (9/1/09)

Jim.