Log in

View Full Version : Ubuntu 9.04 in VirtualBox


robisaks
June 4th, 2009, 11:58 AM
Hey everyone, I wanted to make things a little easier on myself so I'm trying to run boxee inside a ubuntu virtual box. However, when boxee starts the screen goes black for a second then it quits out. Has anyone tried this?

some info from terminal:
Running Boxee test...
* Enable platform firectoriesAnd the log goes to... /tmp/berger-
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 1 (X_CreateWindow)
Serial number of failed request: 21
Current serial number in output stream: 22
Boxee: asked to stop
Boxee: already stopped
BXBGProcess, Resolver Audio Processor, asked to stop, this = 0x8fa38e0
BXBGProcess, Resolver Video Processor, asked to stop, this = 0x8fa3874
BXBGProcess, , asked to stop, this = 0x8fa339c
BXBGProcess, Application Messenger, asked to stop, this = 0x8f0e7e4
BXBGProcess, Application Messenger, asked to stop, this = 0x8f0e7e4

glxinfo | grep -i direct
direct rendering: Yes

jdarnold
June 4th, 2009, 01:10 PM
This almost certainly won't work, as I don't believe any VM solution currently "does" OpenGL, which Boxee requires and is probalby why it isn't working for you now.

robisaks
June 5th, 2009, 08:56 AM
I knew boxee required openGL but from the forum posts I read, most people were saying that it would run unusably slow without it, rather than it not working at all.

I guess I'll have to dust off the old computer and set it up with boxee :)

Thanks for the reply.

The funny thing is that in 9.04 glxinfo displays yes, but in 8.04 it displays no.

liquid64
June 5th, 2009, 10:31 AM
Actually, I believe the later versions of virtualbox actually support opengl, to some degree. I haven't been able to get boxee working under a ubuntu 9.04 VM either though.

Here's a screenshot of the option that needs to be enabled:
http://g.imagehost.org/view/0227/opengl