boxee :: forums  

Go Back   boxee :: forums > boxee community > Boxee Box help

Reply
 
Thread Tools Display Modes
  #1  
Old November 13th, 2010, 07:53 PM
dconti dconti is offline
team boxee
 
Join Date: Feb 2009
Posts: 322
Default Tips for network shares with Boxee

Hey guys,

I am trying to consolidate info that i have and guidance folks have posted on the forums into a more standard FAQ. Starting from a rough draft, I would love to get this ironed out and posted in a more visible space. First off though, i want to make sure that it has enough information to help people navigate through their issues.

I'll continue to post on other threads and add guidance to this top post as needed, or feel free to post additional advice you have below. File sharing shouldn't require anything overly complicated on your windows/osx/linux machine, so if you have only had success using something tricky, i'd love to have a chance to troubleshoot with you a bit.

Thanks. Any comments/feedback very much appreciated -

-----

Scanning the local network

When you first power on Boxee, you'll be prompted to configure your network setup. Once you've done this we will start scanning your local network looking for two things:

* Computers and network attached storage devices supporting the SMB protocol
* UPnP/DLNA devices capable of acting as a Media Server

SMB is implemented by Windows, MacOS, Linux, and most network attached storage devices. It is an extremely common and well tested protocol for accessing files over a network. Boxee supports adding SMB servers as a "content source" from which we'll index, identify, and categorize movies, pictures, and music.

Boxee takes a very aggressive approach to locating SMB servers:

* We issue broadcast search queries using the traditional (NetBIOS) method used in MacOS, Linux, Network Attached Storage devices, and Windows versions up to and including Windows XP
* We issue multicast search queries using the more recent (Web Services) method used in Windows Vista and Windows 7
* We send a direct message to every possible node on your home network checking to see if they support the NetBIOS method

This approach helps minimize the impact of misconfigured networks and variations between desktop operating systems. A precondition for this approach is the ability to use NetBIOS to communicate with the server.

After we have searched and located all of the machines we believe support SMB on your subnet, we start indexing shares from these servers so you can browse and add content sources.

Troubleshooting

If we don't find your network share, there are a few possibilities. First off, our odds of being successful go up if the boxee box is on the same network as the file server. Typically this is as easy as ensuring they are hooked up to the same router.

Second, if we don't see your share in the files -> network section, the odds are not good that we will properly locate and scan it if added manually. The reason is the manual addition of servers is designed to cover cases where the server is not on the local subnet (such as complex home network configurations); if you manually add a server that is on the local subnet, Boxee will try to verify that it is online using similar techniques to how it discovers the servers it shows in the file browser.

If your file share is on a Mac OSX machine:

1) Make sure your shares are exposed via SMB: go to system preferences, sharing, file sharing (ensure this is enabled), options, and check 'Share files and folders using SMB (Windows)'
2) Make sure your shares are available either via a guest account, or via a user account you can enter on your boxee box.

If your file share is on a Linux machine:

1) Make sure you have a netbios name set for your machine (typically in /etc/smb.conf or /etc/samba/smb.conf) and that you have your shares set as browsable.
2) Make sure the nmbd (netbios name resolution, this is part of samba) is running on your server; without this you will need to add your shares manually using the ip address
3) If possible, validate that you can access the shares from another machine
4) Ensure that either a) your shares are marked as guest accessible, or b) your shares are accessible by a user account that you can enter on your boxee box.
5) Ensure you have file permissions set on the share in line with the user account you use; if you use a guest account to access the share, you must ensure that read permissions are available for the guest user

If your file share is on a Windows Vista or Windows 7 machine:

1) Ensure your network interface is marked as 'home'. Windows ties a huge amount of state in file sharing support and firewall configuration to the network type.
2) Ensure you either have guest access enabled and your file shares are marked as readable by everyone, or that you have your folders shared by a specific user account you can enter on your boxee box.
3) In your networking settings, make sure that file sharing is enabled; this should be set by default if your network interface is set to home, but it may be disabled on accident
4) If possible, browse your network using explorer (open an explorer pane, go to the lower left and select network, then choose your workgroup - which is probably 'WORKGROUP' or 'MSHOME' - make sure your machine shows up there)
5) If you are using user accounts, you may need to ensure that security on the folders and files you are accessing allows 'everyone'. It is worth noting that if you configure a homegroup, file permissions are set correctly for your files.
6) Very important - it is worth noting that the security access on shares can show one thing in the 'share ...' section and a completely different thing in 'advanced settings' -> 'permissions' section. You need to ensure that both of these sections are aligned, otherwise you may get access denied issues.

If your file share is on a Windows XP machine:

1) Make sure you either have a firewall exception that covers file sharing, or that you have the firewall disabled. The inbox firewall for Windows XP SP2 and SP3 has a simple configuration for this, as do most third party firewall applications.

Odds and ends for Windows machines:
*) If your windows machine is part of a Windows domain (this is sometimes the case on larger company networks), you'll need to have a local machine user account (preferably not the administrator account) that you can give read access to your shares. This local machine user account will be the one you use from the boxee box, not your Windows domain account

*) If your network is part of a domain configured with IPSec (very rare) you may need to check with your IT administrator to ensure that NetBIOS and SMB are accessible by non-domain devices.

*) If you are still getting prompted for credentials and unable to access your windows share, and you've removed windows live essentials, and you no matter what cannot get things to work, you can try what some wdtv live owners have done to correct windows security policy around file sharing. Please note these are advanced settings and you should set a restore point prior to trying these:

Quote:
1. Start > type 'Secpol.msc' .... Navigate to 'Local Policies' > 'Security Options' > 'Network access: Restrict anonymous access to Named Pipes and Shares' ... changed from 'enabled' to 'disabled'.

2. Preform the following registry changes...
a. Navigate to 'HKEY_LOCAL_MACHINE\System\CurrentControlSet\Contr ol\Lsa' ...
i. On the right side, double-click on 'everyoneincludesanonymous' and change the 'Value data' from '0' to '1'
ii. On the right side, double-click on 'NoLmHash' and change the 'Value data' from '1' to '0'
b. Navigate to 'HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servi ces\Lanman Server\Parameters'
i. Double-click on 'restrictnullsessaccess' and change the 'Value data' from '1' to '0' (Note: this value was allready set to 0 for me)

3. Re-boot your PC, then navigate to the network shares on WDTV Live and hopefully this will work for you to.
Known issues

* When streaming high bitrate content from a Windows 7 machine, i sometimes see rebuffering, but don't see this from Windows Home Server or other file shares
-- Windows 7 appears to significantly reduce the bandwidth for background file transfers when other tasks run by default. Server versions of windows don't do this as they try to keep equal priority for all tasks. You can reconfigure Windows 7 to keep an equal priority for file serving by following steps in this post: http://forums.boxee.tv/showpost.php?...6&postcount=36
__________________
dan conti, boxee engineer

Last edited by dconti; December 14th, 2010 at 12:15 PM. Reason: add notes on file permissions, workaround for WLE, workaround for nmbd not running, notes on sharing on windows
Reply With Quote
  #2  
Old November 13th, 2010, 08:10 PM
gmd024 gmd024 is offline
Moderator
 
Join Date: Apr 2010
Posts: 1,521
Default

Quote:
Originally Posted by dconti View Post
Thanks. Any comments/feedback very much appreciated -

-----
Dan - hope I didn't miss this info - but I don't see where it's mentioned, that on a Windows 7 share to also set the 'security' settings to allow 'everyone' - this has unlocked a few sharing scenarios on other media players for me in the past - and I can't say for sure if it helped me set up Boxee without issue because I simply 'do it' when setting the Boxee App and recently the Boxee Box

Last edited by darcilicious; November 13th, 2010 at 09:33 PM. Reason: trimmed down the quoted text -- pm me if need be :)
Reply With Quote
  #3  
Old November 13th, 2010, 08:17 PM
dconti dconti is offline
team boxee
 
Join Date: Feb 2009
Posts: 322
Default

Quote:
Originally Posted by gmd024 View Post
Dan - hope I didn't miss this info - but I don't see where it's mentioned, that on a Windows 7 share to also set the 'security' settings to allow 'everyone' - this has unlocked a few sharing scenarios on other media players for me in the past - and I can't say for sure if it helped me set up Boxee without issue because I simply 'do it' when setting the Boxee App and recently the Boxee Box
hey, thanks for the tip, much appreciated. let me try that out a bit on monday and i'll update the thread. i *think* it should work without requiring that, but i'd rather be certain
__________________
dan conti, boxee engineer
Reply With Quote
  #4  
Old November 13th, 2010, 10:03 PM
timbudtwo timbudtwo is offline
Member
 
Join Date: Feb 2010
Posts: 64
Default

I am not alone in saying this but I did have to do a few tricky things to get sharing working. I had to disable media streaming. As well I had share the folder with everyone via advanced networking, simply sharing it did nothing. I can browse the folder structure, but nothing is indexed (even when told to manually.) While I can select and watch movies, I am greeted with a notice that my sources are disconnected. I am using win 7 x64 pro. No live installed. Computer is hooked up through a client bridge (ddwrt) to main router (stock dlink.)


Last edited by timbudtwo; November 13th, 2010 at 10:41 PM.
Reply With Quote
  #5  
Old November 14th, 2010, 07:46 AM
dbretton dbretton is offline
Member
 
Join Date: Nov 2010
Posts: 44
Default

Quote:
Originally Posted by timbudtwo View Post
I am not alone in saying this but I did have to do a few tricky things to get sharing working. I had to disable media streaming. As well I had share the folder with everyone via advanced networking, simply sharing it did nothing. I can browse the folder structure, but nothing is indexed (even when told to manually.) While I can select and watch movies, I am greeted with a notice that my sources are disconnected. I am using win 7 x64 pro. No live installed. Computer is hooked up through a client bridge (ddwrt) to main router (stock dlink.)

This is the exact problem I have. I have 2 different shares, with the identical problem:
system A: Windows XP Pro x32
system B: Windows Vista Home
wireless router: Linksys WRT160N

Also, my home network's WORKGROUP name is "W0", if that makes any difference

Last edited by dbretton; November 14th, 2010 at 07:55 AM.
Reply With Quote
  #6  
Old November 14th, 2010, 09:35 AM
l0th l0th is offline
Senior Member
 
Join Date: Nov 2010
Posts: 235
Default

no matter what I do, I can see computers on my network (all Win 7) from BB but I can't access their shared folders. When I try to see the shared folders BB asks for username and password and none seems to work (whether username on the Win computer, "guest" or nothing). This is strange because all win 7 computers on the network have no problem seeing and browsing one another's shared folder without the need to enter a password.
Reply With Quote
  #7  
Old November 14th, 2010, 02:04 PM
dbretton dbretton is offline
Member
 
Join Date: Nov 2010
Posts: 44
Default

Quote:
Originally Posted by dbretton View Post
This is the exact problem I have. I have 2 different shares, with the identical problem:
system A: Windows XP Pro x32
system B: Windows Vista Home
wireless router: Linksys WRT160N

Also, my home network's WORKGROUP name is "W0", if that makes any difference
Based upon some of the suggestions here, I have everything coming up fine on both boxes now.

Here are the changes I made to both my Windows Vista laptop and my Windows XP box to allow Boxee Box to work with the shares:

1) Created a new user account "shareguest", exclusively for accessing shared drives.
2) Added UDP ports 137,138,139 and TCP/IP ports 137,138,139 through Windows Firewall.
3) Turned on NetBios over TCP/IP.
4) Removed the existing shares on Boxee and reconnected to them as "shareguest".
5) Rebooted Boxee Box

Now everything is working ok. It wouldn't surprise me if only 1 or 2 of the above steps are what got things working for me. However, I don't have the time to sit down for several hours and do fault isolation, so I did everything at once.

YMMV!
Reply With Quote
  #8  
Old February 5th, 2011, 07:53 AM
jimbob_sf jimbob_sf is offline
Junior Member
 
Join Date: Feb 2010
Posts: 7
Default Got Win 7 to work

Bingo. I followed all the suggested for Win 7. I didn't like having a Guest account, so I disabled it. I had all my shares and security settings set, but still no go.

I finally went to Advanced sharing settings and turned off "Password protected sharing". This did it.
Reply With Quote
  #9  
Old November 15th, 2010, 11:20 AM
dconti dconti is offline
team boxee
 
Join Date: Feb 2009
Posts: 322
Default

Quote:
Originally Posted by gmd024 View Post
Dan - hope I didn't miss this info - but I don't see where it's mentioned, that on a Windows 7 share to also set the 'security' settings to allow 'everyone' - this has unlocked a few sharing scenarios on other media players for me in the past - and I can't say for sure if it helped me set up Boxee without issue because I simply 'do it' when setting the Boxee App and recently the Boxee Box
just to follow up - i'm noticing on my win7 machine that this was already set.

also:

network discovery is enabled for home networks
file and printer sharing is enabled
public folder sharing is on (though not used, i can access shares in my user account)
password protected sharing is on
__________________
dan conti, boxee engineer
Reply With Quote
  #10  
Old November 15th, 2010, 01:47 PM
gmd024 gmd024 is offline
Moderator
 
Join Date: Apr 2010
Posts: 1,521
Default

Quote:
Originally Posted by dconti View Post
just to follow up - i'm noticing on my win7 machine that this was already set.

also:

network discovery is enabled for home networks
file and printer sharing is enabled
public folder sharing is on (though not used, i can access shares in my user account)
password protected sharing is on
Ditto on my Home/Work network profile - except my password protection is 'off'
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:19 AM.


skin based on greenzero from vBSkins.com

 
Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2011, Jelsoft Enterprises Ltd.