boxee :: forums  

Go Back   boxee :: forums > boxee community > boxee for linux help

Reply
 
Thread Tools Display Modes
  #11  
Old November 5th, 2009, 02:39 PM
RobSpectre RobSpectre is offline
team boxee
 
Join Date: Jun 2009
Location: San Francisco, CA
Posts: 109
Send a message via Yahoo to RobSpectre
Default

Thank you for this guide BeyondZero - overwhelmingly the guides one finds when googling to figure out how to enable HDMI audio involve uninstalling pulseaudio. Great to be able to get HDMI audio working while sticking with the future of audio on Linux. The biggest help was the device chooser utility which absolutely changed my opinion of the pulseaudio platform - this is useful as hell.

One note for Zotac users, you may need to unmute a setting in your ALSA mixer in order to get HDMI audio. Following this guide, I saw the audio successfully go through the pulseaudio mixer, but never got any sound to my TV speakers.

Using this forum post, I found I needed to unmute the IEC958 device in the alsamixer.

You can do it either by using the "alsamixer" utility, right-arrow until you see IEC958 and pressing the "m" key or by running this command:

Code:
amixer -c 1 sset 'IEC958' unmute
__________________
web: gonzee.tv
twitter: @dn0t
boxee: RobSpectre
cliqset: RobSpectre
Reply With Quote
  #12  
Old January 25th, 2010, 11:29 AM
Jeff91 Jeff91 is offline
Junior Member
 
Join Date: Aug 2009
Location: Chicago Suburbs
Posts: 12
Send a message via AIM to Jeff91
Default

Hey All,

I realise this is a slightly old thread at this point, but I am trying to get audio to work over my HDMI on Ubuntu 9.10, here is the output from my aplay -l

Code:
owner@owner-desktop:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC888 Analog [ALC888 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC888 Digital [ALC888 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Using said information I added the following line to my /etc/pulse/default.pa:

Code:
### Load audio drivers statically (it's probably better to not load
### these drivers manually, but instead use module-hal-detect --
### see below -- for doing this automatically)
#load-module module-alsa-sink
#load-module module-alsa-source device=hw:1,0
#load-module module-oss device="/dev/dsp" sink_name=output source_name=input
#load-module module-oss-mmap device="/dev/dsp" sink_name=output source_name=input
#load-module module-null-sink
#load-module module-pipe-sink
load-module module-alsa-sink device=hw:0,3
I then went into my sound preferences and under "Hardware" I selected "Digital Stereo (HDMI) Output" I also tried selecting "Internal Audio Digital Stereo (HDMI)" under "output" but this also had no effect.

Is there something I am missing here? I also have the 185.18.36 nVidia drivers installed if that matters at all...

Regards,
~Jeff
__________________
Sager NP8662 - 2.8gzh p9700 - 4 gigs DDR3 - nVidia 260m - 320gig HDD - Linux 64bit
Asus EEE 900A - Atom 1.6ghz - 2gigs DDR2 - 32gig SSD - Ubuntu 32bit
Reply With Quote
  #13  
Old February 26th, 2010, 10:33 AM
terminus terminus is offline
Junior Member
 
Join Date: Feb 2010
Posts: 1
Default Doesn't work with multi-channel sound

This is a useful thread, but even by following it, I can only hear Dolby/DTS sources by downsampling them to Stereo - it doesn't pass the encoded streams through. Without downsampling, I just get an awful thundering noise. Are others getting multi-channel sound?

Last edited by terminus; February 26th, 2010 at 10:33 AM. Reason: Clarity
Reply With Quote
  #14  
Old February 26th, 2010, 11:23 PM
beyondzero beyondzero is offline
Member
 
Join Date: Jun 2009
Posts: 42
Default

Quote:
Originally Posted by Jeff91 View Post
I then went into my sound preferences and under "Hardware" I selected "Digital Stereo (HDMI) Output" I also tried selecting "Internal Audio Digital Stereo (HDMI)" under "output" but this also had no effect.

Is there something I am missing here? I also have the 185.18.36 nVidia drivers installed if that matters at all...

Regards,
~Jeff
Can you get sound in some other app, like VLC?
Reply With Quote
  #15  
Old February 26th, 2010, 11:24 PM
beyondzero beyondzero is offline
Member
 
Join Date: Jun 2009
Posts: 42
Default

Quote:
Originally Posted by terminus View Post
This is a useful thread, but even by following it, I can only hear Dolby/DTS sources by downsampling them to Stereo - it doesn't pass the encoded streams through. Without downsampling, I just get an awful thundering noise. Are others getting multi-channel sound?
Alas that is necessary. I do not believe Ubuntu (and therefore Boxee) is able to pass the raw digital audio.
Reply With Quote
  #16  
Old November 29th, 2010, 12:42 AM
elventear elventear is offline
Junior Member
 
Join Date: Nov 2010
Posts: 2
Default

On Ubuntu 10.10 I have HDMI audio working out of the Box almost. Every time that I begin a session after a reboot, the Audio works fine. But if I log out and login again, then it stops working. No idea why. Pulse does not report any problem and seems to be streaming the audio but nothing comes out of the speakers. A reboot, will fix this for the first logon only.

I tried setting the alsa-sink settings and I get a similar behaviour and get an error on the locks saying the HDMI device is busy and the sink is disabled. Haven't been able to track what the source of the error is.
Reply With Quote
  #17  
Old November 29th, 2010, 01:09 AM
Silverlock Silverlock is offline
Member
 
Join Date: Jan 2010
Posts: 77
Default

All I had to do to my Revo was:
1. Grab the Nvidia drivers from the Ubuntu repositories.
2. Change the Profile in System -> Preferences -> Sound to "Digital Stereo (HDMI) Output + Analog Stereo Input".
3. Unmute all the SPDIF outputs in alsamixer.

In Boxee:
1. "DTS capable receiver" is checked.
2. "Dolby Digital (AC3) receiver" is unchecked.
3. "Downmix multichannel audio to stereo" is checked.

So far it's played everything I've thrown at it, with no problems after reboots or logouts.
__________________
Boxee Beta 0.9.22.13692 (32 bit) / Lucid Lynx (Ubuntu 10.04)
Acer AspireRevo 3610 (Atom N330/ION/4GB RAM+500GB HD), PS3 BD Remote, HDMI to Vizio M320VT
Boxee Beta 0.9.22.13692 (32 bit) / Maverick Meerkat (Ubuntu 10.10)
Asus Eee PC 901 (Atom N270/Intel 945GSE/2GB RAM+32GB SDD)
Reply With Quote
Reply

Bookmarks

Tags
audio, coax, hdmi, linux, toslink

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:59 PM.


skin based on greenzero from vBSkins.com

 
Powered by vBulletin® Version 3.7.5
Copyright ©2000 - 2010, Jelsoft Enterprises Ltd.