Boxee

regression: Boxee fails to resume video after long paused, all video either freeze frames or black screen, audio works though

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: P2 P2
  • Resolution: Duplicate
  • Fix Version/s: None
  • Component/s: Graphics and Display
  • Labels:
    None
  • Severity:
    Major
  • Version:
    1.1.1.19092
  • Operating System:
    Boxee Box
  • Number of attachments:
    1

Description

Short Description:

I stream most of my video off a hard drive attached to an Apple Airport Extreme. This is attached wireless to my Apple Time Capsule, Boxee connects wirelessly It works like a basic NAS, although a bit slow. What happens is when I'm playing a DVR rip of my NAS, i pause it for while. Boxee goes in to screensaver and the hard drive of my Airport goes to sleep. After say, 5-10 mins or longer I attempt to resume the video and it kicks me out back to menu. When I then resume the video, video itself freezes but audio continues. All other video, be it video files like divx, MKV or of the internet does not play anymore, I get black screen and short burst of audio.. then it does nothing. Only way to fix it is restart boxee box, go back to DVD rip and restart video from the beginning and it will work.

With previous firmwares, 1.0.4 and earlier, boxee would just resume the video without any hiccups. All other video would also play fine after the issue.

I believe though this issue is not very widespread, as only people with slow network attached storage will run into this, if you have hdd attached directly to boxee, or decent speedy NAS you most likely never run into this issue.

How to reproduce:

My Time Capsule died over the weekend, so reproducing the issue was not easy. It doesn't occur when playing files back when the HDD is attached directly to the Box or to Airport extreme which now forms the main hub of the network. So it most likely is related to response time that it takes for Airport and HHD to stream video over to the box.

In steps:
1. Play dvd rip over the network, either via NAS or other computer with the HDD attached to it.
2. Pause it, let it sit for at least 5 mins or more so that HDD goes to sleep and Boxee does shows screensaver
3. Disconnect HDD from network or pc to simulate slows response time of the NAS
4. Play file on Boxee, boxee will quit playing and throw you back in the menu
5. Resume dvd rip from your left of.. (I had to restart boxee for to recognize my network share again)
6. Boxee will freeze frame, audio will still play...
7. Playing any other video will result in black screen and short bit of audio, be it from local or internet sources

Included are 2 logs, one from recreating the situation just when boxee throws you out to menu. Second log is after the restart mention above when the actually issue occurs with no video playing after resuming it.

IMHO this issue is caused by slow response in resuming from NAS Source, boxee expecting something to happen within a certain time scale but it doesn't... This causes a crash in the video driver... resulting the freeze frame or no video at all.

Thus if you have this issue, please vote for it.. and for boxee devs, u got questions ask me..

Issue Links

Activity

Ami Ben-David [Boxee] added a comment - 05/Jun/11 3:58 AM
closed as duplicate of BOXEE-6148

please comment and vote on the linked issue.

People

Vote (1)
Watch (5)

Dates

  • Created:
    03/Jun/11 9:06 AM
    Updated:
    12/Jul/11 10:14 AM
    Resolved:
    05/Jun/11 3:58 AM