Boxee

regression: "Loading Error" when browse into uPnP from the file/network menu when wireless

Details

  • Product:
    Boxee Client
  • Severity:
    Critical
  • Version:
    1.2.1.20451
  • Operating System:
    Boxee Box
  • Number of attachments:
    6

Description

having a wireless manual configured IP
browsing into UPNP fail with the "Loading Error" dialog.
Note: this issue is similar to BOXEE-10867 but in this issue the log does not contain any indication of a djmount crash

workaround: use wired connection

original report:
uPnP does not work in 1.2.1.20451. In fact, it has been broken (at least for me) in all the 1.2 betas too.

Going to Settings - File sources - uPnP doesn't show any uPnP server (nothing happens).

Going to Files -> Network -> uPnP from the main screen results in the error message "Loading error - could not access file, directory, or device".

The server is Windows 7 and AssetUPnP. I've tried the WMP11 uPnP server also.

Network is wireless, SMB works just fine (within the limits of network speed).

The Box is using a fixed P address (no DHCP).
  1. boxee.1318490771.2272.tar.bz2
    16/Oct/11 1:15 AM
    48 kB
    Jameel Al-Aziz
  2. boxee.1318816575.2661.tar.bz2
    16/Oct/11 10:03 PM
    14 kB
    Harvey Artz
  3. boxee.1318841978.1991.tar.bz2
    17/Oct/11 5:04 AM
    12 kB
    Ora Järvinen
  4. boxee.1319190964.2364.tar.bz2
    21/Oct/11 6:02 AM
    17 kB
    Ora Järvinen
  5. boxee.1319559702.2363.tar.bz2
    25/Oct/11 12:51 PM
    38 kB
    Steven Rollason
  6. boxee.1320880132.4632.tar.bz2
    09/Nov/11 6:13 PM
    32 kB
    Mike Pelley

Issue Links

Activity

Hide
Jameel Al-Aziz added a comment -
I'm experiencing the exact same problem. The server is Ubuntu 10.04 with TwonkyMedia Server and a fixed IP.

Attached are logs after I attempted the steps outlined in the bug report.
Show
Jameel Al-Aziz added a comment - I'm experiencing the exact same problem. The server is Ubuntu 10.04 with TwonkyMedia Server and a fixed IP. Attached are logs after I attempted the steps outlined in the bug report.
Hide
Rafael Mizrahi [Boxee] added a comment -
thanks Jameel.
I see in your log :
00:25:57.0947 T:3021130640 M:518201344 DEBUG: GetDirectory - Error getting upnp://all
00:25:57.0948 T:3021130640 M:518201344 DEBUG: Thread 3021130640 terminating
00:25:57.0948 T:3072427808 M:518201344 ERROR: CGUIWindowBoxeeMediaSourceAddShare::ShowNetworkDevices - Unable found network devices (msmk)

Ora Järvine, please also attach a DEBUG log which was produced during reproducing the problem.
Set the Settings > System > Debug > Debug Level = Debug
ReStart Boxee, and after reproducing the problem, get the log and attach it to this issue.
Boxee Box log may be found at http://Your_boxee_box_IP:8080/ click on the "Get latest " link.
DEBUG log slows down the performance. so afterward, switch the log level back to NONE
more information at
http://support.boxee.tv/entries/329278-i-ve-been-asked-by-boxee-support-to-send-debug-logs-how-do-i-do-that

please see if changing from static IP into Dynamic IP workaround this issue.
Show
Rafael Mizrahi [Boxee] added a comment - thanks Jameel. I see in your log : 00:25:57.0947 T:3021130640 M:518201344 DEBUG: GetDirectory - Error getting upnp://all 00:25:57.0948 T:3021130640 M:518201344 DEBUG: Thread 3021130640 terminating 00:25:57.0948 T:3072427808 M:518201344 ERROR: CGUIWindowBoxeeMediaSourceAddShare::ShowNetworkDevices - Unable found network devices (msmk) Ora Järvine, please also attach a DEBUG log which was produced during reproducing the problem. Set the Settings > System > Debug > Debug Level = Debug ReStart Boxee, and after reproducing the problem, get the log and attach it to this issue. Boxee Box log may be found at http://Your_boxee_box_IP:8080/ click on the "Get latest " link. DEBUG log slows down the performance. so afterward, switch the log level back to NONE more information at http://support.boxee.tv/entries/329278-i-ve-been-asked-by-boxee-support-to-send-debug-logs-how-do-i-do-that please see if changing from static IP into Dynamic IP workaround this issue.
Hide
Harvey Artz added a comment -
Same issue, using dynamic IP from Windows Server 2003. Neither windows media player or playon is showing up. I just get an error "Loading Error" when I try to browse uPnP from the file/network menu. Both work fine on my Sony SMP-N100.
Show
Harvey Artz added a comment - Same issue, using dynamic IP from Windows Server 2003. Neither windows media player or playon is showing up. I just get an error "Loading Error" when I try to browse uPnP from the file/network menu. Both work fine on my Sony SMP-N100.
Hide
Ora Järvinen added a comment -
Oops, sorry, attached same file multiple times...
Show
Ora Järvinen added a comment - Oops, sorry, attached same file multiple times...
Hide
Rafael Mizrahi [Boxee] added a comment -
Ora Järvinen, your log level is not in DEBUG
please Set the Settings > System > Debug > Debug Level = Debug
reproduce the issue, get the log file and attach it to this issue.
Show
Rafael Mizrahi [Boxee] added a comment - Ora Järvinen, your log level is not in DEBUG please Set the Settings > System > Debug > Debug Level = Debug reproduce the issue, get the log file and attach it to this issue.
Hide
Rafael Mizrahi [Boxee] added a comment -
If you cannot see upnp servers when browsing into Network > Upnp
please verify that the following ports are open in the firewall
1900, 2869 , 49152

* The UPnP framework uses UDP port 1900 and TCP port 2869. Simple Service Discovery Protocol (SSDP) uses multicast searches to discover UPnP devices
verify that these ports are open at the machine which hosts the upnp server and at the router.

* djmount (the fuse upnp library boxee 1.2 is using for upnp mounting) requires port 49152
Show
Rafael Mizrahi [Boxee] added a comment - If you cannot see upnp servers when browsing into Network > Upnp please verify that the following ports are open in the firewall 1900, 2869 , 49152 * The UPnP framework uses UDP port 1900 and TCP port 2869. Simple Service Discovery Protocol (SSDP) uses multicast searches to discover UPnP devices verify that these ports are open at the machine which hosts the upnp server and at the router. * djmount (the fuse upnp library boxee 1.2 is using for upnp mounting) requires port 49152
Hide
Ora Järvinen added a comment -
I disabled the (Windows) firewall completely... no change in behavior.

I'll submit new logs later when I have time...
Show
Ora Järvinen added a comment - I disabled the (Windows) firewall completely... no change in behavior. I'll submit new logs later when I have time...
Hide
Ora Järvinen added a comment -
Tried again today... I must be doing something wrong.

Debug level is certainly set to "DEBUG" (and a line of text appears at the top of the sreen displaying CPU usage, frame rate etc.).

The resulting .tar.bz2 file doesn't contain "root-boxee.log" (which is the file I assume you're interested in) like the other logs posted here. I even powered the box off, booted and checked the debug level. The file sizes are around 12 kb.
Show
Ora Järvinen added a comment - Tried again today... I must be doing something wrong. Debug level is certainly set to "DEBUG" (and a line of text appears at the top of the sreen displaying CPU usage, frame rate etc.). The resulting .tar.bz2 file doesn't contain "root-boxee.log" (which is the file I assume you're interested in) like the other logs posted here. I even powered the box off, booted and checked the debug level. The file sizes are around 12 kb.
Hide
Serg added a comment - - edited
I have exactly the same issue. Every time I tried to scan for uPnP it returned error "Could not access file, directory or device". I have PC with PlayOn server running on it and I can see it from PS3 but not from Boxee Box. Just in case I disabled Windows firewall but it didn't help. Firewall should not be a reason of problem in this case because I could see PlayOn server from PS3 in the same network. I tested it for couple of days, so PC and Boxee Box were rebooted not once. I use Windows 7 and SMB works properly and shares can be accessed from the Boxee Box.
Show
Serg added a comment - - edited I have exactly the same issue. Every time I tried to scan for uPnP it returned error "Could not access file, directory or device". I have PC with PlayOn server running on it and I can see it from PS3 but not from Boxee Box. Just in case I disabled Windows firewall but it didn't help. Firewall should not be a reason of problem in this case because I could see PlayOn server from PS3 in the same network. I tested it for couple of days, so PC and Boxee Box were rebooted not once. I use Windows 7 and SMB works properly and shares can be accessed from the Boxee Box.
Hide
gmd added a comment -
Serg - If PlayOn is your main UPnP issue then you might want to check and vote in the Jira ticket #10945 - and there's a current PlayOn work-around for the BBox... type ( m.playon.tv ) in the BBox's browser
Show
gmd added a comment - Serg - If PlayOn is your main UPnP issue then you might want to check and vote in the Jira ticket #10945 - and there's a current PlayOn work-around for the BBox... type ( m.playon.tv ) in the BBox's browser
Hide
Ora Järvinen added a comment -
uPnP problem log
Show
Ora Järvinen added a comment - uPnP problem log
Hide
Rafael Mizrahi [Boxee] added a comment -
thanks Ora,
I also see in your leg, the same error

11:55:16.0349 T:2959010704 M:529014784 DEBUG: GetDirectory - Error getting upnp://all
11:55:16.0349 T:2959010704 M:529014784 DEBUG: Thread 2959010704 terminating
11:55:16.0350 T:3071420192 M:529014784 ERROR: CGUIWindowBoxeeMediaSourceAddShare::ShowNetworkDevices - Unable found network devices (msmk)

having you both experience the same problem and error, is helping to try and reproduce this issue.
Show
Rafael Mizrahi [Boxee] added a comment - thanks Ora, I also see in your leg, the same error 11:55:16.0349 T:2959010704 M:529014784 DEBUG: GetDirectory - Error getting upnp://all 11:55:16.0349 T:2959010704 M:529014784 DEBUG: Thread 2959010704 terminating 11:55:16.0350 T:3071420192 M:529014784 ERROR: CGUIWindowBoxeeMediaSourceAddShare::ShowNetworkDevices - Unable found network devices (msmk) having you both experience the same problem and error, is helping to try and reproduce this issue.
Hide
Rafael Mizrahi [Boxee] added a comment -
reproduced using 1.2.2.20476
having a wireless manual configured IP
browsing into UPNP fail with the "Loading Error" dialog.

workaround: use dynamic IP or wired connection.
Show
Rafael Mizrahi [Boxee] added a comment - reproduced using 1.2.2.20476 having a wireless manual configured IP browsing into UPNP fail with the "Loading Error" dialog. workaround: use dynamic IP or wired connection.
Hide
Ora Järvinen added a comment -
It doesn't work for me either with dynamic or with fixed IP.

I can't easily use a wired connection but can't really see what difference it might make.
Show
Ora Järvinen added a comment - It doesn't work for me either with dynamic or with fixed IP. I can't easily use a wired connection but can't really see what difference it might make.
Hide
Joe Midway added a comment -
I'm using both dynamic and static IP from a DHCP server. Does not work with either. SMB (as stated above) works fine, uPNP does not work at all with any devices. Annoying since I can do more with the software version of Boxee on my mac then I can with the actual "appliance".

It was returning an error previously, now it just doesn't do anything when I search for uPnP devices.

Version is 1.2.1.20451-4f66dd0 from Oct 11, 2011
Show
Joe Midway added a comment - I'm using both dynamic and static IP from a DHCP server. Does not work with either. SMB (as stated above) works fine, uPNP does not work at all with any devices. Annoying since I can do more with the software version of Boxee on my mac then I can with the actual "appliance". It was returning an error previously, now it just doesn't do anything when I search for uPnP devices. Version is 1.2.1.20451-4f66dd0 from Oct 11, 2011
Hide
Steven Rollason added a comment -
Attached log file. Same "Loading Error" message here in 1.2.1.20451
Wireless with IP address via DHCP not static (but is reserved in router). UPnP server is Samsung AllShare on my phone if this makes any difference - can access this from Boxee on Mac (both wired and wireless).
Show
Steven Rollason added a comment - Attached log file. Same "Loading Error" message here in 1.2.1.20451 Wireless with IP address via DHCP not static (but is reserved in router). UPnP server is Samsung AllShare on my phone if this makes any difference - can access this from Boxee on Mac (both wired and wireless).
Hide
Steven Rollason added a comment -
I temporarily switched to a wired connection (still to the same router) and found that no error was displayed and it could see the UPnP server on my phone.
Since it was going through the same router (and the phone is connected wirelessly) it would seem that this is a problem with uPnP when wireless connection is enabled (but not specifically with static IP addresses).

Incidentally, after switching back to wireless again the error didn't re-appear immediately and the list of servers was still displayed. However, no files were shown when selecting the server from the list. This was presumably Boxee caching the list of servers it picked up when on the wired connection, as after rebooting the error came back.
Show
Steven Rollason added a comment - I temporarily switched to a wired connection (still to the same router) and found that no error was displayed and it could see the UPnP server on my phone. Since it was going through the same router (and the phone is connected wirelessly) it would seem that this is a problem with uPnP when wireless connection is enabled (but not specifically with static IP addresses). Incidentally, after switching back to wireless again the error didn't re-appear immediately and the list of servers was still displayed. However, no files were shown when selecting the server from the list. This was presumably Boxee caching the list of servers it picked up when on the wired connection, as after rebooting the error came back.
Hide
gmd added a comment -
After reading Steven Rollason's comment above I just realized while troubleshooting an issue with my Windows Home Server yesterday that the Twonky UPnP server in the WHS was working fine on the BBox using frmw v122.20482 over a wired Gb network - wireless is disabled in my router

However the PlayOn UPnP server installed on my W7 PC, accessed with the same BBox over the same wired Gb network is still not functioning correctly as explained in Jira ticket #10945
Show
gmd added a comment - After reading Steven Rollason's comment above I just realized while troubleshooting an issue with my Windows Home Server yesterday that the Twonky UPnP server in the WHS was working fine on the BBox using frmw v122.20482 over a wired Gb network - wireless is disabled in my router However the PlayOn UPnP server installed on my W7 PC, accessed with the same BBox over the same wired Gb network is still not functioning correctly as explained in Jira ticket #10945
Hide
Tom Aratyn added a comment -
This bug is blocking my purchase of a boxee.
Show
Tom Aratyn added a comment - This bug is blocking my purchase of a boxee.
Hide
Mike Pelley added a comment - - edited
Same problem as everyone else.

Since upgrading the firmware I cannot access my Synology DS211j NAS media server.

When I try to add a source and I select the upnp option Boxee Box "spins" the timer circle and then returns to the menu. No upnp servers are shown.

If I try to access the upnp server by navigation, I get a an error.

I'm running the Synology DSM 3.2-1944 firmware and I have no problem access the NAS upnp server from either my Sony PS3, MLPlayer Lite 1.1.8 on my iPod Touch, MLPlayer Lite 1.0.7 on my iPad (v.1), Windows Media Player 12.0.7601.17514 under Windows 7, and finally the Totem Movie Player 2.32.0 (using GStreamer 0.10.32) under Linux Mint 11.

It used to work fine using upnp from the NAS prior to the firmware update.

I have tried both using DHCP and manual network configuration. I am using wireless (wired would mean having to change floors).
Show
Mike Pelley added a comment - - edited Same problem as everyone else. Since upgrading the firmware I cannot access my Synology DS211j NAS media server. When I try to add a source and I select the upnp option Boxee Box "spins" the timer circle and then returns to the menu. No upnp servers are shown. If I try to access the upnp server by navigation, I get a an error. I'm running the Synology DSM 3.2-1944 firmware and I have no problem access the NAS upnp server from either my Sony PS3, MLPlayer Lite 1.1.8 on my iPod Touch, MLPlayer Lite 1.0.7 on my iPad (v.1), Windows Media Player 12.0.7601.17514 under Windows 7, and finally the Totem Movie Player 2.32.0 (using GStreamer 0.10.32) under Linux Mint 11. It used to work fine using upnp from the NAS prior to the firmware update. I have tried both using DHCP and manual network configuration. I am using wireless (wired would mean having to change floors).
Hide
Mike Pelley added a comment -
Here's my log with debug enabled...
Show
Mike Pelley added a comment - Here's my log with debug enabled...
Hide
Monroe Preston added a comment -
I just purchased 2 of these boxes mainly for wireless local streaming. This issue needs to be addressed. My older DSM-520 streams files fine through my PlayOn Premium account but the new, "better?"
 Boxee has the UPnP "error" issue. These will be returnned unless a fix becomes available. I'm gonna try to factory reset the box and disconnect my interner so it doesn;t update firmware. See if it't a firmware issue. Anyone else have any luck?
Show
Monroe Preston added a comment - I just purchased 2 of these boxes mainly for wireless local streaming. This issue needs to be addressed. My older DSM-520 streams files fine through my PlayOn Premium account but the new, "better?"  Boxee has the UPnP "error" issue. These will be returnned unless a fix becomes available. I'm gonna try to factory reset the box and disconnect my interner so it doesn;t update firmware. See if it't a firmware issue. Anyone else have any luck?
Hide
gmd added a comment -
There's a separate ticket (# 10945) concerning PlayOn -- there's also a workaround that allows the use on PlayOn in the mean time - type ' m.playon.tv ' in the BBox's browser
Show
gmd added a comment - There's a separate ticket (# 10945) concerning PlayOn -- there's also a workaround that allows the use on PlayOn in the mean time - type ' m.playon.tv ' in the BBox's browser
Hide
Rafael Mizrahi [Boxee] added a comment -
closed. verified using 1.5.0.22662
Show
Rafael Mizrahi [Boxee] added a comment - closed. verified using 1.5.0.22662

People

Vote (17)
Watch (16)

Dates

  • Created:
    Updated:
    Resolved: