Boxee

Replace boxee font with full unicode font

Details

  • Severity:
    Critical
  • Number of attachments:
    2

Description

charcters of non English languages such as hebrew appear as squares.
japanese and chinese text not working
Japanese text in file paths is not shown (see image)

Issue Links

Activity

Yuval Tal [Boxee] added a comment - 24/Aug/08 1:15 PM
We need full unicode font. Tom?
Rafael Mizrahi [Boxee] made changes - 13/May/09 1:38 PM
Field Original Value New Value
Fix Version/s future boxee top model [ 11110 ]
Rafael Mizrahi [Boxee] made changes - 13/May/09 1:56 PM
Project boxee trac [ 10054 ] boxee [ 10000 ]
Key TRAC-976 BOXEE-121
Affects Version/s future boxee top model [ 11110 ]
Component/s client [ 10312 ]
Fix Version/s future release [ 10019 ]
Fix Version/s future boxee top model [ 11110 ]
Rafael Mizrahi [Boxee] made changes - 17/May/09 5:41 AM
Workflow jira [ 24806 ] Copy of jira [ 26828 ]
Rafael Mizrahi [Boxee] made changes - 17/May/09 5:43 AM
Workflow Copy of jira [ 26828 ] jira [ 27758 ]
Rafael Mizrahi [Boxee] made changes - 17/May/09 5:49 AM
Workflow jira [ 27758 ] Copy of jira [ 28688 ]
Rafael Mizrahi [Boxee] made changes - 17/May/09 5:51 AM
Workflow Copy of jira [ 28688 ] jira [ 29618 ]
Rafael Mizrahi [Boxee] made changes - 17/May/09 5:53 AM
Workflow jira [ 29618 ] Copy of jira [ 30732 ]
Rafael Mizrahi [Boxee] made changes - 26/May/09 4:53 AM
Workflow Copy of jira [ 30732 ] jira [ 32875 ]
Rafael Mizrahi [Boxee] made changes - 26/May/09 5:09 AM
Workflow jira [ 32875 ] Copy of jira [ 35123 ]
Rafael Mizrahi [Boxee] made changes - 03/Jun/09 7:37 AM
Assignee vulkanr
[ vulkanr ]
Rafael Mizrahi [Boxee] made changes - 19/Jul/09 10:32 AM
Affects Version/s alpha [ 11130 ]
Feature Parent values: Client(10102). Level 1 values: UI and Usability (10109).
Operating System [ALL]
Rafael Mizrahi [Boxee] made changes - 20/Jul/09 5:39 AM
Summary japanese font not working Replace font with full unicode font
Description imported from trac ticket http://trac.boxee.tv/ticket/828
Japanese text in file paths is not shown (see image)
japanese and chinese text not working
Japanese text in file paths is not shown (see image)
Rafael Mizrahi [Boxee] made changes - 05/Aug/09 5:17 AM
Assignee idan [ idan ]
Fix Version/s beta [ 11122 ]
Fix Version/s future release [ 10019 ]
Idan Cohen [Boxee] added a comment - 09/Dec/09 11:25 AM
any news?
Idan Cohen [Boxee] made changes - 09/Dec/09 11:25 AM
Assignee idan [ idan ] Tom Sella [ tsella ]
Rafael Mizrahi [Boxee] made changes - 27/Dec/09 7:24 AM
Summary Replace font with full unicode font Replace boxee font with full unicode font
Security #jira-developers [ 10020 ]
Priority Major [ 3 ] Critical [ 2 ]
Description japanese and chinese text not working
Japanese text in file paths is not shown (see image)
charcters of non English languages such as hebrew appear as squares.
japanese and chinese text not working
Japanese text in file paths is not shown (see image)
Rafael Mizrahi [Boxee] made changes - 27/Dec/09 7:25 AM
Link This issue is duplicated by BOXEE-3852 [ BOXEE-3852 ]
David Zentgraf added a comment - 29/Dec/09 9:03 AM
The beta version seems to include full unicode fonts, non-english characters are still showing up as squares though. (Windows 7, Japanese version, Boxee settings on default and English)
Rafael Mizrahi [Boxee] made changes - 09/Feb/10 4:24 AM
Fix Version/s internal_10_Feb_2010 [ 11191 ]
Fix Version/s beta [ 11122 ]
Tom Sella [Boxee] added a comment - 09/Feb/10 7:01 AM
fixed in trunk
Tom Sella [Boxee] made changes - 09/Feb/10 7:01 AM
Status Open [ 1 ] Resolved [ 5 ]
Resolution Fixed [ 1 ]
Rafael Mizrahi [Boxee] made changes - 16/Feb/10 4:38 AM
Fix Version/s internal_24_Feb_2010 [ 11193 ]
Fix Version/s internal_10_Feb_2010 [ 11191 ]
Ami Ben-David [Boxee] added a comment - 15/Mar/10 6:57 AM
Reproducible on boxee-0.9.20.11xxx
Japanese and Chinese text still appears as squares...
Ami Ben-David [Boxee] made changes - 15/Mar/10 6:57 AM
Resolution Fixed [ 1 ]
Status Resolved [ 5 ] Reopened [ 4 ]
Assignee Tom Sella [ tsella ] idan [ idan ]
Ami Ben-David [Boxee] made changes - 15/Mar/10 6:57 AM
Fix Version/s internal_21_Mar_2010 [ 11213 ]
Fix Version/s internal_24_Feb_2010 [ 11193 ]
Rafael Mizrahi [Boxee] made changes - 29/Mar/10 3:10 AM
Fix Version/s internal_4_Apr_2010 [ 11215 ]
Fix Version/s internal_21_Mar_2010 [ 11213 ]
Rafael Mizrahi [Boxee] made changes - 07/Apr/10 5:34 AM
Link This issue relates BOXEE-4260 [ BOXEE-4260 ]
Rafael Mizrahi [Boxee] made changes - 07/Apr/10 5:43 AM
Fix Version/s elin [ 11201 ]
Fix Version/s internal_4_Apr_2010 [ 11215 ]
Rafael Mizrahi [Boxee] made changes - 27/Apr/10 5:50 AM
Fix Version/s beta [ 11122 ]
Fix Version/s elin [ 11201 ]
Rafael Mizrahi [Boxee] made changes - 27/Apr/10 5:54 AM
Affects Version/s beta [ 11122 ]
Affects Version/s alpha [ 11130 ]
Idan Cohen [Boxee] made changes - 05/May/10 11:31 AM
Assignee idan [ idan ] rafael [ rafael ]
Rafael Mizrahi [Boxee] made changes - 05/May/10 12:37 PM
Assignee rafael [ rafael ] vulkanr
[ vulkanr ]
Rafael Mizrahi [Boxee] made changes - 10/May/10 5:10 AM
Link This issue is duplicated by ARCHIVE-2292 [ ARCHIVE-2292 ]
Rafael Mizrahi [Boxee] made changes - 26/Jul/10 6:27 AM
Feature Parent values: Client(10102). Level 1 values: UI and Usability (10109).
Component/s UI and Usability [ 10586 ]
Rafael Mizrahi [Boxee] made changes - 17/Aug/10 8:46 AM
Fix Version/s Top [ 11303 ]
Fix Version/s backlog [ 11122 ]
Rafael Mizrahi [Boxee] made changes - 29/Aug/10 10:20 AM
Assignee vulkanr
[ vulkanr ]
Eli Schwartz [Boxee] made changes - 08/Sep/10 8:59 AM
Fix Version/s Fiona [ 11240 ]
Fix Version/s Top [ 11303 ]
Yuval Tal [Boxee] made changes - 12/Sep/10 10:41 AM
Assignee yuvalt [ yuvalt ]
Yuval Tal [Boxee] made changes - 12/Sep/10 10:41 AM
Assignee yuvalt [ yuvalt ] Zach Klein [ zachklein ]
Yuval Tal [Boxee] made changes - 13/Sep/10 5:41 AM
Fix Version/s Fiona Sprint 6 [ 11322 ]
Eli Schwartz [Boxee] made changes - 22/Sep/10 6:41 PM
Fix Version/s Fiona Sprint 8 [ 11327 ]
Fix Version/s Fiona Sprint 6 [ 11322 ]
Yuval Tal [Boxee] made changes - 10/Oct/10 3:59 AM
Fix Version/s Backlog [ 11122 ]
Fix Version/s Fiona [ 11240 ]
Fix Version/s Fiona Sprint 8 [ 11327 ]
Jimmy Shin added a comment - 17/Nov/10 1:25 PM
Reproducible on Boxee box on v1.0
Affects Korean as well.
Ken added a comment - 18/Nov/10 12:18 PM
Unicode subtitles are affected as well, such as Vietnamese subtitles on Boxee Box v1.0
Ken added a comment - 18/Nov/10 12:30 PM
In the windows 7 v0.9.23.15885 I was able to temporarily fix the subtitle issue by replace C:\Program Files\Boxee\media\Fonts\boxee.ttf with another font from C:\Windows\fonts\ such as "Arial" . You can either delete boxee.ttf and copy arial.ttf and remane to to boxee.ttf OR copy arial.ttf over without renaming and go to Settings -> Media -> Video and select the new font.
Mike Chang added a comment - 21/Dec/10 11:58 PM
I can not believe Boxee Tech is draging their feet on this issue, it is a simply fix but important for asian community, it is useless without proper font showing!

we can easily solved the problem(although we shouldn't have to) on Boxee-computer http://forums.boxee.tv/showthread.php?t=23293

But on Boxee Box which is not as easy to get into the os, we need the tech support to get on the ball and updated the correct font package on their next updated, the current font error make Boxee Box useless for Asian user in US and abroad!

Carlos Moreira added a comment - 24/Dec/10 1:46 AM
Yes, agreed. Please please please add this in. It will open up access to a lot of chinese videos.
Rafael Mizrahi [Boxee] made changes - 27/Dec/10 5:58 AM
Assignee Zach Klein [ zachklein ]
Gerald Marechal made changes - 28/Dec/10 7:20 AM
Attachment screenshot-1.jpg [ 13315 ]
Gerald Marechal added a comment - 28/Dec/10 7:26 AM
Like you can see on the screenshot1.jpg. I succeded to add the unicode font to boxee without using more space on the drive wit the help the symbolic link in windows 7.
1° keep a copy of your file font in boxee
2° backup theses files
3° delete them in the boxee directories
4° make the 6 symlinks

The code is here (just copy paste in a batch file created with notedpad)

REM ====== FROM HERE ======
mkdir "boxeefonts"
copy "C:\Program Files (x86)\Boxee\skin\boxee\Fonts\*.ttf" boxeefonts
copy "C:\Program Files (x86)\Boxee\media\Fonts\boxee.ttf" boxeefonts

del "C:\Program Files (x86)\Boxee\media\Fonts\boxee.ttf"
del "C:\Program Files (x86)\Boxee\skin\boxee\Fonts\*.ttf"

MKLINK "C:\Program Files (x86)\Boxee\skin\boxee\Fonts\LiberationMono-Regular.ttf" C:\Windows\Fonts\ARIALUNI.TTF
MKLINK "C:\Program Files (x86)\Boxee\skin\boxee\Fonts\LiberationSans-Regular.ttf" C:\Windows\Fonts\ARIALUNI.TTF
MKLINK "C:\Program Files (x86)\Boxee\skin\boxee\Fonts\LiberationSerif-Regular.ttf" C:\Windows\Fonts\ARIALUNI.TTF
MKLINK "C:\Program Files (x86)\Boxee\skin\boxee\Fonts\MuseoSans_500.ttf" C:\Windows\Fonts\ARIALUNI.TTF
MKLINK "C:\Program Files (x86)\Boxee\skin\boxee\Fonts\MuseoSans_700.ttf" C:\Windows\Fonts\ARIALUNI.TTF
MKLINK "C:\Program Files (x86)\Boxee\media\Fonts\boxee.ttf" C:\Windows\Fonts\ARIALUNI.TTF
REM ==== UNTIL HERE ===
Gerald Marechal made changes - 28/Dec/10 7:26 AM
Comment [ Thai font in Boxee with ARIALUNI ]
Jimmy Shin added a comment - 28/Dec/10 11:21 PM
Can we please get this issue fixed? I've been looking at the issues fixed in the Fiona SP1, SP2 & SP3 and this has more votes than most and it's such a SIMPLE fix. An issue that has a high impact in usability with a very isolated, trivial fix should be addressed ASAP in my opinion. Esp. when the issue is so noticeable in the UI.

Can this issue be retargeted?
xmas j added a comment - 02/Jan/11 5:25 PM
Please fix this issue since it's critical UI issue. Most of media players in market has no issue with fonts.
BoxeeBox will be useless for those who can't read the local files.
Rafael Mizrahi [Boxee] made changes - 05/Jan/11 9:52 AM
Link This issue is duplicated by BOXEE-7819 [ BOXEE-7819 ]
The Richmonds added a comment - 07/Jan/11 8:19 PM
Why is it taking so long to fix this?
Rafael Mizrahi [Boxee] made changes - 18/Jan/11 4:15 AM
Link This issue is duplicated by BOXEE-6964 [ BOXEE-6964 ]
Vince Wesselmann added a comment - 31/Jan/11 12:27 PM
Just showing my support for fixing this issue. It is hugely important to the wife-acceptance-factor that our Japanese-language media be supported and displayed on the box with something other than boxes. Please consider scheduling this issue for attention in an upcoming update. Thank you.
Hameed added a comment - 11/Feb/11 12:11 PM
++ please fix it
xmas j added a comment - 24/Feb/11 10:27 AM
I still can't read local files in other languages. Please please fix this!!!!
Thanks!
Yuval Tal [Boxee] made changes - 28/Feb/11 1:09 PM
Assignee yuvalt [ yuvalt ]
Yuval Tal [Boxee] made changes - 28/Feb/11 1:09 PM
Fix Version/s Fiona 1.1 Sprint 3 [ 11353 ]
Fix Version/s Backlog [ 11122 ]
Udice Mimi added a comment - 01/Mar/11 4:33 AM
updated on d-link boxee box latest firmware still get square box on Chinese characters. Please help to fix this issue.
Thank you very much
Marcus Tse added a comment - 03/Mar/11 9:41 AM
Please fix it. I got tons of folder and video are encoded at Chinese Characters. I don't wont to rename all to get move forward.
Eli Semory [Boxee] made changes - 07/Mar/11 7:46 AM
Fix Version/s Fiona 1.1 [ 11350 ]
Fix Version/s Fiona 1.1 Sprint 2 [ 11352 ]
Fix Version/s Fiona 1.1 Sprint 3 [ 11353 ]
Eli Semory [Boxee] added a comment - 07/Mar/11 7:46 AM
Fixed 17720
Eli Semory [Boxee] made changes - 07/Mar/11 7:46 AM
Status Reopened [ 4 ] Resolved [ 5 ]
Resolution Fixed [ 1 ]
Marcus Tse added a comment - 07/Mar/11 9:30 AM
how do it get it updated to your fixed?
Jeremy Milum added a comment - 07/Mar/11 9:53 AM
You will have to wait until a a patch is released that contains the fix.
Marcus Tse added a comment - 07/Mar/11 9:58 AM
which means the next release? or is there any beta version we can try at least get that fixed.
i have alot of folder and files are in chinese.
Ami Ben-David [Boxee] added a comment - 16/Mar/11 5:47 AM
verified 1.1.0.17863
Ami Ben-David [Boxee] made changes - 16/Mar/11 5:47 AM
Status Resolved [ 5 ] Closed [ 6 ]
Nishad Kaippally added a comment - 12/May/11 10:50 PM
Hi
Yesterday I Updated the firmware to 1.1.0.1.19053-9ac0630 on my Boxee Box.
I was happy to notice that indic-Unicode characters are now displayed, but the rendering is incorrect. I created a few folders in Hindi, Tamil and Malayalam as a test. Vowel signs do not appear in the correct positions. Subtitles also have the same issue. However the browser displays indic-unicode correctly. Websites that have specified a Unicode font in it's CSS via the @font tag does display correctly.

Rafael Mizrahi [Boxee] made changes - 12/Jul/11 10:03 AM
Severity Critical
Rafael Mizrahi [Boxee] made changes - 03/Aug/11 5:31 AM
Fix Version/s Fiona 1.1 Sprint 2 [ 11352 ]
Transition Time In Source Status Execution Times Last Executer Last Execution Date
Open Resolved
550d 17h 2m 1 Tom Sella [Boxee] 09/Feb/10 7:01 AM
Resolved Reopened
33d 22h 55m 1 Ami Ben-David [Boxee] 15/Mar/10 6:57 AM
Reopened Resolved
357d 1h 49m 1 Eli Semory [Boxee] 07/Mar/11 7:46 AM
Resolved Closed Closed
8d 21h 1 Ami Ben-David [Boxee] 16/Mar/11 5:47 AM

People

Vote (32)
Watch (17)

Dates

  • Created:
    07/Aug/08 2:58 PM
    Updated:
    03/Aug/11 5:31 AM
    Resolved:
    07/Mar/11 7:46 AM