Boxee

sometimes boxee hang on shutdown and does not exit

Details

  • Severity:
    Critical
  • Version:
    1.0.1.16319
  • Operating System:
    Boxee Box, Windows 7, Windows XP
  • Number of attachments:
    0

Description

many times boxee refuses to shut down and does not exit
sometimes it takes few minutes to shutdown.

Issue Links

Activity

Hide
alex romanov [Boxee] added a comment - 09/Dec/09 8:55 AM
Please provide specific logs for those cases
Show
alex romanov [Boxee] added a comment - 09/Dec/09 8:55 AM Please provide specific logs for those cases
Hide
Rafael Mizrahi [Boxee] added a comment - 14/Dec/09 4:08 AM - edited
reopen by mistake 0.9.20.9780
Show
Rafael Mizrahi [Boxee] added a comment - 14/Dec/09 4:08 AM - edited reopen by mistake 0.9.20.9780
Hide
Ami Ben-David [Boxee] added a comment - 14/Dec/09 10:58 AM
verified boxee-0.9.20.9816
Show
Ami Ben-David [Boxee] added a comment - 14/Dec/09 10:58 AM verified boxee-0.9.20.9816
Hide
Rafael Mizrahi [Boxee] added a comment - 28/Dec/09 9:53 AM
reproduces on 0.9.20.10063 on windows xp while the resolving is running and boxee experianced an internet outage
Show
Rafael Mizrahi [Boxee] added a comment - 28/Dec/09 9:53 AM reproduces on 0.9.20.10063 on windows xp while the resolving is running and boxee experianced an internet outage
Hide
Tim Howland added a comment - 29/Dec/09 2:38 PM
I'm having the same issue on 0.9.20.10063 with Mac OSX Snow Leopard.

Command Line Output:
START PLAYBACK
Debugger() was called!
Application: delete item loader...

Show
Tim Howland added a comment - 29/Dec/09 2:38 PM I'm having the same issue on 0.9.20.10063 with Mac OSX Snow Leopard. Command Line Output: START PLAYBACK Debugger() was called! Application: delete item loader...
Hide
Rich McGeheran added a comment - 19/Jan/10 5:10 PM
I am seeing same thing
On MacBook Pro,
OS 10.5.8,
boxee version 0.9.20.10357

occurred in previous versions.
Show
Rich McGeheran added a comment - 19/Jan/10 5:10 PM I am seeing same thing On MacBook Pro, OS 10.5.8, boxee version 0.9.20.10357 occurred in previous versions.
Hide
Rich McGeheran added a comment - 19/Jan/10 5:11 PM
this are the logs from my mac.
Show
Rich McGeheran added a comment - 19/Jan/10 5:11 PM this are the logs from my mac.
Hide
Tim Matheny added a comment - 24/Jan/10 8:50 AM
Same issue on Mac mini running 10.6.2 and boxee 0.9.20.10357, with this wrinkle: choosing "Exit Boxee" causes hang and freeze which cannot be exited unless boxee was taken out of fullscreen mode beforehand (boxee can then be exited with Force Quit from the Dock); "Suspend Machine" crashes the entire Mac OS X System.
Will attach logs from 1/24/10.
Show
Tim Matheny added a comment - 24/Jan/10 8:50 AM Same issue on Mac mini running 10.6.2 and boxee 0.9.20.10357, with this wrinkle: choosing "Exit Boxee" causes hang and freeze which cannot be exited unless boxee was taken out of fullscreen mode beforehand (boxee can then be exited with Force Quit from the Dock); "Suspend Machine" crashes the entire Mac OS X System. Will attach logs from 1/24/10.
Hide
Travis Riffle added a comment - 24/Jan/10 6:11 PM

This is how I have my system setup for HTPC:


HTPC - Boxee 0.9.20.10356, Ubuntu 9.10, MSI AMD 785 MB w/ ATI/AMD 4200 HD IGP, Athlon II X2 250, 4, 500GB HD, Wireless G PCI, MCE Remote

Videos and Music are being streamed via SMB/CIFS from my freenas server. I have created shares for both in boxee.

Pictures are locally on my Htpc.

I have added Family Guy, and Scubs to : "add to My Shows (Que new episodes)" .

When I go to "My TV Shows" it usually shows all of the TV shows that I have on my server. But sometimes (usually after watching a video from an app IE revision3, Youtube) "My TV Shows" will only display Family Guy, and Scrubs. I am assuming this because it is pulling those shows from the internet. So it appears that I have lost connection to my server. So I will go to Media>Network Shares and both of my shares are "NOT CONNECTED". The strange thing is that I am able to navigate to them through "Files". Now when this happens and I go to "EXIT BOXEE" is when it hangs...


Show
Travis Riffle added a comment - 24/Jan/10 6:11 PM This is how I have my system setup for HTPC: HTPC - Boxee 0.9.20.10356, Ubuntu 9.10, MSI AMD 785 MB w/ ATI/AMD 4200 HD IGP, Athlon II X2 250, 4, 500GB HD, Wireless G PCI, MCE Remote Videos and Music are being streamed via SMB/CIFS from my freenas server. I have created shares for both in boxee. Pictures are locally on my Htpc. I have added Family Guy, and Scubs to : "add to My Shows (Que new episodes)" . When I go to "My TV Shows" it usually shows all of the TV shows that I have on my server. But sometimes (usually after watching a video from an app IE revision3, Youtube) "My TV Shows" will only display Family Guy, and Scrubs. I am assuming this because it is pulling those shows from the internet. So it appears that I have lost connection to my server. So I will go to Media>Network Shares and both of my shares are "NOT CONNECTED". The strange thing is that I am able to navigate to them through "Files". Now when this happens and I go to "EXIT BOXEE" is when it hangs...
Hide
Rafael Mizrahi [Boxee] added a comment - 25/Jan/10 9:31 AM - edited
occured again on windows XP using 0.9.20.10408
Boxee idle, clicked exit. hang
log indicate that the media resolving is still running.
Show
Rafael Mizrahi [Boxee] added a comment - 25/Jan/10 9:31 AM - edited occured again on windows XP using 0.9.20.10408 Boxee idle, clicked exit. hang log indicate that the media resolving is still running.
Hide
Rafael Mizrahi [Boxee] added a comment - 09/Feb/10 9:58 AM
increased to critical. happens again on Mac and Windows.
Show
Rafael Mizrahi [Boxee] added a comment - 09/Feb/10 9:58 AM increased to critical. happens again on Mac and Windows.
Hide
Brett Bieber added a comment - 17/Feb/10 8:32 PM
Same issue here on OSX 10.6.2, w/ 0.9.20.10708.

When the network is down (I'm guessing because boxee is over-zealous with scanning my samba share?), boxee will not exit immediately.

After I force-quit boxee, I then have to "Turn AirPort Off" then back On to get my wireless connection back.
Show
Brett Bieber added a comment - 17/Feb/10 8:32 PM Same issue here on OSX 10.6.2, w/ 0.9.20.10708. When the network is down (I'm guessing because boxee is over-zealous with scanning my samba share?), boxee will not exit immediately. After I force-quit boxee, I then have to "Turn AirPort Off" then back On to get my wireless connection back.
Hide
Ivan Unger added a comment - 23/Feb/10 1:00 PM
Same here on 10708.
MacMini, 10.6.2.

Samba can't be the reason, because I don't have a network drive connected.
Show
Ivan Unger added a comment - 23/Feb/10 1:00 PM Same here on 10708. MacMini, 10.6.2. Samba can't be the reason, because I don't have a network drive connected.
Hide
Matt Hawke added a comment - 27/Feb/10 9:16 AM
I have this issue on a fresh Ubuntu 9.10 (32-bit) install...
Show
Matt Hawke added a comment - 27/Feb/10 9:16 AM I have this issue on a fresh Ubuntu 9.10 (32-bit) install...
Hide
Scott Newmann added a comment - 30/Mar/10 6:13 AM
Same issue on 10708
MacMini 10.6.3

I am using network drives, through hardline though, and I do not lose connection.
Show
Scott Newmann added a comment - 30/Mar/10 6:13 AM Same issue on 10708 MacMini 10.6.3 I am using network drives, through hardline though, and I do not lose connection.
Hide
Ivan Unger added a comment - 06/May/10 1:22 AM
Also not working with the current beta 0.9.21.11497. Boxee doesn't exit when left idle overnight.
Show
Ivan Unger added a comment - 06/May/10 1:22 AM Also not working with the current beta 0.9.21.11497. Boxee doesn't exit when left idle overnight.
Hide
JR added a comment - 10/May/10 3:32 AM
Had same issue.

windows 7 x64
Radeon 4770
Show
JR added a comment - 10/May/10 3:32 AM Had same issue. windows 7 x64 Radeon 4770
Hide
Sim Harbert added a comment - 06/Jul/10 9:49 PM
This always happens to me when I quit. Using Platform: GNU/Linux. Built on Jun 27 2010 (SVN:12563M) I am running it on an eee Box with ATI graphics card. I have attached the log file "noisygecko-boxee.log"
Show
Sim Harbert added a comment - 06/Jul/10 9:49 PM This always happens to me when I quit. Using Platform: GNU/Linux. Built on Jun 27 2010 (SVN:12563M) I am running it on an eee Box with ATI graphics card. I have attached the log file "noisygecko-boxee.log"
Hide
Travis Kessler added a comment - 23/Aug/10 10:26 AM
Windows XP SP3 MCE
P4 3.4GHz 3.0 GB RAM
Boxee almost never closes on it's own. even when left sitting.

And why doesn't boxee still not have an auto-update feature? At least a notification of a new version
Show
Travis Kessler added a comment - 23/Aug/10 10:26 AM Windows XP SP3 MCE P4 3.4GHz 3.0 GB RAM Boxee almost never closes on it's own. even when left sitting. And why doesn't boxee still not have an auto-update feature? At least a notification of a new version
Hide
Sim Harbert added a comment - 13/Sep/10 9:37 PM
This still happens to me. How do I easily report things like version number and all that? I have seen different versions in the program from what I installed.

I always run Boxee from the command line, but I don't see the version printed out when I run Boxee that way. Seems like a good way to give you guys that information. Actually, I find the whole bug reporting process very tedious. Every single one of the reports I read gets a "post your log", "post version", "post more information" response.

Sorry, but I am really would like to see Boxee get better, but I am not developing it, just reporting issues. People like me get tired of reporting issues if we get too many of our issues closed due to lack of information on our part.
Show
Sim Harbert added a comment - 13/Sep/10 9:37 PM This still happens to me. How do I easily report things like version number and all that? I have seen different versions in the program from what I installed. I always run Boxee from the command line, but I don't see the version printed out when I run Boxee that way. Seems like a good way to give you guys that information. Actually, I find the whole bug reporting process very tedious. Every single one of the reports I read gets a "post your log", "post version", "post more information" response. Sorry, but I am really would like to see Boxee get better, but I am not developing it, just reporting issues. People like me get tired of reporting issues if we get too many of our issues closed due to lack of information on our part.
Hide
Iain Donaldson added a comment - 16/Sep/10 8:04 AM
always happens to me on OSX Snow Leopard (10.6.4) even with build installed this week. My boxee log is filled with entries that say "ERROR: Seek - Error( Bad file descriptor )". All my music is on an smb mounted share (samba at the other end). It makes boxee unusable on a system where you want to be able to run other apps. If I quit boxee soon after it loads it sometimes quits ok, otherwise I have to force quit it.
Show
Iain Donaldson added a comment - 16/Sep/10 8:04 AM always happens to me on OSX Snow Leopard (10.6.4) even with build installed this week. My boxee log is filled with entries that say "ERROR: Seek - Error( Bad file descriptor )". All my music is on an smb mounted share (samba at the other end). It makes boxee unusable on a system where you want to be able to run other apps. If I quit boxee soon after it loads it sometimes quits ok, otherwise I have to force quit it.
Hide
haveringcottage added a comment - 02/Nov/10 12:58 PM
This happens to me to, running boxee 0.9.22 on windows 7.
Show
haveringcottage added a comment - 02/Nov/10 12:58 PM This happens to me to, running boxee 0.9.22 on windows 7.
Hide
Hans Zetterberg added a comment - 08/Nov/10 8:35 AM
I have the same issue:

Windows 7 x64
INTEL DG45ID G45 S-775 M-ATX
Intel® Graphics Media Accelerator X4500HD onboard graphics
Show
Hans Zetterberg added a comment - 08/Nov/10 8:35 AM I have the same issue: Windows 7 x64 INTEL DG45ID G45 S-775 M-ATX Intel® Graphics Media Accelerator X4500HD onboard graphics
Hide
Robert added a comment - 16/Nov/10 1:21 PM
This crash seems to be related to a similar bug I had reported with v0.9.22.13692 running on the Apple TV. It was resolved in my case by removing the music library from the sources list. This also works to temporarily fix this crash on v1.0.1 on the Boxee Box. If I can provide any further logs or do any testing to help troubleshoot this please let me know.
Show
Robert added a comment - 16/Nov/10 1:21 PM This crash seems to be related to a similar bug I had reported with v0.9.22.13692 running on the Apple TV. It was resolved in my case by removing the music library from the sources list. This also works to temporarily fix this crash on v1.0.1 on the Boxee Box. If I can provide any further logs or do any testing to help troubleshoot this please let me know.
Hide
haveringcottage added a comment - 19/Nov/10 1:52 PM
this happened to me just now.

i have attached my boxee log for perusal
Show
haveringcottage added a comment - 19/Nov/10 1:52 PM this happened to me just now. i have attached my boxee log for perusal
Hide
haveringcottage added a comment - 19/Nov/10 1:56 PM - edited
i run windows 7 x86, boxee crashes once every 20 or so exits....
Show
haveringcottage added a comment - 19/Nov/10 1:56 PM - edited i run windows 7 x86, boxee crashes once every 20 or so exits....
Hide
gregory added a comment - 12/Dec/10 7:15 AM
Software power off failing seems common after system configuration or medial source addition on boxee box, I did about 20 in a row and there were no hangs if just media playing.
Show
gregory added a comment - 12/Dec/10 7:15 AM Software power off failing seems common after system configuration or medial source addition on boxee box, I did about 20 in a row and there were no hangs if just media playing.
Hide
Dirk Watkins added a comment - 21/Dec/10 8:57 AM
Also happens to me on the Boxee Box with the latest firmware update. I tell it to shut down but it restarts instead. Upon 2nd attempt it usually shuts down. The hardware button seems to work all the time so I often go and just click that.
Show
Dirk Watkins added a comment - 21/Dec/10 8:57 AM Also happens to me on the Boxee Box with the latest firmware update. I tell it to shut down but it restarts instead. Upon 2nd attempt it usually shuts down. The hardware button seems to work all the time so I often go and just click that.
Hide
Branden Silva added a comment - 21/Dec/10 9:11 AM - edited
I can confirm what Dirk Watkins mentioned above with the latest firmware as of 12/21/10. It takes me two shutdowns for it to finally close. This is on a Boxee Box.
Show
Branden Silva added a comment - 21/Dec/10 9:11 AM - edited I can confirm what Dirk Watkins mentioned above with the latest firmware as of 12/21/10. It takes me two shutdowns for it to finally close. This is on a Boxee Box.
Hide
Ben Blackford added a comment - 05/Jan/11 12:54 PM
I have the same issue with my Boxee Box, though I have noticed it's not entirely consistent. If I used it a significant amount I'm bound to run into it but other times when I haven't played much it would shut down fine. Haven't yet sat down to try and figure out what sort of things will make it restart instead of shut down.
Show
Ben Blackford added a comment - 05/Jan/11 12:54 PM I have the same issue with my Boxee Box, though I have noticed it's not entirely consistent. If I used it a significant amount I'm bound to run into it but other times when I haven't played much it would shut down fine. Haven't yet sat down to try and figure out what sort of things will make it restart instead of shut down.
Hide
Dima added a comment - 10/Jan/11 11:04 AM
The same here I have to shutdown BoxeeBox manually. It's on random bases
Show
Dima added a comment - 10/Jan/11 11:04 AM The same here I have to shutdown BoxeeBox manually. It's on random bases
Hide
Martin G. Lapointe added a comment - 07/Feb/11 11:09 AM
Boxee Box latest firmware at this date. Boxee Box hangs on shutdown request. Usually happens more often after watching streams. If its a simple boot up, show homescreen and shutdown... it works.
Show
Martin G. Lapointe added a comment - 07/Feb/11 11:09 AM Boxee Box latest firmware at this date. Boxee Box hangs on shutdown request. Usually happens more often after watching streams. If its a simple boot up, show homescreen and shutdown... it works.
Hide
Tim Wood added a comment - 07/Feb/11 1:37 PM
I agree with Martin. Happens same way for me.
Show
Tim Wood added a comment - 07/Feb/11 1:37 PM I agree with Martin. Happens same way for me.
Hide
Rafael Mizrahi [Boxee] added a comment - 27/Apr/11 7:23 AM - edited
This appears to be fixed in version 1.1.0.18768
If this same issue happens again, please open a new issue.
Please check the Release Notes to verify that this issue has been implemented into the version you are using.
Show
Rafael Mizrahi [Boxee] added a comment - 27/Apr/11 7:23 AM - edited This appears to be fixed in version 1.1.0.18768 If this same issue happens again, please open a new issue. Please check the Release Notes to verify that this issue has been implemented into the version you are using.

People

Vote (85)
Watch (29)

Dates

  • Created:
    30/Nov/09 3:22 AM
    Updated:
    Today 5:31 AM
    Resolved:
    27/Apr/11 7:23 AM