Boxee

My Apps screen and Repositories screen hang when third party repository is inaccessible.

Details

  • Labels:
  • Boxee Build Number:
    0.9.21.xxxx
  • Operating System:
    Ubuntu Lucid, Windows XP
  • Description:
    When a third party repository is inaccessible, the client hangs at the My Apps screen and in Repositories screen.
    there is no indication to the user that a non-Boxee resource is unavailable.

    Log repeats the following:

    09:19:45 T:139936616093456 M:2455977984 DEBUG: Boxee: 11/08/10 13:19:45#DEBUG#bxappboxmanager.cpp:228(GetAppBox3rdPartyRepositoryApplications)#BXAppBoxManager::GetAppBox3rdPartyRepositoryApplications - AppBox3rdPartyApplicationsMap is not loaded yet. Going to try again in [1000ms]. [repositoryId=com.fuzzthed][IsRepositoriesMapLoaded=0][numOfIterToWaitForRepoMapLoad=0] (repos)
    Show
    When a third party repository is inaccessible, the client hangs at the My Apps screen and in Repositories screen. there is no indication to the user that a non-Boxee resource is unavailable. Log repeats the following: 09:19:45 T:139936616093456 M:2455977984 DEBUG: Boxee: 11/08/10 13:19:45#DEBUG#bxappboxmanager.cpp:228(GetAppBox3rdPartyRepositoryApplications)#BXAppBoxManager::GetAppBox3rdPartyRepositoryApplications - AppBox3rdPartyApplicationsMap is not loaded yet. Going to try again in [1000ms]. [repositoryId=com.fuzzthed][IsRepositoriesMapLoaded=0][numOfIterToWaitForRepoMapLoad=0] (repos)

Activity

Rob Spectre added a comment - 11/Aug/10 9:54 AM
The repo that caused this issue for me was Fuzz the Destroyer's (dir.fuzzthed.com) which appears to be available now.

Steps to reproduce:

1) Add a valid repository on a development host.
2) Turn off apache on development host (or make repo somehow otherwise inaccessible).
3) Restart Boxee.
4) Navigate to My Apps.

A little involved and definitely corner case - timeout in log explicitly states 1000ms wait until next poll.
Ami Ben-David made changes - 11/Aug/10 9:57 AM
Field Original Value New Value
Assignee alex [ alex ]
Ami Ben-David made changes - 11/Aug/10 9:57 AM
Fix Version/s fiona [ 11240 ]
rafael made changes - 11/Aug/10 11:33 AM
Component/s Windows > Applications [ 10604 ]
Component/s Applications [ 10585 ]
rafael made changes - 16/Sep/10 6:30 AM
Link This issue is duplicated by BOXEE-4014 [ BOXEE-4014 ]
rafael added a comment - 16/Sep/10 6:30 AM - edited
reproduces using 0.9.22.13692
when a third party repository is in accessible, the whole MY APPS is empty with loading animation running endlessly.
It takes more than 5 minutes for the connection to timeout. and also it hangs boxee and you cannot exit boxee properly.
rafael made changes - 16/Sep/10 6:31 AM
Security #jira-developers [ 10020 ]
rafael made changes - 16/Sep/10 6:33 AM
Description When a third party repository is inaccessible, the client hangs at the My Apps screen until timing out 1000 milliseconds later. This time out should likely be shorter, as there is no indication to the user that a non-Boxee resource is unavailable.

Log repeats the following:

09:19:45 T:139936616093456 M:2455977984 DEBUG: Boxee: 11/08/10 13:19:45#DEBUG#bxappboxmanager.cpp:228(GetAppBox3rdPartyRepositoryApplications)#BXAppBoxManager::GetAppBox3rdPartyRepositoryApplications - AppBox3rdPartyApplicationsMap is not loaded yet. Going to try again in [1000ms]. [repositoryId=com.fuzzthed][IsRepositoriesMapLoaded=0][numOfIterToWaitForRepoMapLoad=0] (repos)
When a third party repository is inaccessible, the client hangs at the My Apps screen.
there is no indication to the user that a non-Boxee resource is unavailable.

Log repeats the following:

09:19:45 T:139936616093456 M:2455977984 DEBUG: Boxee: 11/08/10 13:19:45#DEBUG#bxappboxmanager.cpp:228(GetAppBox3rdPartyRepositoryApplications)#BXAppBoxManager::GetAppBox3rdPartyRepositoryApplications - AppBox3rdPartyApplicationsMap is not loaded yet. Going to try again in [1000ms]. [repositoryId=com.fuzzthed][IsRepositoriesMapLoaded=0][numOfIterToWaitForRepoMapLoad=0] (repos)
rafael made changes - 16/Sep/10 6:33 AM
Boxee Build Number [0.9.21.125xx] [0.9.22.13692, 0.9.21.125xx]
rafael made changes - 16/Sep/10 6:33 AM
Operating System [Ubuntu Lucid] [Ubuntu Lucid, Windows XP]
rafael made changes - 16/Sep/10 6:49 AM
Summary My Apps screen hangs when third party repo is inaccessible. My Apps screen and Repositories screen hang when third party repository is inaccessible.
Priority Major [ 3 ] Critical [ 2 ]
Description When a third party repository is inaccessible, the client hangs at the My Apps screen.
there is no indication to the user that a non-Boxee resource is unavailable.

Log repeats the following:

09:19:45 T:139936616093456 M:2455977984 DEBUG: Boxee: 11/08/10 13:19:45#DEBUG#bxappboxmanager.cpp:228(GetAppBox3rdPartyRepositoryApplications)#BXAppBoxManager::GetAppBox3rdPartyRepositoryApplications - AppBox3rdPartyApplicationsMap is not loaded yet. Going to try again in [1000ms]. [repositoryId=com.fuzzthed][IsRepositoriesMapLoaded=0][numOfIterToWaitForRepoMapLoad=0] (repos)
When a third party repository is inaccessible, the client hangs at the My Apps screen and in Repositories screen.
there is no indication to the user that a non-Boxee resource is unavailable.

Log repeats the following:

09:19:45 T:139936616093456 M:2455977984 DEBUG: Boxee: 11/08/10 13:19:45#DEBUG#bxappboxmanager.cpp:228(GetAppBox3rdPartyRepositoryApplications)#BXAppBoxManager::GetAppBox3rdPartyRepositoryApplications - AppBox3rdPartyApplicationsMap is not loaded yet. Going to try again in [1000ms]. [repositoryId=com.fuzzthed][IsRepositoriesMapLoaded=0][numOfIterToWaitForRepoMapLoad=0] (repos)
rafael added a comment - 29/Sep/10 5:23 AM
cannot test this using 0.9.30.14503 because the custom repositories does not work at all.
yuvalt made changes - 12/Oct/10 7:51 AM
Fix Version/s Fiona Backlog [ 11329 ]
yuvalt made changes - 12/Oct/10 9:59 AM
Fix Version/s Fiona [ 11240 ]
rafael made changes - 18/Oct/10 12:38 PM
Boxee Build Number [0.9.22.13692, 0.9.21.125xx] [0.9.21.xxxx]
alex made changes - 28/Oct/10 5:09 AM
Assignee alex [ alex ] haim [ haim ]
haim added a comment - 28/Oct/10 8:34 AM
tried accessing unavailable repository, got the empty state screen.

My Apps screen doesn't include third party apps.
haim made changes - 28/Oct/10 8:34 AM
Status Open [ 1 ] Resolved [ 5 ]
Resolution Cannot Reproduce [ 5 ]
Ami Ben-David made changes - 28/Oct/10 11:25 AM
Status Resolved [ 5 ] Closed [ 6 ]
Ami Ben-David added a comment - 28/Oct/10 11:26 AM - edited
closed
manipulating the DNS in the host file did the trick to reproduce this issue.
rafael made changes - 22/Nov/10 8:05 AM
Link This issue is duplicated by BOXEE-4014 [ BOXEE-4014 ]

People

Dates

  • Created:
    11/Aug/10 9:29 AM
    Updated:
    22/Nov/10 8:05 AM
    Resolved:
    28/Oct/10 8:34 AM