Boxee

some movies do not play audio (AC3)

Details

  • Severity:
    Critical
  • Version:
    1.0.1.16319
  • Operating System:
    Boxee Box
  • Number of attachments:
    0

Description

some movies (both mkv and avi) do not play audio. they all seem to have it in AC3 format.

examples:
Boardwalk.Empire.S01E01.720p.HDTV.x264-IMMERSE.mkv
Cairo.Time.2009.Limited.720p.Bluray.X264-DIMENSION.mkv
La Vita è Bella - Life is Beautiful (BDrip 1080p ITA-ENG-RUS - AC3) x264 bluray (1997).mkv
Machete.2010.1080P.X264.MKV.AC3.NLSubs.NLUPPER.mkv

Issue Links

Activity

Eli Semory [Boxee] added a comment -
Please provide samples. Also, what's your setup? (TV AVR etc)
B K added a comment - - edited
I'm not sure how to provide samples as the video files are very big. Do you have an FTP I can upload to? If you google the titles in my original report you will easily find where to get them on the internet. Please advice if this is sufficient.

with regards to my set up:

BoxeeBox connected via HDMI to Sharp Aquos 52D62U (video only).
BoxeeBox connected to Kenwood VR-507 via digital optical (audio).
Files are sitting on WD USB hard drive directly connected to BB.
William Hardy added a comment -
I have exactly the same problem with the Kenwood VR-407 via optical out
from boxeebox with any video that has ac3 5.1 audio.
If I turn off the Dolby Digital check box in SPDIF settings then I get stereo.
The surround sound works with movies with DTS audio though.
B K added a comment -
uploaded sample file BOXEE-7414.BK.sample-001.mkv to the dropbox (ftp.boxee.tv)
Rafael Mizrahi [Boxee] added a comment -
file downloaded and copied to
\\dlink-nas-323\Volume_2\Media Issues Folder\BOXEE-7414.BK.sample-001.mkv
William Hardy added a comment -
I know that my Kenwood VR-407 can decode Dolby Digital ac3 5.1 output because I have downladed
the 2 ac3 files from http://www.diatonis.com/downloads_dts_ac3.html:

   http://www.diatonis.com/downloads/diatonis_ac3_48k_currents.zip
   http://www.diatonis.com/downloads/diatonis_ac3_48k_soal.zip

and the test mkv from http://jira.boxee.tv/browse/BOXEE-6936:

   http://jira.boxee.tv/secure/attachment/12980/test_mkv.zip

and they played properly through my computer SPDIF out. I tested coax and optical separately and both worked out on VLC v1.1.5.
The Dolby Digital light clicked on on my receiver as soon as the songs and video started playing.
If I try to play the test_mkv on boxeebox through SPDIF with the Dolby Digital capable receiver turned on (in SPDIF settings) the receiver doesn't play anything
and the Dolby Digital light never clicks on; however If I turn the Dolby Digital capable receiver check box off (in SPDIF settings) then the receiver plays a stereo downmix of the 5.1 audio
and the Dolby Digital light still doesn't click on.

Is there any receiver that has been tested to work with AC3 5.1 over SPDIF (with Dolby Digital capable receiver check box on) on the boxee box or is it a Kenwood specific problem?
William Hardy added a comment -
Once again DTS works fine through SPDIF.
Just to reiterate.
B K added a comment -
this seems to be also discussed here:
http://forums.boxee.tv/showthread.php?t=21990
Rutger Middendorp added a comment -
Same here with a Sony KDL-32W40xx/42xx TV and a Sony STR-DG820Amp. Just told my Boxee Box I wanted digital in in preferences, but deselected all boxes (DTS, etc.) Now it does work.... Please fix, now I don't have 5.1 sound.
Eli Semory [Boxee] added a comment -
This issue is specific to some AVR models
Ami Ben-David [Boxee] added a comment -
closed as duplicate of BOXEE-7070

People

Vote (2)
Watch (3)

Dates

  • Created:
    Updated:
    Resolved: