Boxee

Boxee Box remote stopped working

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: P1 P1
  • Resolution: Incomplete
  • Fix Version/s: Fiona 1.1.0
  • Component/s: Hardware
  • Labels:
    None
  • Severity:
    Critical
  • Operating System:
    Boxee Box
  • Number of attachments:
    0

Description

After turning on my Boxee Box this evening, the remote suddenly doesn't work anymore. Putting in fresh batteries doesn't working. Re-syncing doesn't work.
A factory reset doesn't work.

The remote was just laying on the tabletop and worked this afternoon.

It might be a hardware defect, but there's more people with the same problem in the forums... some after they applied the update.

This is essential and it BREAKS the box.

also see this thread: http://forums.boxee.tv/showthread.php?t=23967

Issue Links

Activity

Rafael Mizrahi [Boxee] made changes -
Field Original Value New Value
Assignee Eli Schwartz [ esch ]
Rafael Mizrahi [Boxee] made changes -
Fix Version/s Fiona Unscheduled [ 11340 ]
Priority Critical [ 2 ] Blocker [ 1 ]
Description After turning on my Boxee Box this evening, the remote suddenly doesn't work anymore. Putting in fresh batteries doesn't working. Re-syncing doesn't work. A factory reset doesn't work.

The remote was just laying on the tabletop and worked this afternoon.

It might be a hardware defect, but there's more people with the same problem in the forums... some after they applied the update.

This is essential and it BREAKS the box.

also see this thread: http://forums.boxee.tv/showthread.php?t=23967
After turning on my Boxee Box this evening, the remote suddenly doesn't work anymore. Putting in fresh batteries doesn't working. Re-syncing doesn't work.
A factory reset doesn't work.

The remote was just laying on the tabletop and worked this afternoon.

It might be a hardware defect, but there's more people with the same problem in the forums... some after they applied the update.

This is essential and it BREAKS the box.

also see this thread: http://forums.boxee.tv/showthread.php?t=23967
Rafael Mizrahi [Boxee] added a comment -
Please attach a Debug log to this issue.
Settings > System > Debug > Debug Level = Debug
ReStart Boxee, and after reproducing the problem, close Boxee and attach your log file to this issue.
DEBUG log slows down the performance. so afterward, switch the log level back to NONE
Boxee Box log may be found at http://boxeebox:8080/ click on the "Get latest " link.

you can use a USB keyboard to perform this task.
Eli Schwartz [Boxee] added a comment -
I think the answer here is to RMA, I’m checking whether according to D-Link policy you need to RMA the whole package (box included) or can just RMA the remote
Salomon Meij added a comment -
Here's the debug log :)
Salomon Meij made changes -
Attachment boxee.1293653770.2697.tar.bz2 [ 13337 ]
Salomon Meij added a comment -
This morning when I turned on my Boxee Box, the remote works again. I haven't done anything to the Boxee Box or the remote, it's just been sitting on the table top.

What are possible explanations? Weird bug in the Boxee software that happens sometimes but not all? Weird hardware defect that sometimes props up but not at all times?
Rafael Mizrahi [Boxee] added a comment -
Salomonת
looking at your log boxee.1293653770.2697.tar.bz2 (195 kB)
I see that you are using some Web based remote, such as the iPhone remote.
log lines :
   HttpApi Start command: SendKey

also see that the remote IR receiver was initialized properly
dmesg file:
  lirc_mceusb2: Philips eHome USB IR Transceiver and Microsoft MCE 2005 Remote Control driver for LIRC $Revision: 1.81 $
root-boxee.log
  21:08:14.0102 T:3073316640 M:606027776 INFO: LIRC Initialize: sucessfully started on: /dev/lircd

Did you click on the Boxee remote during this session?
Salomon Meij added a comment -
I used the iPhone remote to turn on debug and then might have navigated around some. I did try to sync the remote to the Boxee Box and move around, to no avail. Since the remote is working again now I'm not sure what else I can do. However, in two separate forum threads people have reported the remote working on an off and on basis - works sometimes, but not others. If the remote stops working again I'll make another log.
Rafael Mizrahi [Boxee] added a comment -
thanks for the information Salomon.
some of the information in the forums are not for sure a remote failure.
I've notice reports that a reboot solved the problem. which is clearly not a remote issue. users probably think that a hang or non responsiveness are a malfunction remote.
I will continue to follow and investigate this issue.
please report again if problem occurs again.
Rui Pinheiro added a comment -
i think i have the same issue here. my remote stops working and after some time starts working again (i don't see a pattern, but sometimes is 15 minutes) . i have a log of it, how can i upload it?
Rui Pinheiro added a comment -
here's the attachment
Rui Pinheiro made changes -
Attachment boxee.1293659015.1957.tar.bz2 [ 13339 ]
Rafael Mizrahi [Boxee] added a comment -
thanks Rui, your log archive does not contain a boxee log file. it only contain general information and boot log.
I guess that your log level is set to NONE. please change it to DEBUG or at least INFO (see above comment)
did you try attaching a USB keyboard or a Web API remote such as the Boxee iPhone remote to make sure this is a Boxee remote failure?
Rui Pinheiro added a comment -
thanks for your reply.
i'm not sure it is a remote failure. all i know is i loose control of my boxee box for periods (each time more often). The boxee box doesn't respond to the remote clicks, and after while it starts working again. for example, right now my boxee is powered off, and i can't power it on through the remote...
I haven't tried attaching an usb keyboard, does it work? what conclusions do i get from it? i don't have an iPhone.
The log i did as you instructed. the thing is, there is no error. it simply stops...
any thoughts on this?

thank you :)
Rui Pinheiro added a comment -
so, i did another log.
the boxee in debug mode was restarted, and it didnt respond to the remote.
i went to the support tool and clicked get the latest
Rui Pinheiro made changes -
Attachment boxee.1293723070.2388.tar.bz2 [ 13340 ]
Mark Weisenberger added a comment -
Same problem here. Was working just fine last night. This morning, no joy. iPhone remote works. The minimal pairing instructions are a joke and didn't solve the issue.
Rafael Mizrahi [Boxee] added a comment -
Rui, to eliminate if this is an application temporary hang or a remote failure, attach a USB keyboard.
if boxee reacts to the keyboard clicks and does not react to a paired remote, than its seems a remote failure.
A quicker approach to test the remote is by starting the boxee "recovery console" and click the remote to see if it works.
Michael Hove added a comment -
I have same issue - remote working after update here today, after unpacking the item and updated it with newest release of SW. Cant "re-pair" or restore to get it working. USB Keyboard is working. Please, fix it.
Rafael Mizrahi [Boxee] added a comment -
few notes::
* To pair the Boxee Remote, you need to press the center button for 10 seconds, and not 5 as mentioned by some D-Link documentation.
* Upgrading Boxee box software does not and should not unpair your boxee remote.
Michael Hove added a comment -
rafael - yes, I did this, but it does not work. I see others have the same feeling. I would like my D-link Boxee to be anything else then a "brick", so please accept this as a HUGE problem in your product.
Alexander Kieselbach added a comment -
Hello from germany.
Same problem here. Can turn on the box with the remote. After some navigation thru the menues, the remote starts to freeze some times. No answer after click. Then some seconds later it starts to freak out. The cursor runs 4 or 5 steps up or down, hits the enter button automatically and other things. Then some minutes later everything seems to be okay. After a while it starts the game again. Its not funny. It feels like the cpu is extreme under stress or something like that....
Todd Schachinger added a comment -
Same issue here although mine affects the ability to turn it on as well. I have to press the switch to turn it on then the remote works fine for a few minutes then stops responding again. restarting the box or taking the battery in/out seems to work for a while at least
Todd Schachinger added a comment -
Sorry, thought I should add that I turned off my router to rule out RF interference. This just started today after owning it for 2 weeks.
Rui Pinheiro added a comment -
i haven't yet tried rafael's suggestions, but i configured the folder scanning to ONCE instead of DAILY a few days ago. Since then i had only a small temporary hang...
Alexander Kieselbach added a comment - - edited
Hello again from germany. Now something to laugh :-) . My neighbor told me just some minutes ago that his new gadget arrived yesterday. But he is not lucky, because the remote is going crazy *lol . Yes he owns a Boxee Box too :-) . Now everything is clear. The remote has a very a large range. We paired or boxes now as described and both are working fine. No problems any more. If you have problems with freaking out remotes then check your neighborhood ;-)
Rob Wheeler added a comment -
I've had the box since release day. Use it every day, updated to latest firmware the day it was released. Today I turned on the box and the remote will not work. Pairing does not work. Factory reset/etc. is not an option since the remote does not work.

I tried a new battery, it does not work. A test of old and new battery show them both as fine (via multimeter).

This seems like a fairly prevalent issue. Have developers already received a log that might expose the issue or is this issue still awaiting more details?



Cedric Tomas added a comment -
I have the same issue but after a restart the remote is working again, very annoying though
boulderado added a comment -
I've owned by box for about 20 days, the remote just stopped working, its completely dead. Tried repairing, battery etc, it's completely unresponsive. Note the box still works using the iphone app. This is a huge issue, I'll be returning the box within the week if a solution is not found.
Gil Hamlin added a comment -
I had this issue - the boxee remote would stop responding intermittently, and then start again.

Whenever this happened, I orientated the remote with the keyboard facing towards me in landscape (as if I was going to type) and then held down the bottom button on the reverse side underneath the cursor pad. This *shouldn't* work but it always seemed to get the boxee remote working for me again within around 10 seconds - try it!

In terms of the issue - I'd be interesting to see how many people are using SMB shares with this problem - I had a flakey opensolaris SMB share that periodically hung / did bad things.... Boxee couldn't scan the SMB share very well and I think the issues I had with the remote were related to that. Since I have upgrade the Solaris box (both software, RAM) and recreated the SMB share, I now have about 3 x the original speeds in transfer, and the Boxee Box hasn't stopped responding once. Does this help at all?
Matthew Chartier added a comment -
I have had this problem happen to me a few times, when it does I disconnect all cables from the Boxee Box and then plug them back in and the remote works again, not sure if it is coincidence or not but has work twice in the last month and a half.
Eli Schwartz [Boxee] added a comment -
all, from reading the above comments and others, I would like to focus the issues to better the experience for all.
we have here 3 main issues (assuming initial checks, like battery inserted correctly, etc. have been done):
1. terminal condition - the remote does not respond at all while other control devices (phone, USB Keyboard) work - in this condition user should reinstall the latest update via USB, if condition persists the Remote is RMA candidate
currently DLink request to RMA the entire package, I’m checking with D-link if there's an alternative to RMA the remote only
2. temporarily failure - in theory could be SW bug related to remote but usually is related to other activities that create hang in the client or sluggish in the response that can feel like the remote is not responding, in such case please check that there are no massive efforts going on in the background, if you are facing such an event please checked if any of the activities can be redefined (reduce amount of scanning, redefine the SMB share, etc.), also some of the issues are solved via restart.
3 erratic behavior - one click created multiple steps, button reacted not according to description etc.)this is usually caused by not pairing the remote or having an unpaired remote in proximity - make sure that you pair the remote by holding the remote very near (les than an inch) from the box and pressing the OK (central button) for 10 sec or more, if after this you still detect erratic behavior please try to pair again or check if there are other devices with unpaired remotes nearby (since it is an RF remote the neighbors are not such a distinct possibility)

I’m closing the current issue as it is not focused to a fixable issue, for those still facing difficulties in the remotes please try to categorize the behavior according to above, and if relevant open a new issue in JIRA with the details and logs
Eli Schwartz [Boxee] made changes -
Status Open [ 1 ] Resolved [ 5 ]
Resolution Incomplete [ 4 ]
Rafael Mizrahi [Boxee] made changes -
Status Resolved [ 5 ] Closed [ 6 ]
Rafael Mizrahi [Boxee] made changes -
Link This issue relates BOXEE-8352 [ BOXEE-8352 ]
Rafael Mizrahi [Boxee] made changes -
Attachment boxee.1293653770.2697.tar.bz2 [ 13337 ]
Rafael Mizrahi [Boxee] made changes -
Attachment boxee.1293659015.1957.tar.bz2 [ 13339 ]
Rafael Mizrahi [Boxee] made changes -
Attachment boxee.1293723070.2388.tar.bz2 [ 13340 ]
BBChopper added a comment -
Two solutions for two separate Boxee Box remote issues in this thread: http://forums.boxee.tv/showthread.php?t=24042
Rafael Mizrahi [Boxee] made changes -
Fix Version/s Fiona 1.1 [ 11350 ]
Fix Version/s Fiona 1.1 Sprint 1 [ 11351 ]
Fix Version/s Fiona Unscheduled [ 11340 ]
Will made changes -
Attachment boxee.1301533244.2269.tar.bz2 [ 13727 ]
Will added a comment -
Mine is going crazy. See the forum thread above.

My debug logged is attached.
Rafael Mizrahi [Boxee] made changes -
Attachment boxee.1301533244.2269.tar.bz2 [ 13727 ]
Rafael Mizrahi [Boxee] made changes -
Severity Critical
tronbrain added a comment -
This issue should NOT be closed as not fixable until it is determined to be a hardware issue. It might be a software issue. Until it's known, it should be left open.

D-Link should send one of the RMA returned remotes to Boxee so Boxee can do some on-site debugging.
Rafael Mizrahi [Boxee] made changes -
Fix Version/s Fiona 1.1 Sprint 1 [ 11351 ]
Greg Baker added a comment -
I have encountered this issue and here is my description, which hopefully will remove some ambiguities.

I was navigating around netflix when suddenly the box appeared to lock up.
Hitting the power button on the boxee didn't help, I had to hold it down until it shut off.

The next morning I noticed that I couldn't turn the boxee on with the remote. I turned it on manually and once everything loaded up I couldn't use the remote at all.
I decided to try a factory reset but the recovery console wouldn't respond to the remote either.
I tried repairing the remote by holding the center button for 30 secs, this didn't work.
I downloaded a boxee remote app for android and gave it a shot and that worked fine. I figured my remote battery had died so I bought a new one and replaced it. Still no go.
I kept trying the remote periodically over the course of 3 days but it never worked.
I finally packed up the boxee box to return it to the store where I bought it...but they wouldn't take it back.
I brought it home and left it on the table, in the box, while I went on vacation.
When I returned from vacation I tried the box once more and the remote worked again.

Now that I think back, perhaps pulling the plugs from the boxee fixed the issue. Maybe it just needed a week and a half to fix itself (??).
If this happens again I'll try pulling the plug for a bit. Seems to me that may be what fixed my problem.
Transition Time In Source Status Execution Times Last Executer Last Execution Date
Open Resolved
17d 19h 24m 1 Eli Schwartz [Boxee] 16/Jan/11 7:51 AM
Resolved Closed Closed
20h 42m 1 Rafael Mizrahi [Boxee] 17/Jan/11 4:33 AM

People

Vote (12)
Watch (17)

Dates

  • Created:
    Updated:
    Resolved: