Boxee

cannot add new repository because boxee caches repo-destination online

Details

  • Severity:
    Major
  • Version:
    0.9.22
  • Number of attachments:
    0

Description

i had setup a custom repository on my local server ans used dyndns.
after it completely works, i uploaded it to a live-server and CORRECT ALL links in the repo-files.
now, when i add the new repo-link it always fails.
the log says it get the repository.xml from the right new server, but also some statements from the old dyndns-target exists.
i tryed to delete the usercache, reinstall boxee, and test it with an different boxee-user.
is it possible that boxee stores/caches repo-infos online?? how to clean/fit that?

here some files:
http://tv.sanduhrgucker.de/repository/repository.xml
----
<?xml version="1.0" encoding="utf-8" ?>
<repository>
<id>com.sanduhrgucker</id>
<url>http://tv.sanduhrgucker.de/repository</url>
<name>SandUhrGucker.tv - Deine deutsche Stream-Programmzeitschrift</name>
<thumb>http://tv.sanduhrgucker.de/repository/images/logo.jpg</thumb>
<description>SandUhrGucker.tv bietet dir eine komfortable Möglichkeit dir deine Streams nach Interesse zusammenzustellen.</description>
<test-app>true</test-app>
</repository>

----
http://tv.sanduhrgucker.de/repository/index.xml
----
<?xml version="1.0" encoding="utf-8" ?>
<apps>
  <app>
    <id>com.sanduhrgucker.news</id>
    <name>news</name>
    <version>1.0</version>
    <description>SandUhrGucker.tv - Nachrichten-Streams</description>
    <thumb>http://tv.sanduhrgucker.de/repository/images/logo.jpg</thumb>
    <repositoryid>com.sanduhrgucker</repositoryid>
    <repository>http://tv.sanduhrgucker.de/repository</repository>
    <media>video</media>
    <author>SandUhrGucker</author>
    <copyright>no</copyright>
    <email>info@SandUhrGucker.de</email>
    <type>rss</type>
    <platform>all</platform>
    <minversion>0.9.7</minversion>
    <url>rss://tv.sanduhrgucker.de/repository/news/news.php</url>
  </app>
</apps>

--
boxeelog:
----
18:44:19 T:2846296944 M:1773109248 DEBUG: Boxee: 07/02/11 17:44:19#DEBUG#bxappboxmanager.cpp:668(BuildRepositoriesApplicationsList)#RequestAppBoxRepositoriesListFromServerTask::BuildRepositoriesApplicationsList - [1/1] - Going to get ApplicationList for [repoId=com.sanduhrgucker][repoName=SandUhrGucker.tv - Deine deutsche Stream-Programmzeitschrift] (repos)
18:44:19 T:2846296944 M:1773109248 DEBUG: Boxee: 07/02/11 17:44:19#DEBUG#bxappboxmanager.cpp:685(BuildRepositoriesApplicationsList)#RequestAppBoxRepositoriesListFromServerTask::BuildRepositoriesApplicationsList - [1/1] - Try to get [strUrl=http://pchotfix.dyndns.org/repository/index.xml] for [repoId=com.sanduhrgucker][repoName=SandUhrGucker.tv - Deine deutsche Stream-Programmzeitschrift] (repos)
18:44:19 T:2846296944 M:1773109248 DEBUG: update ref map. url http://pchotfix.dyndns.org/repository/index.xml new ref_count 1 progress 0 (hcm)
18:44:19 T:2846296944 M:1773109248 DEBUG: CHttpCacheManager::StartCachingURL push http://pchotfix.dyndns.org/repository/index.xml to m_references (hcm)
----

i am running ubuntu 10.4

Issue Links

Activity

Rafael Mizrahi [Boxee] made changes -
Field Original Value New Value
Summary cannot add new reposity cause boxee caches repo-destination online cannot add new repository because boxee caches repo-destination online
Description i had setup a custom reposity on my local server ans used dyndns.
after it completely works, i uploaded it to a live-server and CORRECT ALL links in the repo-files.
now, when i add the new repo-link it allways fails.
the log says it get the repository.xml from the right new server, but also some statements from the old dyndns-target exists.
i tryed to delete the usercache, reinstall boxee, and test it with an different boxee-user.
is it possible that boxee stores/caches repo-infos online?? how to clean/fit that?

here some files:
http://tv.sanduhrgucker.de/repository/repository.xml
----
<?xml version="1.0" encoding="utf-8" ?>
<repository>
<id>com.sanduhrgucker</id>
<url>http://tv.sanduhrgucker.de/repository</url>
<name>SandUhrGucker.tv - Deine deutsche Stream-Programmzeitschrift</name>
<thumb>http://tv.sanduhrgucker.de/repository/images/logo.jpg</thumb>
<description>SandUhrGucker.tv bietet dir eine komfortable Möglichkeit dir deine Streams nach Interesse zusammenzustellen.</description>
<test-app>true</test-app>
</repository>

----
http://tv.sanduhrgucker.de/repository/index.xml
----
<?xml version="1.0" encoding="utf-8" ?>
<apps>
  <app>
    <id>com.sanduhrgucker.news</id>
    <name>news</name>
    <version>1.0</version>
    <description>SandUhrGucker.tv - Nachrichten-Streams</description>
    <thumb>http://tv.sanduhrgucker.de/repository/images/logo.jpg</thumb>
    <repositoryid>com.sanduhrgucker</repositoryid>
    <repository>http://tv.sanduhrgucker.de/repository</repository>
    <media>video</media>
    <author>SandUhrGucker</author>
    <copyright>no</copyright>
    <email>info@SandUhrGucker.de</email>
    <type>rss</type>
    <platform>all</platform>
    <minversion>0.9.7</minversion>
    <url>rss://tv.sanduhrgucker.de/repository/news/news.php</url>
  </app>
</apps>

--
boxeelog:
----
18:44:19 T:2846296944 M:1773109248 DEBUG: Boxee: 07/02/11 17:44:19#DEBUG#bxappboxmanager.cpp:668(BuildRepositoriesApplicationsList)#RequestAppBoxRepositoriesListFromServerTask::BuildRepositoriesApplicationsList - [1/1] - Going to get ApplicationList for [repoId=com.sanduhrgucker][repoName=SandUhrGucker.tv - Deine deutsche Stream-Programmzeitschrift] (repos)
18:44:19 T:2846296944 M:1773109248 DEBUG: Boxee: 07/02/11 17:44:19#DEBUG#bxappboxmanager.cpp:685(BuildRepositoriesApplicationsList)#RequestAppBoxRepositoriesListFromServerTask::BuildRepositoriesApplicationsList - [1/1] - Try to get [strUrl=http://pchotfix.dyndns.org/repository/index.xml] for [repoId=com.sanduhrgucker][repoName=SandUhrGucker.tv - Deine deutsche Stream-Programmzeitschrift] (repos)
18:44:19 T:2846296944 M:1773109248 DEBUG: update ref map. url http://pchotfix.dyndns.org/repository/index.xml new ref_count 1 progress 0 (hcm)
18:44:19 T:2846296944 M:1773109248 DEBUG: CHttpCacheManager::StartCachingURL push http://pchotfix.dyndns.org/repository/index.xml to m_references (hcm)
----

i am running ubuntu 10.4

i had setup a custom repository on my local server ans used dyndns.
after it completely works, i uploaded it to a live-server and CORRECT ALL links in the repo-files.
now, when i add the new repo-link it always fails.
the log says it get the repository.xml from the right new server, but also some statements from the old dyndns-target exists.
i tryed to delete the usercache, reinstall boxee, and test it with an different boxee-user.
is it possible that boxee stores/caches repo-infos online?? how to clean/fit that?

here some files:
http://tv.sanduhrgucker.de/repository/repository.xml
----
<?xml version="1.0" encoding="utf-8" ?>
<repository>
<id>com.sanduhrgucker</id>
<url>http://tv.sanduhrgucker.de/repository</url>
<name>SandUhrGucker.tv - Deine deutsche Stream-Programmzeitschrift</name>
<thumb>http://tv.sanduhrgucker.de/repository/images/logo.jpg</thumb>
<description>SandUhrGucker.tv bietet dir eine komfortable Möglichkeit dir deine Streams nach Interesse zusammenzustellen.</description>
<test-app>true</test-app>
</repository>

----
http://tv.sanduhrgucker.de/repository/index.xml
----
<?xml version="1.0" encoding="utf-8" ?>
<apps>
  <app>
    <id>com.sanduhrgucker.news</id>
    <name>news</name>
    <version>1.0</version>
    <description>SandUhrGucker.tv - Nachrichten-Streams</description>
    <thumb>http://tv.sanduhrgucker.de/repository/images/logo.jpg</thumb>
    <repositoryid>com.sanduhrgucker</repositoryid>
    <repository>http://tv.sanduhrgucker.de/repository</repository>
    <media>video</media>
    <author>SandUhrGucker</author>
    <copyright>no</copyright>
    <email>info@SandUhrGucker.de</email>
    <type>rss</type>
    <platform>all</platform>
    <minversion>0.9.7</minversion>
    <url>rss://tv.sanduhrgucker.de/repository/news/news.php</url>
  </app>
</apps>

--
boxeelog:
----
18:44:19 T:2846296944 M:1773109248 DEBUG: Boxee: 07/02/11 17:44:19#DEBUG#bxappboxmanager.cpp:668(BuildRepositoriesApplicationsList)#RequestAppBoxRepositoriesListFromServerTask::BuildRepositoriesApplicationsList - [1/1] - Going to get ApplicationList for [repoId=com.sanduhrgucker][repoName=SandUhrGucker.tv - Deine deutsche Stream-Programmzeitschrift] (repos)
18:44:19 T:2846296944 M:1773109248 DEBUG: Boxee: 07/02/11 17:44:19#DEBUG#bxappboxmanager.cpp:685(BuildRepositoriesApplicationsList)#RequestAppBoxRepositoriesListFromServerTask::BuildRepositoriesApplicationsList - [1/1] - Try to get [strUrl=http://pchotfix.dyndns.org/repository/index.xml] for [repoId=com.sanduhrgucker][repoName=SandUhrGucker.tv - Deine deutsche Stream-Programmzeitschrift] (repos)
18:44:19 T:2846296944 M:1773109248 DEBUG: update ref map. url http://pchotfix.dyndns.org/repository/index.xml new ref_count 1 progress 0 (hcm)
18:44:19 T:2846296944 M:1773109248 DEBUG: CHttpCacheManager::StartCachingURL push http://pchotfix.dyndns.org/repository/index.xml to m_references (hcm)
----

i am running ubuntu 10.4

Rafael Mizrahi [Boxee] made changes -
Assignee rafael [ rafael ]
Rafael Mizrahi [Boxee] added a comment -
yes, your defined third party repositories information is stored online with your account details.

try deleting
\BOXEE\userdata\cache
\BOXEE\userdata\profiles\USERNAME\cache

what do you mean by "also some statements from the old dyndns-target exists" ?
what is the exact problem ?
Rafael Mizrahi [Boxee] made changes -
Link This issue is related to BOXEE-4199 [ BOXEE-4199 ]
Rafael Mizrahi [Boxee] made changes -
Fix Version/s Backlog [ 11122 ]
bububu added a comment -
Hi Rafael!
as i wrote i already deleted
\BOXEE\userdata\cache
\BOXEE\userdata\profiles\USERNAME\cache

and i mean there must not exists any entrys to the old repository-destination when i add the new repository (on absolute different server, with NONE link to the old one). but the logfile shows new entrys to the old. i think boxee get the old information from a online-cache - not from my local pc.

;-) sorry about my bad english.


Rene'
Rafael Mizrahi [Boxee] added a comment -
im closing this issue as duplicate of BOXEE-4199
please vote and add your information in the linked issue
Rafael Mizrahi [Boxee] made changes -
Status Open [ 1 ] Resolved [ 5 ]
Resolution Duplicate [ 3 ]
Rafael Mizrahi [Boxee] made changes -
Status Resolved [ 5 ] Closed [ 6 ]
bububu made changes -
Comment [ ps: i think you can verify the problem by adding my repo: http://tv.sanduhrgucker.de/repository
your debug-logfile may show you that boxee try to connect my old (lokal) repo "http://pchotfix.dyndns.org/repository"
as you can see on the repository-files
http://tv.sanduhrgucker.de/repository/repository.xml
http://tv.sanduhrgucker.de/repository/index.xml
http://tv.sanduhrgucker.de/repository/download/...

there are no links to the old repo inside.

]
Yuval Tal [Boxee] added a comment -
I will ask rob to help.
Tatum Lade [Boxee] made changes -
Assignee rafael [ rafael ] tatum [ tatum ]
Tatum Lade [Boxee] added a comment -
This should be resolved. Fixed on the server.
Rafael Mizrahi [Boxee] added a comment -
closed as duplicate of BOXEE-4199
Rafael Mizrahi [Boxee] made changes -
Version 0.9.22
Rafael Mizrahi [Boxee] made changes -
Severity Major
Transition Time In Source Status Execution Times Last Executer Last Execution Date
Open Resolved
38m 13s 1 Rafael Mizrahi [Boxee] 07/Feb/11 1:28 PM
Resolved Closed Closed
8s 1 Rafael Mizrahi [Boxee] 07/Feb/11 1:29 PM

People

Vote (0)
Watch (0)

Dates

  • Created:
    Updated:
    Resolved: