Boxee

Leanback menu button should not exit the app

Details

  • Severity:
    Major
  • Number of attachments:
    0

Description

In Leanback, pressing the Menu button in any state exits the app and loses all of your searches. This completely breaks with the UI-design of Boxee where in most places pressing Menu will dismiss the controls on the screen. I realize that Leanback has it's own look-and-feel, so I propose a compromise: add an "Are you sure you want to exit Leanback?" dialog when Menu is pressed. Could we also perhaps have a little bit of the Boxee behavior as well? If there's any type of Leanback control visible, pressing Menu will dismiss it. Pressing menu on a screen with no controls will either ask Are you sure or exit the app directly. Actually, the problem of menu always exiting usually occurs when I'm trying to dismiss the controls and forget to do the non-standard Up/Down.

Issue Links

Activity

Harvey Chapman added a comment -
It's not a duplicate, but they are related. BOXEE-7829 is a much bigger issue. I'm advocating for Leanback to better handle the menu button.
Shawn Rieger [Boxee] added a comment -
any change here will not be a change to leanback, but a client change that effects all web applications.
Shawn Rieger [Boxee] added a comment -
the fact that there is no menu popup or leave/stay dialog when you exit leanback has absolutely nothing to do with youtube leanback and everything to do with the browser, this is a global issue. we are currently in discussion on the best approach to handle this scenario. please post any suggestions you may have on what should happen when you hit the menu button on the linked ticked. thanks!
Rafael Mizrahi [Boxee] added a comment -
closed as duplicate of BOXEE-7829
please vote and comment on the linked issue

People

Vote (1)
Watch (2)

Dates

  • Created:
    Updated:
    Resolved: