Boxee

Hangs when doing a manual identify

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: P1 P1
  • Resolution: Duplicate
  • Fix Version/s: None
  • Labels:
    None
  • Severity:
    Critical
  • Version:
    1.1.1.19092
  • Operating System:
    Boxee Box
  • Number of attachments:
    2

Description

Whenever I press identify for a file the box hangs. It doesn't matter if it is from within either shows, movies or from the unidentified files list.

Issue Links

Activity

Rafael Mizrahi [Boxee] added a comment - 22/May/11 4:34 AM
in case of a hang there is no access to the box through port 8080
To get a log for a hang situation, configure boxee to send the logs to a syslog server.
Boxee will send every log line to the syslog server and when the hang occurs, we will be able to see the last log lines at the syslog.

* Windows: Open source SysLog daemon for windows
http://www.aonaware.com/syslog.htm

* Mac OSX: To enable your OSX system to receive network syslog submissions edit:
edit /System/Library/LaunchDaemons/com.apple.syslogd.plist

Uncomment the paragraph commented:

<!--
Un-comment the following lines to enable the network syslog protocol listener.
-->

<key>NetworkListener</key>
<dict>
<key>SockServiceName</key>
<string>syslog</string>
<key>SockType</key>
<string>dgram</string>
</dict>

Then execute the following commands:
sudo launchctl unload /System/Library/LaunchDaemons/com.apple.syslogd.plist
sudo launchctl load /System/Library/LaunchDaemons/com.apple.syslogd.plist

If you have firewall enabled make sure to allow the traffic for UDP 514
Robert Ylvestedt added a comment - 28/May/11 7:35 PM
I have done some more testing this week. I did a reset of the settings from the recovery menu and many of the problems went away. This one sort of went away. I discovered when it actually happens. It is for instance when a scanning of source "lock-ups" in a continius loop. Also the box acts very unstable when in said loop. I have learned not to do manual identifys whenever a scan is running because when the box is idle everything works as it should.
Robert Ylvestedt added a comment - 31/May/11 11:35 AM - edited
I'm just getting error message when trying to install the Syslog WEB Client. It says the installer was interrupted and needs to be restarted. This happens everytime I try to start it. I have followed the installation instructions perfectly.

I have managed to get around the problem with an IIS6 workaround. I have setup everything according to instructions, but I can't login to the log..

"Cannot open database "syslog" requested by the login. The login failed."
Rafael Mizrahi [Boxee] added a comment - 01/Jun/11 6:05 AM
Hi Robert, I'm sorry, but I cannot support the issues you have with syslog.
and I am not familiar with the problem you experience.
personally, I am using the source code. maybe its because I could not install it properly :)
I am attaching the binaries of the syslog im using. i've also added a save to "c:\syslog.csv" menu item
Robert Ylvestedt added a comment - 01/Jun/11 2:36 PM
That did not work for me either.. Got some error message stating that normally only one user is allowed something, something, dark side :)
Robert Ylvestedt added a comment - 01/Jun/11 4:52 PM
Success!! Had to switch to another syslog application, which I can recommend for users of Win7, Syslog Watcher 4 (http://www.snmpsoft.com/syslogwatcher/syslog-server.html). It worked right out of the box :)
Will upload the new log as soon I figure out how to save it ;-) You wanted it in csv format right?
Robert Ylvestedt added a comment - 01/Jun/11 5:33 PM
Couldn't save the log for some reason.. But good news is that I found out what caused the "one user" error before and could now use your app to log.. And here it is :)

From the moment I press identify from the unidentified file list the GUI locks up. The box continued to pass logs though, as I could actually watch it continue working in syslog..

Oh, and thank you for the syslog program, now I feel like I can help more easily with bug hunting :)
Robert Ylvestedt added a comment - 01/Jun/11 6:20 PM
I found in the log a filerar error that I have fixed. After unpacking that one the box continued to match files. Will see later if that caused the identify to hang.
Rafael Mizrahi [Boxee] added a comment - 02/Jun/11 5:05 AM
Im looking at your log syslog.csv (890 kB) 01/Jun/11 5:33 PM
I see that at 21:08:48 you are manually identifying an archived movie : Appaloosa
and the log continues until 21:25:42
so, during all this time, boxee was not responsive ?
Robert Ylvestedt added a comment - 02/Jun/11 2:12 PM
Exactly.. I could also see when looking at syslog at the computer that it continued to send data even when the box was locked up.. I believe if the reason for this is solved it will also solve the other bugs I reported.

For example, before I fixed the filerar error:
It hanged when doing manual ID
it hanged if I tried to shut down the box.
No movie or show would start (the circle continue to spin forever)
it restarted boxee app when I tried to re-scan a source manually.

Now, after filerar fix, everything of above works as it seems.

This points out even more the suggestion I made in the unidentified files bug report, to have it move problematic files to a special section of the unidentified files list and then move on with its tasks.
Rafael Mizrahi [Boxee] added a comment - 28/Jun/11 3:31 AM
thank you robert for the investigation.
issue closed as duplicate of BOXEE-8055
please vote and comment at the linked issue.

People

Vote (1)
Watch (1)

Dates

  • Created:
    19/May/11 7:07 PM
    Updated:
    12/Jul/11 9:54 AM
    Resolved:
    28/Jun/11 3:31 AM