Knowledge Base/Boxee PC Software/Setting Up Boxee

I can't get Boxee to run full screen on my external monitor or TV

boxee tv
posted this on Jun-29 2009 08:26 am

If you are running Boxee for Windows on your laptop, and can't seem to run Boxee full screen on your external monitor or TV connected to the laptop, then be calm. This is a known issue we are hoping to fix in one of our next versions.

In the meantime, there is a workaround that does the trick:

  1. Connect the laptop to the TV or external monitor.
  2. Define the TV or external monitor as your Primary Monitor (click here for Windows XP instructions, and here for Windows Vista instructions).
  3. Run Boxee.

Boxee's default is to start in full screen on the primary monitor, so after defining the external monitor or TV as the primary one, you should have Boxee running in full screen mode on that monitor.

 

Comments latest first

Hussein Hill
boxee

I agree WinShiftArrow is the best tip I've seen in a long time thanks.

Regarding Boxee launching on the non-primary screen (my HDTV) non of the above reasonable solutions worked on Win7 64.

Boxee PLEASE fix this!!! 

May-02 2010 02:14 am.
Robert Andersson
boxee

"Yeah, I can't get this working for me either. For those people windowing, moving then maximizing again, there is an easier way if you are using windows 7. Just hit: windowskey+shift+direction of secondary monitor after boxee boots up."

 

Best tip so far!!!!

Apr-26 2010 12:52 pm.
Aaron Canaday
boxee

Yeah, I can't get this working for me either. For those people windowing, moving then maximizing again, there is an easier way if you are using windows 7. Just hit: windowskey+shift+direction of secondary monitor after boxee boots up.

Apr-04 2010 07:34 pm.
Justin Boughton
boxee

This drives me nuts! I'm running 3 screens, and I can't ever get Boxee to open on the screen I use for watching my movies in bed. Please devs, please find a way to make this work. And some more WMC remote support would be AWESOME too.

Mar-28 2010 01:32 am.
Emilio Tantor
boxee

Instructions suck if they aren't complete, I suppose.  To create a macro in Event Ghost (Step 2 from above):

1.  Download (Free) Event Ghost http://www.eventghost.org  -- Install

2.  File > New

3.  On the right hand side, under Configuration Tree, there should be "AutoStart" (Green Arrow)

4.  Right Click, Select "Add Plugin".  Select "Microsoft MCE Remote" from the "Remote Receivers" section (top folder in tree)

5.  Right Click, Select "Add Plugin".  Select "Task Create/Switch Events" from the "Other" section (bottom folder in tree)

6.  Right Click, Select "Add Macro".  Select from "System", "Start Application".  Navigate to Boxee.exe (C:\Program Files\Boxee\Boxee.exe, or whatever).  You can add -fs -p if you want, but you don't need to.  I don't use any command line parameters this way.  Just start it.   

7.  Right Click, Select, "Add Event".  In the small dialog box, you will enter the Windows MCE Remote "code" that represents the MCE Remote button you wish to "Start Boxee" when pressed.  In otherwords, whatever button you want to start Boxee, this is where you enter that button's IR code.  For example, codes for the Green button (the little one, not the big windows one), the Teletext, and LiveTV buttons are listed below:

MceRemote.Green

MceRemote.Teletext

MceRemote.LiveTV

8.  Collect that code, from your chosen button, and write it down in the dialog box.  Write it as-is, for example, "MceRemote.Teletext" (without quotations). Now you are declaring the event "Teletext" button press to execute Boxee application. 

9.  Save your Event Ghost configuration file.  It is native .xml format. 

10.  With Event Ghost open, hit the button on your remote.  You should see Event Ghost trigger, and if all is well, execute Boxee. 

 

Start at step #4 above to have it start on Extended Display, in full screen, every time you hit your remote button.

 

Mar-08 2010 07:25 pm.
Emilio Tantor
boxee

There is another way to solve this problem, to run Boxee on a Secondary/Extended display.  Using EventGhost.

 

Most of you, like me, already have EG running anyway, and likely are using EG to help start whatever Home Theater apps (like Boxee) you have directly from your remote (Logi Harmony, etc etc).  This uses Event Ghost, and some specific actions to essentially move the Boxee window from your Primary display to the Secondary display, and maximize it.

 

1.  In Boxee set appearance to full screen on your primary display.

2.  In Event Ghost, if you do not have an auto-start Macro item for Boxee, make one.  You can use EG help to learn about Macros, or Google "Event Ghost XBMC".  Or something similar, there is tons of info out there, and this is easy. 

3.  Now that you have a Macro in EG to start Boxee (hopefully tied to a button on your WinMCE Remote, or at least a keyboard button), add some new actions.

4.  Add Action, "Wait".  This is under Event Ghost actions, you can supply number of seconds.  I use 2.0 seconds.

5.  Add Action, "Find Window".  This is under System actions.  You can supply which window to find.  It is very easy.  If you have Boxee open, you can drag the "window finder" onto that window and it will fill out the rest.  Run test to make sure you are finding the correct window.

6.  Add action, "Bring to Front".  This is good to make the window active for the next actions:

7.  Add action, "Move Window".  You supply the X and Y coordinates.  Supply coordinates such that the window will be on your Secondary Display!  Viola, are you seeing what we're doing?  Basically you can test by moving the little box around to see what X & Y values to select.  Once you have those, add one file action:

8.  Add action, "Maximize". 

 

You have just created a Macro to run Boxee from your remote control, find the window, move the window, and maximize the window on your secondary display.  Anytime you hit the button on your remote (or whatever) to run Boxee, it'll be on your secondary display, in full screen. 

 

Hope this helps somebody.  Took me about 15min of fooling with other solutions on Win Vista 64bit to finally decide this was best and most efficient.  YMMV. 

Mar-08 2010 05:14 pm.
Nicolas Kolnes-Cassis
boxee

This problem still active? I just realized that my primary dislpay is set to Display Identity #2. My theory is that Boxee wants to open in Screen #2 so it thinks that the primary screen is #2.

I guess this is a bug, anyone know if Boxee is working on this?

Mar-04 2010 09:41 pm.
kinto bean
boxee

i'm on a mac with 2 monitors and by default boxee starts up on your primary monitor so it took me a minute to figure this out.  

go to settings, appearance, screen, resolution, choose #2 with the arrows, then hit the test & apply resolution, then ok.

=)

Feb-26 2010 10:49 pm.
Becca Sill
boxee
This may very well be wrong as i haven't tried it yet, but I run windows 7 on a Dell laptop and pressing f1 allows me to choose which screen I want and I can choose a large screen as my primary, only screen. Don't know if this is a Dell only option or all windows 7. Noob here.
Feb-09 2010 12:12 pm.
m klein
boxee
I've discovered a workaround for those running a secondary display. This works for me with my video card connected to my HDTV via HDMI (secondary @ 1080P) while my monitor is connected via RGB (primary at 1650x1050). I use Ultramon to switch between primary and secondary monitor arrangements as well as to disable and re-enable displays with little effort. Please note, I am running Windows 7 64-bit with an Nvidia graphics card (9-something series) and Ultramon 3.0.x. For this workaround, you must make an Ultramon shortcut. Do this by right clicking on the Ultramon icon in the tray. Select Shortcuts --> New Shortcut Browse to your Boxee executable, typically, Program Files (x86)/Boxee Click Next Check "use custom settings" and choose Monitor 2 Click Next Check "use custom settings" Select Monitor 2 (in this instance my TV) Check "enabled" and "primary" (also, if you want your displays to return to their usual arrangement after you exit Boxee, check "restore original display settings when application exits") Click Next Name your shortcut and choose a place or places for it to be located. Click Finish What this does is create a link to an Ultramon shortcut which has all the configuration settings you just entered. The last thing you want to make sure you do is to have Boxee itself open on Display 1 @1080P (or whatever your second display's resolution runs at). Now, whenever you click the Ultramon link, the program will intercede on your behalf, change the display setting automatically and then Boxee, not knowing the difference, will open on the new primary display (which is really your secondary). This worked for me (everything else suggested, didn't) and seems the most elegant solution until the program itself is fixed to open automatically on secondary displays at a pre-defined resolution.
Feb-08 2010 10:50 pm.
Samuel Goh
boxee
I couldn't get my TV to be the secondary monitor either. I resorted to setting both screens as mirror displays. Not exactly what I was hoping, but it works for me, at least until Boxee updates with that display option.
Feb-07 2010 11:21 pm.
Aaron Vandermause
boxee

Ricky, your method did not work for me. I'm using a Vista based laptop and Boxee refuses to open on the extended desktop despite all attempts. I can open it on the primary, switch to windowed mode, drag it to the secondary screen, then maximize it...but that is seemingly the only way to do it.

I don't understand why there can't just be an option in properties to select which display Boxee should use...

Jan-21 2010 04:29 pm.
Ricky Wilson
boxee

Before someone asks, TCV is a typo, I meant TV/Secondary Monitor

Jan-11 2010 03:54 pm.
Ricky Wilson
boxee

Guys really? This method below works for any program you want to open on another montitor by default. You may need admin privledges for it to stick, maybe not.

EZ Way to have Boxee on your secondary monitor (and I'm on Win7 64 it works fine, aside from some playing issues it always opens on my 61 inch): Open Boxee, GO to Settings and Appearance, change the Resolution to "Windowed".  Right click and Exit out of Boxee. Now open Boxee and drag it to your seconday monitor and maximize it. Change the setting from windowed to the resolution for your TV: Fullscreen (non-HD is ususally 480i in America.) Right Click and exit. Now everytime you open Boxee it will open on your TCV/Secondary monitor.

 

YW

Jan-11 2010 03:53 pm.
Robert Paege
boxee

Boxee works great on my Mac with a TV attached as a second monitor.  It sees the TV as resolution #2 (I have it set at 800x600, but it could also be set to whatever I want), and I simply select that and voilĂ !  Boxee on my TV.  I can also toggle between the TV and my main monitor with Boxee in a window by pressing command-f.

Dec-12 2009 09:18 pm.
Gerry Creighton
boxee

I agree with Kokuryu, on a Mac, a setting in the Boxee settings window for video should allow the choice for which monitor to use if the user has multiple monitors OR a TV connected as a second monitor (my case). I also had an issue with audio, digital output was selected but that's not was was playing through my receiver. 

Dec-12 2009 06:13 pm.
Kokuryu Tenchi
boxee

This is not good.  Boxee for the MAC should be able to detect the multiple monitors attached and give a selection list of the monitors to use for Boxee to display on.  Every other MAC video product out there has that.  But not Boxee.  My environment is multi-monitor.  Boxee should support this properly, rather than giving excuses.

Oct-30 2009 08:00 pm.
dave ballard
boxee

im on w7 and tried this switch and still opens on the primary monitor in fs, any other thoughts?  if not i'll have to pass on boxee, seems like it should be a easy fix and should at least be able to run in a normal windowed mode..

Sep-22 2009 09:00 pm.
Michael
boxee

Do what emmet says, then close boxee, right click the boxee icon ->properties and edit the start up string: replace -p flag with -s. boxee will now start in full screen on your secondary.

Jul-29 2009 11:39 pm.
Emmett Logan
boxee

This worked for me.

Please connect your HDTV and then open Boxee (make sure boxee is closed until you connect the second screen) select Settings>Appearance>Screen>Resolution > appropriate setting with (full screen #2) and then select "Test Resolution".

 

Jul-18 2009 01:12 pm.
erik b
boxee

Try starting up (or waking from sleep) your laptop while it is closed.  At least on Apple laptops (older macbooks in particular) external screens with bigger resolutions are thus recognized while they are not when the laptop is open.

Jul-18 2009 10:13 am.
s1mon
boxee

With most laptops, it is impossible to define an external monitor as the primary monitor, because the laptop's own screen has to be the primary one. So is there another way to start up and run boxee full screen on your external monitor? 

Jul-16 2009 05:29 pm.